summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-02-04 13:46:57 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-02-04 13:48:53 -0500
commit2e97b8deb6243c68f61728efef005f48f62ba0e1 (patch)
tree3810eac781f77d6ef588f62115d76c7918968038 /sci-libs/fplll
parentsci-libs/fplll: add myself and François as maintainers. (diff)
downloadgentoo-2e97b8deb6243c68f61728efef005f48f62ba0e1.tar.gz
gentoo-2e97b8deb6243c68f61728efef005f48f62ba0e1.tar.bz2
gentoo-2e97b8deb6243c68f61728efef005f48f62ba0e1.zip
sci-libs/fplll: new version 5.3.2.
This new version is based on François's v5.3.1 ebuild in the sage-on-gentoo overlay. I investigated adding support for the sci-libs/qd package, but the build system is a bit weird about it at the moment, so ultimately there's only one important change: I've bumped the subslot to match the first component (6) of the soname. The EAPI was also updated to 7 uneventfully. Closes: https://bugs.gentoo.org/708198 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/fplll')
-rw-r--r--sci-libs/fplll/Manifest1
-rw-r--r--sci-libs/fplll/fplll-5.3.2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/sci-libs/fplll/Manifest b/sci-libs/fplll/Manifest
index 5f37068f156e..ea33ec4e94bc 100644
--- a/sci-libs/fplll/Manifest
+++ b/sci-libs/fplll/Manifest
@@ -1 +1,2 @@
+DIST fplll-5.3.2.tar.gz 1284989 BLAKE2B 66d022c1a6acb3f029c871bebf4925ec5f9447af71829c6d52f2065155bf75f075965a41918722d095546ca18e8e87a85f181a76f5e42abd20c8de8165210bab SHA512 eacd990c468b1d919e1d6cc04f99656d982d5a3807970e0a1dd910a2703eb5b8eff913bc5c0e45790a547bb7aa71189fb9022024186bb84ee04d8602c9980ac2
DIST libfplll-4.0.4.tar.gz 413519 BLAKE2B afeea5a813d3d5b1b7fe3e81d5a8e9bce66ee4f8a3d265dacaa0ba7ff2f632f0f533182027322e2fd17645f5bc5816b266b167da0e36a00a38f73e794e22a522 SHA512 81cf61118f0dadca8fd82cc58df2fb5f0dc3ddd15a9b5de95a7777e0ece77d8f6a6d50d14ba7fdd6be6697cf375fac2e60792c94cc65f5a181c427dea84d552d
diff --git a/sci-libs/fplll/fplll-5.3.2.ebuild b/sci-libs/fplll/fplll-5.3.2.ebuild
new file mode 100644
index 000000000000..13f7fa295ee2
--- /dev/null
+++ b/sci-libs/fplll/fplll-5.3.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Implementations of the floating-point LLL reduction algorithm"
+HOMEPAGE="https://github.com/fplll/fplll"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/6"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+BDEPEND=""
+DEPEND="dev-libs/gmp:0
+ dev-libs/mpfr:0"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # Support for --with-qd is problematic at the moment.
+ # https://github.com/fplll/fplll/issues/405
+ econf $(use_enable static-libs static)
+}
+
+src_install(){
+ default
+ find "${ED}" -name '*.la' -delete || die
+}