summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/coinor-smi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/coinor-smi')
-rw-r--r--sci-libs/coinor-smi/Manifest1
-rw-r--r--sci-libs/coinor-smi/coinor-smi-0.93.4.ebuild71
-rw-r--r--sci-libs/coinor-smi/metadata.xml18
3 files changed, 90 insertions, 0 deletions
diff --git a/sci-libs/coinor-smi/Manifest b/sci-libs/coinor-smi/Manifest
new file mode 100644
index 000000000000..16f15da5c957
--- /dev/null
+++ b/sci-libs/coinor-smi/Manifest
@@ -0,0 +1 @@
+DIST Smi-0.93.4.tgz 4907130 SHA256 e63ee0f6f6fd20cd7481d7c88fa60980fc1ce8334032a8f4baaad3a88e63004b SHA512 9439b7421475cf5d0c85f529305657e04d1ebb3eca28399b0df0352b52df315e9dceb3f1410ada0b7a6f9447b0e383116fb208d6447994ce1611f019fcace007 WHIRLPOOL a6f6814420111b2e6cf6ae6251aef44f327372bcbe4dff1f9159f95ec4967a77d7912c10d503f480da91143a94a552993a59b9931e893e6c32c21956f93786e9
diff --git a/sci-libs/coinor-smi/coinor-smi-0.93.4.ebuild b/sci-libs/coinor-smi/coinor-smi-0.93.4.ebuild
new file mode 100644
index 000000000000..c43e25ff950c
--- /dev/null
+++ b/sci-libs/coinor-smi/coinor-smi-0.93.4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=yes
+inherit autotools-utils multilib
+
+MYPN=Smi
+
+DESCRIPTION="COIN-OR Stochastic modelling interface"
+HOMEPAGE="https://projects.coin-or.org/Smi/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="CPL-1.0"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs test"
+
+RDEPEND="
+ sci-libs/coinor-cbc:=
+ sci-libs/coinor-cgl:=
+ sci-libs/coinor-clp:=
+ sci-libs/coinor-flopcpp:=
+ sci-libs/coinor-osi:=
+ sci-libs/coinor-utils:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+ test? ( sci-libs/coinor-sample )"
+
+S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
+
+src_prepare() {
+ # needed for the --with-coin-instdir
+ dodir /usr
+ sed -i \
+ -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ configure || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-dependency-linking
+ --with-coin-instdir="${ED}"/usr
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ if use doc; then
+ cd "${WORKDIR}/${MYPN}-${PV}/doxydoc" || die
+ doxygen doxygen.conf || die
+ fi
+}
+
+src_test() {
+ autotools-utils_src_test test
+}
+
+src_install() {
+ use doc && HTML_DOC=("${WORKDIR}/${MYPN}-${PV}/doxydoc/html/")
+ autotools-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples flopcpp_examples
+ fi
+}
diff --git a/sci-libs/coinor-smi/metadata.xml b/sci-libs/coinor-smi/metadata.xml
new file mode 100644
index 000000000000..551066284b8a
--- /dev/null
+++ b/sci-libs/coinor-smi/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ The COIN-OR Stochastic Modeling Interface (SMI) is an interface for
+ problems in which uncertainty and optimization appear
+ together. There are many modeling and algorithmic approaches that
+ could belong here, like: recourse programming, chance constrained
+ programming, stochastic control and dynamic programming, robust
+ optimization, etc, etc. SMI is intended to be like OSI in the sense
+ that an SmiXX object is an implementation derived from a base class
+ that takes care of a number of commonly encountered programming
+ issues, like handling probability distributions, managing problem
+ generation, interacting with solvers to obtain solution information,
+ etc.
+</longdescription>
+</pkgmetadata>