summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-07 19:59:27 +0100
committerSam James <sam@gentoo.org>2022-10-07 20:00:06 +0100
commit69c1639bc9955366554f4de898f2e5d3b1faf383 (patch)
tree46dc71b39ed296676658be3249699e184cbc2cde /sci-libs/cartopy
parentdev-tex/tth: add changelog link (diff)
downloadgentoo-69c1639bc9955366554f4de898f2e5d3b1faf383.tar.gz
gentoo-69c1639bc9955366554f4de898f2e5d3b1faf383.tar.bz2
gentoo-69c1639bc9955366554f4de898f2e5d3b1faf383.zip
sci-libs/cartopy: switch to single-impl Python
This is needed because gdal is single impl now (b/c of various bugs we hit). Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/cartopy')
-rw-r--r--sci-libs/cartopy/cartopy-0.20.3-r1.ebuild (renamed from sci-libs/cartopy/cartopy-0.20.3.ebuild)63
1 files changed, 35 insertions, 28 deletions
diff --git a/sci-libs/cartopy/cartopy-0.20.3.ebuild b/sci-libs/cartopy/cartopy-0.20.3-r1.ebuild
index 8748a3e391ab..4555f424ccdf 100644
--- a/sci-libs/cartopy/cartopy-0.20.3.ebuild
+++ b/sci-libs/cartopy/cartopy-0.20.3-r1.ebuild
@@ -3,7 +3,8 @@
EAPI=8
-PYTHON_COMPAT=( python3_{7..10} )
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1 virtualx
@@ -13,6 +14,7 @@ MY_P=${PN}-${MY_PV}
DESCRIPTION="Python package for geospatial data processing and analysis"
HOMEPAGE="https://scitools.org.uk/cartopy"
SRC_URI="https://github.com/SciTools/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
LICENSE="LGPL-3"
SLOT="0"
@@ -24,48 +26,53 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
${PYTHON_DEPS}
sci-libs/geos
- dev-python/numpy[${PYTHON_USEDEP}]
- sci-libs/pyshp[${PYTHON_USEDEP}]
- dev-python/shapely[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/pillow[jpeg,${PYTHON_USEDEP}]
- sci-libs/gdal[python,${PYTHON_USEDEP}]
- dev-python/pyproj[${PYTHON_USEDEP}]
>=sci-libs/proj-8
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/shapely[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/pillow[jpeg,${PYTHON_USEDEP}]
+ dev-python/pyproj[${PYTHON_USEDEP}]
+ sci-libs/gdal[python,${PYTHON_USEDEP}]
+ sci-libs/pyshp[${PYTHON_USEDEP}]
+ ')
"
-
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ ')
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/flufl-lock[${PYTHON_USEDEP}]
+ ')
+ )
"
distutils_enable_tests pytest
-DEPEND+="test? (
- dev-python/filelock[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/flufl-lock[$PYTHON_USEDEP]
- )"
-
-S="${WORKDIR}"/${MY_P}
-
python_prepare_all() {
export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
- # drop test file requiring network access, which got not covered by markers
+
+ # Drop test file requiring network access, which got not covered by markers
rm "${S}"/lib/cartopy/tests/mpl/test_crs.py || die
rm "${S}"/lib/cartopy/tests/mpl/test_gridliner.py || die
- # prepare matplotlib backend for test suite
+
+ # Prepare matplotlib backend for test suite
export MPLCONFIGDIR="${T}"
echo "backend : Agg" > "${MPLCONFIGDIR}"/matplotlibrc || die
+
distutils-r1_python_prepare_all
}
python_test() {
- cd "${BUILD_DIR}"
- # drop all tests needing network access
+ cd "${BUILD_DIR}" || die
+
+ # Drop all tests needing network access
virtx pytest -vv -m "not network and not natural_earth" || die "test failed"
}