summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2016-03-31 01:20:52 +0200
committerMarc Schiffbauer <mschiff@gentoo.org>2016-03-31 01:25:46 +0200
commit301f4271d9e13e1c20bdd13ae82f63fb5db62674 (patch)
treedb534a37be9d650d142a0372eae4acfbc80ae578 /sci-geosciences/opencpn-plugin-weatherfax
parentsci-geosciences/opencpn-plugin-weather_routing: add live version (diff)
downloadgentoo-301f4271d9e13e1c20bdd13ae82f63fb5db62674.tar.gz
gentoo-301f4271d9e13e1c20bdd13ae82f63fb5db62674.tar.bz2
gentoo-301f4271d9e13e1c20bdd13ae82f63fb5db62674.zip
sci-geosciences/opencpn-plugin-weatherfax: add live version
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-geosciences/opencpn-plugin-weatherfax')
-rw-r--r--sci-geosciences/opencpn-plugin-weatherfax/opencpn-plugin-weatherfax-9999.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-weatherfax/opencpn-plugin-weatherfax-9999.ebuild b/sci-geosciences/opencpn-plugin-weatherfax/opencpn-plugin-weatherfax-9999.ebuild
new file mode 100644
index 000000000000..db78051cef1e
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-weatherfax/opencpn-plugin-weatherfax-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="weatherfax_pi"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/seandepagnier/${MY_PN}.git"
+ inherit git-r3 cmake-utils wxwidgets
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/seandepagnier/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ "
+ inherit cmake-utils wxwidgets
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Weatherfax Plugin for OpenCPN"
+HOMEPAGE="https://github.com/seandepagnier/weatherfax_pi"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}