summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-27 21:59:06 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-02-01 20:26:36 +0100
commit8905bcd7f8606448a288c413513c56011471b72b (patch)
tree9ab0ec6862102a09a56b59c249ce9cda5d6333f7 /sci-electronics/gazebo
parentdev-libs/s2n: drop 0.10.21-r1 (diff)
downloadgentoo-8905bcd7f8606448a288c413513c56011471b72b.tar.gz
gentoo-8905bcd7f8606448a288c413513c56011471b72b.tar.bz2
gentoo-8905bcd7f8606448a288c413513c56011471b72b.zip
sci-electronics/gazebo: drop 11.10.2, 11.11.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-electronics/gazebo')
-rw-r--r--sci-electronics/gazebo/Manifest2
-rw-r--r--sci-electronics/gazebo/files/ffmpeg4.patch16
-rw-r--r--sci-electronics/gazebo/files/ffmpeg5.patch137
-rw-r--r--sci-electronics/gazebo/gazebo-11.10.2.ebuild85
-rw-r--r--sci-electronics/gazebo/gazebo-11.11.0.ebuild83
5 files changed, 0 insertions, 323 deletions
diff --git a/sci-electronics/gazebo/Manifest b/sci-electronics/gazebo/Manifest
index 51f9bccaff8e..b778335ec365 100644
--- a/sci-electronics/gazebo/Manifest
+++ b/sci-electronics/gazebo/Manifest
@@ -1,3 +1 @@
-DIST gazebo-11.10.2.tar.bz2 56496495 BLAKE2B 09bf370531214e9567d961445797cb50c9e5a81a405720c580d13e6b33029a63dd2cd9930dcbd239c1bf9091a9d5b092bfdef77b0b3524d281a10549e22e7c9a SHA512 8900c483f63cedb8543cfe718b336e3ec372fc0dc3d47ac9cd5378987fae634f16911d3c91fdf70add93b4a090e92f3558beec6c1277e1ba109652dcaf049ac2
-DIST gazebo-11.11.0.tar.bz2 56505651 BLAKE2B c3f63a1ee128fd86be914ba9ad7567d0adf337d82772184bbc362373083ad2b79f1172998182a70faf4127fe6f5996d6946e79927c40a384ac5e0eef3b7799c9 SHA512 f9062a54ee4e252219a246124ad0a22570e12f34f7bced8910a14b96541b16337efbba0f824b0ba70adf91d41acfc407eb0cdb19bbd7272151ef9723acc48882
DIST gazebo-11.12.0.tar.bz2 56542859 BLAKE2B f2da8371fa4655cc831401fcf6ceec8c82d507a93515762c078ac20a78cb4b739c9f373ef53bebc71b5d7e1c1cf4b98928b3e855fca6943a09da554ee19df1cb SHA512 8f60d432ab07084951bbe31c632f04f2fa11500441fb81fe27078a5cb5b67ba681889e1079844d44a5a30df562797d51683fd674942db9fd8c4d853e3e2c5d3e
diff --git a/sci-electronics/gazebo/files/ffmpeg4.patch b/sci-electronics/gazebo/files/ffmpeg4.patch
deleted file mode 100644
index 7b7c8d7270fd..000000000000
--- a/sci-electronics/gazebo/files/ffmpeg4.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Index: gazebo-11.10.1/gazebo/common/VideoEncoder.cc
-===================================================================
---- gazebo-11.10.1.orig/gazebo/common/VideoEncoder.cc
-+++ gazebo-11.10.1/gazebo/common/VideoEncoder.cc
-@@ -224,7 +224,10 @@ bool VideoEncoder::Start(const std::stri
-
- // The remainder of this function handles FFMPEG initialization of a video
- // stream
-- const AVOutputFormat *outputFormat = nullptr;
-+#if LIBAVFORMAT_VERSION_MAJOR >= 59
-+ const
-+#endif
-+ AVOutputFormat *outputFormat = nullptr;
-
- // This 'if' and 'free' are just for safety. We chech the value of formatCtx
- // below.
diff --git a/sci-electronics/gazebo/files/ffmpeg5.patch b/sci-electronics/gazebo/files/ffmpeg5.patch
deleted file mode 100644
index e55bab3c311f..000000000000
--- a/sci-electronics/gazebo/files/ffmpeg5.patch
+++ /dev/null
@@ -1,137 +0,0 @@
-Index: gazebo-11.10.1/gazebo/common/AudioDecoder.cc
-===================================================================
---- gazebo-11.10.1.orig/gazebo/common/AudioDecoder.cc
-+++ gazebo-11.10.1/gazebo/common/AudioDecoder.cc
-@@ -113,8 +113,13 @@ bool AudioDecoder::Decode(uint8_t **_out
- # pragma GCC diagnostic push
- # pragma GCC diagnostic ignored "-Wdeprecated-declarations"
- #endif
-- bytesDecoded = avcodec_decode_audio4(this->codecCtx, decodedFrame,
-- &gotFrame, &packet1);
-+ bytesDecoded = avcodec_send_packet(this->codecCtx, &packet1);
-+ if (bytesDecoded >= 0 || bytesDecoded == AVERROR_EOF) {
-+ bytesDecoded = avcodec_receive_frame(this->codecCtx, decodedFrame);
-+ gotFrame = bytesDecoded >= 0;
-+ if (bytesDecoded == AVERROR(EAGAIN) || bytesDecoded == AVERROR_EOF) bytesDecoded = 0;
-+ }
-+
- #ifndef _WIN32
- # pragma GCC diagnostic pop
- #endif
-@@ -214,7 +219,7 @@ bool AudioDecoder::SetFile(const std::st
- # pragma GCC diagnostic push
- # pragma GCC diagnostic ignored "-Wdeprecated-declarations"
- #endif
-- if (this->formatCtx->streams[i]->codec->codec_type == AVMEDIA_TYPE_AUDIO)
-+ if (this->formatCtx->streams[i]->codecpar->codec_type == AVMEDIA_TYPE_AUDIO)
- #ifndef _WIN32
- # pragma GCC diagnostic pop
- #endif
-@@ -238,7 +243,9 @@ bool AudioDecoder::SetFile(const std::st
- # pragma GCC diagnostic push
- # pragma GCC diagnostic ignored "-Wdeprecated-declarations"
- #endif
-- this->codecCtx = this->formatCtx->streams[audioStream]->codec;
-+ this->codecCtx = avcodec_alloc_context3(nullptr);
-+ avcodec_parameters_to_context(this->codecCtx, this->formatCtx->streams[audioStream]->codecpar);
-+
- #ifndef _WIN32
- # pragma GCC diagnostic pop
- #endif
-Index: gazebo-11.10.1/gazebo/common/AudioDecoder.hh
-===================================================================
---- gazebo-11.10.1.orig/gazebo/common/AudioDecoder.hh
-+++ gazebo-11.10.1/gazebo/common/AudioDecoder.hh
-@@ -75,7 +75,7 @@ namespace gazebo
- private: AVCodecContext *codecCtx;
-
- /// \brief libavcodec audio codec.
-- private: AVCodec *codec;
-+ private: const AVCodec *codec;
-
- /// \brief Index of the audio stream.
- private: int audioStream;
-Index: gazebo-11.10.1/gazebo/common/Video.cc
-===================================================================
---- gazebo-11.10.1.orig/gazebo/common/Video.cc
-+++ gazebo-11.10.1/gazebo/common/Video.cc
-@@ -77,7 +77,7 @@ void Video::Cleanup()
- #ifdef HAVE_FFMPEG
- bool Video::Load(const std::string &_filename)
- {
-- AVCodec *codec = nullptr;
-+ const AVCodec *codec = nullptr;
- this->videoStream = -1;
-
- if (this->formatCtx || this->avFrame || this->codecCtx)
-@@ -107,7 +107,7 @@ bool Video::Load(const std::string &_fil
- # pragma GCC diagnostic push
- # pragma GCC diagnostic ignored "-Wdeprecated-declarations"
- #endif
-- if (this->formatCtx->streams[i]->codec->codec_type == AVMEDIA_TYPE_VIDEO)
-+ if (this->formatCtx->streams[i]->codecpar->codec_type == AVMEDIA_TYPE_VIDEO)
- #ifndef _WIN32
- # pragma GCC diagnostic pop
- #endif
-@@ -128,13 +128,14 @@ bool Video::Load(const std::string &_fil
- # pragma GCC diagnostic push
- # pragma GCC diagnostic ignored "-Wdeprecated-declarations"
- #endif
-- this->codecCtx = this->formatCtx->streams[this->videoStream]->codec;
-+ this->codecCtx = avcodec_alloc_context3(nullptr);
-+ avcodec_parameters_to_context(this->codecCtx, this->formatCtx->streams[this->videoStream]->codecpar);
- #ifndef _WIN32
- # pragma GCC diagnostic pop
- #endif
-
- // Find the decoder for the video stream
-- codec = avcodec_find_decoder(this->codecCtx->codec_id);
-+ codec = avcodec_find_decoder(this->formatCtx->streams[this->videoStream]->codecpar->codec_id);
- if (codec == nullptr)
- {
- gzerr << "Codec not found\n";
-@@ -231,15 +232,19 @@ bool Video::GetNextFrame(unsigned char *
- # pragma GCC diagnostic push
- # pragma GCC diagnostic ignored "-Wdeprecated-declarations"
- #endif
-- int processedLength = avcodec_decode_video2(this->codecCtx, this->avFrame,
-- &frameAvailable, &tmpPacket);
-+ int processedLength = avcodec_send_packet(this->codecCtx, !tmpPacket.data && !tmpPacket.size ? nullptr : &tmpPacket);
- #ifndef _WIN32
- # pragma GCC diagnostic pop
- #endif
-+ if (processedLength >= 0 || processedLength == AVERROR_EOF) {
-+ processedLength = avcodec_receive_frame(this->codecCtx, this->avFrame);
-+ frameAvailable = processedLength >= 0;
-+ if (processedLength == AVERROR(EAGAIN) || processedLength == AVERROR_EOF) processedLength = 0;
-+ }
- if (processedLength < 0)
- {
- gzerr << "Error while processing the data\n";
-- break;
-+ break;
- }
-
- tmpPacket.data = tmpPacket.data + processedLength;
-Index: gazebo-11.10.1/gazebo/common/VideoEncoder.cc
-===================================================================
---- gazebo-11.10.1.orig/gazebo/common/VideoEncoder.cc
-+++ gazebo-11.10.1/gazebo/common/VideoEncoder.cc
-@@ -224,7 +224,7 @@ bool VideoEncoder::Start(const std::stri
-
- // The remainder of this function handles FFMPEG initialization of a video
- // stream
-- AVOutputFormat *outputFormat = nullptr;
-+ const AVOutputFormat *outputFormat = nullptr;
-
- // This 'if' and 'free' are just for safety. We chech the value of formatCtx
- // below.
-@@ -294,7 +294,7 @@ bool VideoEncoder::Start(const std::stri
- }
-
- // find the video encoder
-- AVCodec *encoder = avcodec_find_encoder(
-+ const AVCodec *encoder = avcodec_find_encoder(
- this->dataPtr->formatCtx->oformat->video_codec);
- if (!encoder)
- {
diff --git a/sci-electronics/gazebo/gazebo-11.10.2.ebuild b/sci-electronics/gazebo/gazebo-11.10.2.ebuild
deleted file mode 100644
index d813f60aea22..000000000000
--- a/sci-electronics/gazebo/gazebo-11.10.2.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake flag-o-matic
-
-DESCRIPTION="A 3D multiple robot simulator with dynamics"
-HOMEPAGE="http://gazebosim.org/"
-SRC_URI="https://osrf-distributions.s3.amazonaws.com/gazebo/releases/${P}.tar.bz2"
-
-LICENSE="Apache-2.0"
-# Subslot = major version = soname of libs
-SLOT="0/11"
-KEYWORDS="~amd64"
-IUSE="cpu_flags_x86_sse2 test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-libs/protobuf-2:=
- virtual/opengl
- media-libs/openal
- net-misc/curl
- dev-libs/tinyxml
- >=dev-libs/tinyxml2-6:=
- dev-libs/libtar
- dev-cpp/tbb:=
- >=dev-games/ogre-1.7.4:=[freeimage]
- <dev-games/ogre-1.10
- >=media-libs/freeimage-3.15.4[png]
- sci-libs/libccd
- >=media-video/ffmpeg-2.6:0=
- sci-libs/gts
- >=sci-physics/bullet-2.82:=
- >=dev-libs/sdformat-9.1:=
- dev-qt/qtwidgets:5
- dev-qt/qtcore:5
- dev-qt/qtopengl:5
- dev-libs/boost:=
- sci-libs/gdal:=
- virtual/libusb:1
- dev-libs/libspnav
- media-libs/freeimage
- sci-libs/hdf5:=[cxx]
- sys-apps/util-linux
- media-gfx/graphviz
- net-libs/ignition-msgs:5=
- sci-libs/ignition-math:6=
- net-libs/ignition-transport:8=
- sci-libs/ignition-common:3=
- sci-libs/ignition-fuel-tools:4=
- x11-libs/qwt:6=[qt5(+)]
-"
-DEPEND="${RDEPEND}
- dev-qt/qttest:5
- x11-apps/mesa-progs
- test? ( dev-libs/libxslt )
-"
-BDEPEND="
- || ( app-text/ronn-ng app-text/ronn )
- app-arch/gzip
- virtual/pkgconfig
-"
-CMAKE_BUILD_TYPE=RelWithDebInfo
-PATCHES=(
- "${FILESDIR}/qwt2.patch"
- "${FILESDIR}/cmake.patch"
- "${FILESDIR}/ffmpeg5.patch"
- "${FILESDIR}/ffmpeg4.patch"
-)
-
-src_configure() {
- # find OGRE properly
- sed -e "s#lib/OGRE#$(get_libdir)/OGRE#" -i cmake/gazebo-config.cmake.in || die
-
- local mycmakeargs=(
- "-DUSE_UPSTREAM_CFLAGS=OFF"
- "-DSSE2_FOUND=$(usex cpu_flags_x86_sse2 TRUE FALSE)"
- "-DUSE_HOST_CFLAGS=FALSE"
- "-DBUILD_TESTING=$(usex test TRUE FALSE)"
- "-DENABLE_SCREEN_TESTS=FALSE"
- "-DUSE_EXTERNAL_TINYXML2=TRUE"
- )
- cmake_src_configure
-}
diff --git a/sci-electronics/gazebo/gazebo-11.11.0.ebuild b/sci-electronics/gazebo/gazebo-11.11.0.ebuild
deleted file mode 100644
index 4eac05330fc9..000000000000
--- a/sci-electronics/gazebo/gazebo-11.11.0.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake flag-o-matic
-
-DESCRIPTION="A 3D multiple robot simulator with dynamics"
-HOMEPAGE="http://gazebosim.org/"
-SRC_URI="https://osrf-distributions.s3.amazonaws.com/gazebo/releases/${P}.tar.bz2"
-
-LICENSE="Apache-2.0"
-# Subslot = major version = soname of libs
-SLOT="0/11"
-KEYWORDS="~amd64"
-IUSE="cpu_flags_x86_sse2 test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-libs/protobuf-2:=
- virtual/opengl
- media-libs/openal
- net-misc/curl
- dev-libs/tinyxml
- >=dev-libs/tinyxml2-6:=
- dev-libs/libtar
- dev-cpp/tbb:=
- >=dev-games/ogre-1.7.4:=[freeimage]
- <dev-games/ogre-1.10
- >=media-libs/freeimage-3.15.4[png]
- sci-libs/libccd
- >=media-video/ffmpeg-2.6:0=
- sci-libs/gts
- >=sci-physics/bullet-2.82:=
- >=dev-libs/sdformat-9.8:=
- dev-qt/qtwidgets:5
- dev-qt/qtcore:5
- dev-qt/qtopengl:5
- dev-libs/boost:=
- sci-libs/gdal:=
- virtual/libusb:1
- dev-libs/libspnav
- media-libs/freeimage
- sci-libs/hdf5:=[cxx]
- sys-apps/util-linux
- >=media-gfx/graphviz-4
- net-libs/ignition-msgs:5=
- sci-libs/ignition-math:6=
- net-libs/ignition-transport:8=
- sci-libs/ignition-common:3=
- sci-libs/ignition-fuel-tools:4=
- x11-libs/qwt:6=[qt5(+)]
-"
-DEPEND="${RDEPEND}
- dev-qt/qttest:5
- x11-apps/mesa-progs
- test? ( dev-libs/libxslt )
-"
-BDEPEND="
- || ( app-text/ronn-ng app-text/ronn )
- app-arch/gzip
- virtual/pkgconfig
-"
-CMAKE_BUILD_TYPE=RelWithDebInfo
-PATCHES=(
- "${FILESDIR}/qwt2.patch"
- "${FILESDIR}/cmake.patch"
-)
-
-src_configure() {
- # find OGRE properly
- sed -e "s#lib/OGRE#$(get_libdir)/OGRE#" -i cmake/gazebo-config.cmake.in || die
-
- local mycmakeargs=(
- "-DUSE_UPSTREAM_CFLAGS=OFF"
- "-DSSE2_FOUND=$(usex cpu_flags_x86_sse2 TRUE FALSE)"
- "-DUSE_HOST_CFLAGS=FALSE"
- "-DBUILD_TESTING=$(usex test TRUE FALSE)"
- "-DENABLE_SCREEN_TESTS=FALSE"
- "-DUSE_EXTERNAL_TINYXML2=TRUE"
- )
- cmake_src_configure
-}