summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-07-30 21:50:46 +0200
committerPacho Ramos <pacho@gentoo.org>2024-07-30 23:11:53 +0200
commitf4e00d7c36ad6412719aac744ac959977e38c9d9 (patch)
tree2fa9c4426430d346fb96883a85f6c703c3f81f5e /sci-chemistry
parentsci-chemistry/openbabel: enable py3.12 (diff)
downloadgentoo-f4e00d7c36ad6412719aac744ac959977e38c9d9.tar.gz
gentoo-f4e00d7c36ad6412719aac744ac959977e38c9d9.tar.bz2
gentoo-f4e00d7c36ad6412719aac744ac959977e38c9d9.zip
sci-chemistry/openbabel: sync live ebuild
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/openbabel/openbabel-9999.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/sci-chemistry/openbabel/openbabel-9999.ebuild b/sci-chemistry/openbabel/openbabel-9999.ebuild
index d533ec698acf..fc4d6cab575e 100644
--- a/sci-chemistry/openbabel/openbabel-9999.ebuild
+++ b/sci-chemistry/openbabel/openbabel-9999.ebuild
@@ -3,13 +3,13 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
WX_GTK_VER=3.2-gtk3
inherit cmake desktop flag-o-matic perl-functions python-r1 toolchain-funcs wxwidgets xdg-utils
DESCRIPTION="Interconverts file formats used in molecular modeling"
-HOMEPAGE="https://openbabel.org/"
+HOMEPAGE="https://openbabel.org/ https://github.com/openbabel/openbabel/"
if [[ "${PV}" == *9999* ]]; then
inherit git-r3
@@ -17,7 +17,7 @@ if [[ "${PV}" == *9999* ]]; then
else
if [[ "${PV}" == *_p* ]]; then # eg., openbabel-3.1.1_p20210325
# Set to commit hash
- OPENBABEL_COMMIT=
+ OPENBABEL_COMMIT=08e23f39b0cc39b4eebd937a5a2ffc1a7bac3e1b
SRC_URI="https://github.com/${PN}/${PN}/archive/${OPENBABEL_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${OPENBABEL_COMMIT}"
else
@@ -25,7 +25,7 @@ else
SRC_URI="https://github.com/${PN}/${PN}/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${MY_P}"
fi
- KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+ KEYWORDS="amd64 ~arm ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
fi
SRC_URI="${SRC_URI}
@@ -80,6 +80,10 @@ RDEPEND="
)
"
+PATCHES=(
+ "${FILESDIR}"/openbabel-3.1.1-fix-time-check-cmake.patch
+)
+
pkg_pretend() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}