summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-05-18 12:03:52 +0200
committerPacho Ramos <pacho@gentoo.org>2024-05-18 12:06:40 +0200
commit0262304a0e66328fe0b605343b0dcb05fca7f97c (patch)
tree690dff79a0cccade285a98ae66c26a6e916e4a94 /sci-chemistry
parentsci-libs/libcifpp: add 7.0.4 (diff)
downloadgentoo-0262304a0e66328fe0b605343b0dcb05fca7f97c.tar.gz
gentoo-0262304a0e66328fe0b605343b0dcb05fca7f97c.tar.bz2
gentoo-0262304a0e66328fe0b605343b0dcb05fca7f97c.zip
sci-chemistry/dssp: add 4.4.7
Closes: https://bugs.gentoo.org/924695 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/dssp/Manifest1
-rw-r--r--sci-chemistry/dssp/dssp-4.4.7.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sci-chemistry/dssp/Manifest b/sci-chemistry/dssp/Manifest
index ab8d9af141e6..8388d09b6c61 100644
--- a/sci-chemistry/dssp/Manifest
+++ b/sci-chemistry/dssp/Manifest
@@ -3,3 +3,4 @@ DIST dssp-3.0.11.tar.gz 168085 BLAKE2B e1c42fd22cfb2287f10b5deae48b56a4583d4a677
DIST dssp-4.3.1.tar.gz 226842 BLAKE2B 86318f05b8381d94fa9c65a956f5fb607ef8072b0395d912e20697ba36836c449ddff31a4a64d0005bbfe34899f71853c0f15a911042389fc894934c08fc34c8 SHA512 4dc1a3f5c7ba258ebf548674c7b33c36b0e3a7d14911394eb8d2955c235f3cb1d6c50cb03f411db55a8a9d7aa93e4d03354c47f9f0126b0bdcbf40dc9391d403
DIST dssp-4.4.1.tar.gz 161797 BLAKE2B d6bfb40a730f39e9d5a0988ce22a9dd377ec08a09e29f77e5afaac26d512cf87f6e289c1e4e3e63cfef7354b10fb57bf410bcc169604b1b6a6078380e4f08d26 SHA512 1bcf9e16efc5d3a7de11e24ed63e47d3263123af4670b8f3daa97cdf7cc33202fb4d564acac3024ed4edcce1ef8278f71f5312f27a234d2957afa6f563c88ed6
DIST dssp-4.4.4.1.tar.gz 162809 BLAKE2B 6c3f588a48778cf5f20b40b93736e150a4d366bf44d214b4064362c2a3bce69db415f5d12568a8523d99e2e5a47749d450ff0251dc3035628dbef9343d37e99a SHA512 291810391d74da7ab65bcf4aab61fa4ae1a5518a361fa02d5c15ed0e5c94139fde65e7612a978f5326bd7d93f2ac6ea01b2b65514d6b64f4d062adf112c48deb
+DIST dssp-4.4.7.tar.gz 163831 BLAKE2B 195c8fb183df00105098967850b01c0d6acf776f7cfa409fc536c8291e7a467da2adfb5f34d8191e33dbb29bfd254cd414c1b7b76ed3f3b854928c4dc8a5fcdd SHA512 2fe2d8a494b570934c0d28804fe69b6569089ded58ec92bf3d83b25ce60a3b9486490909e187b511328f13498ca9027869e922d95a355cf0e21c2564c2db1b5a
diff --git a/sci-chemistry/dssp/dssp-4.4.7.ebuild b/sci-chemistry/dssp/dssp-4.4.7.ebuild
new file mode 100644
index 000000000000..4b22c93cb749
--- /dev/null
+++ b/sci-chemistry/dssp/dssp-4.4.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="The protein secondary structure standard"
+HOMEPAGE="https://swift.cmbi.umcn.nl/gv/dssp/ https://github.com/PDB-REDO/dssp"
+SRC_URI="https://github.com/PDB-REDO/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# doc disabled as it only generates a PDF from the manpage for now
+# https://github.com/PDB-REDO/dssp/issues/64
+#IUSE="doc"
+
+CDEPEND="
+ dev-libs/boost:=[zlib]
+ >=dev-libs/libmcfp-1.2.2
+ >=sci-libs/libcifpp-7.0.3
+"
+BDEPEND="${CDEPEND}"
+# doc? (
+# || ( app-text/pandoc-bin[pandoc-symlink] app-text/pandoc )
+# dev-python/weasyprint
+# )
+DEPEND=""
+RDEPEND="${CDEPEND}"
+
+#src_prepare() {
+# # wkhtmltopdf is not available on Gentoo
+# sed -i -e \
+# 's/-t html/-t html --pdf-engine=weasyprint/' \
+# CMakeLists.txt
+# cmake_src_prepare
+#}
+
+src_configure() {
+ local mycmakeargs=(
+ #-DBUILD_DOCUMENTATION=$(usex doc)
+ -DBUILD_DOCUMENTATION=NO
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ if has_version "<=sci-chemistry/gromacs-2022"; then
+ ewarn "DSSP > 3.0.x is not compatible with gmx do_dssp:"
+ ewarn "https://gitlab.com/gromacs/gromacs/-/issues/4129"
+ ewarn
+ ewarn "Feel free to mask newer versions if needed."
+ fi
+}