summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2017-09-03 08:38:57 -0600
committerChristoph Junghans <junghans@gentoo.org>2017-09-03 08:54:54 -0600
commit2dab70fd2251694510671e61828ad03de768cd42 (patch)
treeeef3e4d3531955f488a2a500f74090736559ddb1 /sci-chemistry/votca-ctp
parentsci-libs/votca-moo: initial commit (diff)
downloadgentoo-2dab70fd2251694510671e61828ad03de768cd42.tar.gz
gentoo-2dab70fd2251694510671e61828ad03de768cd42.tar.bz2
gentoo-2dab70fd2251694510671e61828ad03de768cd42.zip
sci-chemistry/votca-ctp: initial commit
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'sci-chemistry/votca-ctp')
-rw-r--r--sci-chemistry/votca-ctp/metadata.xml15
-rw-r--r--sci-chemistry/votca-ctp/votca-ctp-9999.ebuild42
2 files changed, 57 insertions, 0 deletions
diff --git a/sci-chemistry/votca-ctp/metadata.xml b/sci-chemistry/votca-ctp/metadata.xml
new file mode 100644
index 000000000000..7b7ecf654688
--- /dev/null
+++ b/sci-chemistry/votca-ctp/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>junghans@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-chemistry@gentoo.org</email>
+ <name>Gentoo Chemistry Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">votca/ctp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-chemistry/votca-ctp/votca-ctp-9999.ebuild b/sci-chemistry/votca-ctp/votca-ctp-9999.ebuild
new file mode 100644
index 000000000000..cd06c690cdfc
--- /dev/null
+++ b/sci-chemistry/votca-ctp/votca-ctp-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit cmake-utils multilib
+
+IUSE=""
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+ S="${WORKDIR}/${P#votca-}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN/-//}.git"
+ KEYWORDS=""
+fi
+
+DESCRIPTION="Votca charge transport module"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ =sci-libs/votca-tools-${PV}[sqlite]
+ =sci-libs/votca-moo-${PV}
+ =sci-chemistry/votca-csg-${PV}"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( README NOTICE CHANGELOG.md )
+
+src_configure() {
+ mycmakeargs=(
+ -DLIB=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}