summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-10-11 07:51:27 +0000
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-10-27 10:19:12 +0200
commit7bb99f18c1bc348d5b1c1f816dba17ac41febf41 (patch)
treeca7a0a48437416d8b8fedc7b62514c29a64fbeb0 /sci-calculators
parentsci-calculators/bc-gh: add 6.7.2 (diff)
downloadgentoo-7bb99f18c1bc348d5b1c1f816dba17ac41febf41.tar.gz
gentoo-7bb99f18c1bc348d5b1c1f816dba17ac41febf41.tar.bz2
gentoo-7bb99f18c1bc348d5b1c1f816dba17ac41febf41.zip
sci-calculators/tiemu: Fix call to undeclared function romcalls_is_addr
Closes: https://bugs.gentoo.org/886067 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33295 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/tiemu/files/tiemu-3.03-clang16-build-fix.patch23
-rw-r--r--sci-calculators/tiemu/tiemu-3.03-r2.ebuild3
2 files changed, 25 insertions, 1 deletions
diff --git a/sci-calculators/tiemu/files/tiemu-3.03-clang16-build-fix.patch b/sci-calculators/tiemu/files/tiemu-3.03-clang16-build-fix.patch
new file mode 100644
index 000000000000..10d57c7f9ee9
--- /dev/null
+++ b/sci-calculators/tiemu/files/tiemu-3.03-clang16-build-fix.patch
@@ -0,0 +1,23 @@
+Bug: https://bugs.gentoo.org/886067
+--- a/src/core/uae/newcpu.c
++++ b/src/core/uae/newcpu.c
+@@ -19,6 +19,8 @@
+ #include "options.h"
+ #include "memory.h"
+ #include "newcpu.h"
++#include "romcalls.h"
++#include "handles.h"
+
+ // tiemu begin
+ #include "tilibs.h"
+--- a/src/gui/logger/log_link.c
++++ b/src/gui/logger/log_link.c
+@@ -36,7 +36,7 @@
+ #include "filesel.h"
+
+ static GtkTextBuffer *txtbuf;
+-static logger_enabled = 0;
++static int logger_enabled = 0;
+
+ static void udpate_widgets(GtkWidget *button, GtkWidget *spin)
+ {
diff --git a/sci-calculators/tiemu/tiemu-3.03-r2.ebuild b/sci-calculators/tiemu/tiemu-3.03-r2.ebuild
index ef5c95e0d072..ff146a5fd377 100644
--- a/sci-calculators/tiemu/tiemu-3.03-r2.ebuild
+++ b/sci-calculators/tiemu/tiemu-3.03-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -35,6 +35,7 @@ PATCHES=(
"${FILESDIR}"/${P}-remove_depreciated_gtk_calls.patch
"${FILESDIR}"/${P}-r2820.patch
"${FILESDIR}"/${P}-fix-ftbfs-with-customized-abort-function.patch
+ "${FILESDIR}"/${P}-clang16-build-fix.patch
)
src_prepare() {