summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/rnaview
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/rnaview')
-rw-r--r--sci-biology/rnaview/Manifest1
-rw-r--r--sci-biology/rnaview/files/rnaview-20040713-implicit.patch13
-rw-r--r--sci-biology/rnaview/files/rnaview-20040713-makefile.patch87
-rw-r--r--sci-biology/rnaview/metadata.xml13
-rw-r--r--sci-biology/rnaview/rnaview-20040713-r2.ebuild34
-rw-r--r--sci-biology/rnaview/rnaview-20040713-r3.ebuild31
-rw-r--r--sci-biology/rnaview/rnaview-20040713.ebuild39
7 files changed, 218 insertions, 0 deletions
diff --git a/sci-biology/rnaview/Manifest b/sci-biology/rnaview/Manifest
new file mode 100644
index 000000000000..f56b09e2659c
--- /dev/null
+++ b/sci-biology/rnaview/Manifest
@@ -0,0 +1 @@
+DIST rnaview-20040713.tar.bz2 433916 SHA256 0961779c83e247a4b04c02d90d3850e8c4c889b630194ea1516cbeb6c6dbad17 SHA512 c63bb728bad0f358ab36f4ca18f4f9ef046811f21d3b8f3c6fdd3e6e6fcb367a9a52710476c5daea001f8f3262f72b64f0c0546f0c1423f463f2e0d288809e8e WHIRLPOOL 7ae8953a8028da0eb525a6b33964267b15721dbe148f5077cf2c7e47c7cc2e3a47616bcc944e7f8180c0696c27ac16c53bd3847d02db5a575df3cebba29dd169
diff --git a/sci-biology/rnaview/files/rnaview-20040713-implicit.patch b/sci-biology/rnaview/files/rnaview-20040713-implicit.patch
new file mode 100644
index 000000000000..009f6e79ae86
--- /dev/null
+++ b/sci-biology/rnaview/files/rnaview-20040713-implicit.patch
@@ -0,0 +1,13 @@
+Fix implicit function declaration
+
+--- src/xml2ps.c
++++ src/xml2ps.c
+@@ -36,7 +36,7 @@
+ void read_sugar_syn(char *inpfile, long **sugar_syn);
+ void get_sugar_syn(FILE *inp, char *value_ch);
+ void get_chain_broken(long nres, double **a, double **b, long *chain_broken);
+-
++extern void get_BDIR(char *BDIR, char *filename);
+
+
+ FILE *psfile;
diff --git a/sci-biology/rnaview/files/rnaview-20040713-makefile.patch b/sci-biology/rnaview/files/rnaview-20040713-makefile.patch
new file mode 100644
index 000000000000..1af72f581fbf
--- /dev/null
+++ b/sci-biology/rnaview/files/rnaview-20040713-makefile.patch
@@ -0,0 +1,87 @@
+ Makefile | 20 +++++++++++++++++---
+ rnaml2ps/Makefile | 19 ++++++++++++-------
+ 2 files changed, 29 insertions(+), 10 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 452e6c4..00d35f0 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,4 +1,4 @@
+-CC = cc
++CC ?= cc
+
+
+
+@@ -56,12 +56,17 @@ OBJ_FILE = $(OBJ)/rnaview.o \
+ $(OBJ)/multiple.o \
+ $(OBJ)/statistics.o
+
++.PHONY: clean all install
++
++SUBDIRS = rnaml2ps
++
+ all: $(RNAVIEW)
++ for dir in ${SUBDIRS} ; do ( cd $$dir ; ${MAKE} all ) ; done
+
+-CFLAGS = $(LINCLUDES)
++CFLAGS += $(LINCLUDES)
+
+ $(RNAVIEW) : $(HFILES) $(OBJ_FILE)
+- $(CC) $(CFLAGS) -o $@ $(OBJ_FILE) $(LDFLAGS) -lm $(MALLOCLIB)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJ_FILE) -lm $(MALLOCLIB)
+
+
+
+@@ -111,6 +116,15 @@ $(OBJ)/statistics.o : $(SRC)/statistics.c
+ clean:
+ @rm -f $(OBJ)/*.o
+ @rm -f $(ALLTARGETS)
++ for dir in ${SUBDIRS} ; do ( cd $$dir ; ${MAKE} clean ) ; done
++
++install:
++ install -D -m 0755 bin/rnaview $(DESTDIR)/usr/bin/rnaview
++ mkdir -p $(DESTDIR)/usr/share/rnaview/BASEPARS
++ install -m 0644 BASEPARS/* $(DESTDIR)/usr/share/rnaview/BASEPARS
++ mkdir -p $(DESTDIR)/usr/share/rnaview/test
++ install -m 0644 test/* $(DESTDIR)/usr/share/rnaview/test
++ for dir in ${SUBDIRS} ; do ( cd $$dir ; ${MAKE} install ) ; done
+
+ export:
+ mkdir -p $(EXPORT_DIR)
+diff --git a/rnaml2ps/Makefile b/rnaml2ps/Makefile
+index d207655..2278ccc 100644
+--- a/rnaml2ps/Makefile
++++ b/rnaml2ps/Makefile
+@@ -1,20 +1,25 @@
+-CFLAGS = -O
+-CC = cc
++CFLAGS ?= -O
++CC ?= cc
+
+ # ++++++++++++++++++++++++++++ Program RNADRAW
+ RNADRAW = rnaml2ps
+ OBJS_RNADRAW = rnaml2ps.o nrutil.o
+
++all: $(RNADRAW)
++
+ $(RNADRAW): $(OBJS_RNADRAW)
+- $(CC) -o $(RNADRAW) $(OBJS_RNADRAW) -lm
++ $(CC) $(LDFLAGS) -o $(RNADRAW) $(OBJS_RNADRAW) -lm
+
+ nrutil.o : nrutil.c
+- cc -c nrutil.c
++ $(CC) $(CFLAGS) -c nrutil.c
+
+ rnaml2ps.o : rnaml2ps.c
+- cc -c rnaml2ps.c
++ $(CC) $(CFLAGS) -c rnaml2ps.c
+
+
+-.PHONY : clean
++.PHONY : clean all install
+ clean:
+- rm *.o
++ rm -f *.o
++
++install:
++ install -D -m 0755 $(RNADRAW) $(DESTDIR)/usr/bin/$(RNADRAW)
diff --git a/sci-biology/rnaview/metadata.xml b/sci-biology/rnaview/metadata.xml
new file mode 100644
index 000000000000..b243b0c8da63
--- /dev/null
+++ b/sci-biology/rnaview/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <longdescription>
+ The RNAView program generates 2-dimensional displays of RNA/DNA
+ secondary structures with tertiary interactions. RNAView
+ automatically identifies and classifies the types of base pairs that
+ are formed in nucleic acid structures, fully implementing Leontis and
+ Westhof's (RNA (2001) 7, 499-512), convention for edge-to-edge
+ hydrogen bonding interactions.
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-biology/rnaview/rnaview-20040713-r2.ebuild b/sci-biology/rnaview/rnaview-20040713-r2.ebuild
new file mode 100644
index 000000000000..ac9168c57512
--- /dev/null
+++ b/sci-biology/rnaview/rnaview-20040713-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Generates 2D displays of RNA/DNA secondary structures with tertiary interactions"
+HOMEPAGE="http://ndbserver.rutgers.edu/services/download/index.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="public-domain"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch \
+ "${FILESDIR}"/${P}-implicit.patch
+ cat <<- EOF > 22rnaview
+ RNAVIEW="/usr/share/${PN}"
+ EOF
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README || die
+ doenvd 22rnaview || die
+}
diff --git a/sci-biology/rnaview/rnaview-20040713-r3.ebuild b/sci-biology/rnaview/rnaview-20040713-r3.ebuild
new file mode 100644
index 000000000000..5f46e6bc586c
--- /dev/null
+++ b/sci-biology/rnaview/rnaview-20040713-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Generates 2D displays of RNA/DNA secondary structures with tertiary interactions"
+HOMEPAGE="http://ndbserver.rutgers.edu/services/download/index.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-makefile.patch \
+ "${FILESDIR}"/${P}-implicit.patch
+ cat <<- EOF > 22rnaview
+ RNAVIEW="${EPREFIX}/usr/share/${PN}"
+ EOF
+ tc-export CC
+}
+
+src_install() {
+ default
+ doenvd 22rnaview
+}
diff --git a/sci-biology/rnaview/rnaview-20040713.ebuild b/sci-biology/rnaview/rnaview-20040713.ebuild
new file mode 100644
index 000000000000..9bbb7a81f3cf
--- /dev/null
+++ b/sci-biology/rnaview/rnaview-20040713.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="Generates 2D displays of RNA/DNA secondary structures with tertiary interactions"
+HOMEPAGE="http://ndbserver.rutgers.edu/services/download/index.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="public-domain"
+
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e "s/CC = cc/CC = $(tc-getCC)/" \
+ -e "s/CFLAGS =/CFLAGS = ${CFLAGS}/" \
+ -i Makefile || die
+}
+
+src_compile() {
+ make clean
+ make || die
+ cd "${S}"/rnaml2ps
+ make clean
+ make || die
+ cd "${S}"/test
+ rm '.#t'
+}
+
+src_install() {
+ dobin bin/rnaview rnaml2ps/rnaml2ps || die
+ dodoc README || die
+ mkdir -p "${D}"/usr/share/${PN}
+ cp -r BASEPARS test "${D}"/usr/share/${PN}
+}