summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/bioperl-run
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/bioperl-run')
-rw-r--r--sci-biology/bioperl-run/Manifest1
-rw-r--r--sci-biology/bioperl-run/bioperl-run-1.6.9.ebuild42
-rw-r--r--sci-biology/bioperl-run/bioperl-run-9999-r1.ebuild42
-rw-r--r--sci-biology/bioperl-run/files/bioperl-run-Pise-test-patch.diff22
-rw-r--r--sci-biology/bioperl-run/metadata.xml8
5 files changed, 115 insertions, 0 deletions
diff --git a/sci-biology/bioperl-run/Manifest b/sci-biology/bioperl-run/Manifest
new file mode 100644
index 000000000000..bd1970f7c390
--- /dev/null
+++ b/sci-biology/bioperl-run/Manifest
@@ -0,0 +1 @@
+DIST BioPerl-Run-1.006900.tar.gz 14546677 SHA256 6eddca8aae38a139caaa0b28505e2ff3e919e8ed39b7539a662b0145f1f08d96 SHA512 47f2b853885c604291ac0aba3269b897de59cf7da6f7d54a50ff950cca836338091309df550f32695159c620be23391306d0421d2bbc22eebbb61a9e280ad83c WHIRLPOOL a671180b3680d94683e771ba661e0f86430814200efcd8df1552dbc3c30228d90ea8be1b47cc36603cbfc6eadacb276414ae6d79e30ec80495fd836eb1732cca
diff --git a/sci-biology/bioperl-run/bioperl-run-1.6.9.ebuild b/sci-biology/bioperl-run/bioperl-run-1.6.9.ebuild
new file mode 100644
index 000000000000..d633fe3be7a1
--- /dev/null
+++ b/sci-biology/bioperl-run/bioperl-run-1.6.9.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+BIOPERL_RELEASE=1.6.9
+
+MY_PN=BioPerl-Run
+MODULE_AUTHOR=CJFIELDS
+MODULE_VERSION=1.006900
+inherit perl-module
+
+DESCRIPTION="Perl tools for bioinformatics - Wrapper modules around key bioinformatics applications"
+HOMEPAGE="http://www.bioperl.org/"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="-minimal test"
+#SRC_TEST="do"
+
+RESTRICT="test"
+
+CDEPEND=">=sci-biology/bioperl-${BIOPERL_RELEASE}
+ !minimal? (
+ dev-perl/Algorithm-Diff
+ dev-perl/XML-Twig
+ dev-perl/IO-String
+ dev-perl/IPC-Run
+ dev-perl/File-Sort
+ )"
+DEPEND="dev-perl/Module-Build
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}"
+
+src_install() {
+ mydoc="AUTHORS BUGS FAQ"
+ perl-module_src_install
+ # TODO: File collision in Bio/ConfigData.pm (a Module::Build internal file)
+ # with sci-biology/bioperl. Workaround: the "nuke it from orbit" solution :D
+ #find "${D}" -name '*ConfigData*' -print -delete
+}
diff --git a/sci-biology/bioperl-run/bioperl-run-9999-r1.ebuild b/sci-biology/bioperl-run/bioperl-run-9999-r1.ebuild
new file mode 100644
index 000000000000..13c3ca1477da
--- /dev/null
+++ b/sci-biology/bioperl-run/bioperl-run-9999-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit perl-module git-2
+
+DESCRIPTION="Perl tools for bioinformatics - Wrapper modules around key bioinformatics applications"
+HOMEPAGE="http://www.bioperl.org/"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/bioperl/${PN}.git
+ https://github.com/bioperl/${PN}.git"
+
+LICENSE="Artistic GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="-minimal test"
+#SRC_TEST="do"
+
+RESTRICT="test"
+
+CDEPEND=">=sci-biology/bioperl-${PV}
+ !minimal? (
+ dev-perl/Algorithm-Diff
+ dev-perl/XML-Twig
+ dev-perl/IO-String
+ dev-perl/IPC-Run
+ )"
+DEPEND="dev-perl/Module-Build
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}/BioPerl-run-${PV}"
+
+src_install() {
+ mydoc="AUTHORS BUGS FAQ"
+ perl-module_src_install
+ # TODO: File collision in Bio/ConfigData.pm (a Module::Build internal file)
+ # with sci-biology/bioperl. Workaround: the "nuke it from orbit" solution :D
+ find "${D}" -name '*ConfigData*' -print -delete
+}
diff --git a/sci-biology/bioperl-run/files/bioperl-run-Pise-test-patch.diff b/sci-biology/bioperl-run/files/bioperl-run-Pise-test-patch.diff
new file mode 100644
index 000000000000..5683347a6b52
--- /dev/null
+++ b/sci-biology/bioperl-run/files/bioperl-run-Pise-test-patch.diff
@@ -0,0 +1,22 @@
+--- Makefile.PL.original 2003-09-28 23:33:16.000000000 -0400
++++ Makefile.PL 2003-09-28 23:33:50.000000000 -0400
+@@ -73,19 +73,6 @@
+ my $DISTNAME = "bioperl-run";
+ my $VERSION = "1.2.2";
+
+-my $proceed = prompt("Do you want to run the Pise tests (requires a network connection) y/n",'n');
+-if( $proceed =~ /^[yY]/) {
+- my $address = prompt("Enter your email address (no default)",'');
+-
+- if (open T,">t/pise-email.test") {
+-print T "$address\n";
+-close T;
+- } else { warn("Cannot open file t/pise-email.test for writing - no Pise tests will be run"); }
+-} else {
+- if( -e "t/pise-email.test" ) {
+-unlink "t/pise-email.test";
+- }
+-}
+ #$do_autoload_finesse = 0;
+ #$NAME = 'Bio';
+ #$DISTNAME = "GFD";
diff --git a/sci-biology/bioperl-run/metadata.xml b/sci-biology/bioperl-run/metadata.xml
new file mode 100644
index 000000000000..f8c7078a2813
--- /dev/null
+++ b/sci-biology/bioperl-run/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <upstream>
+ <remote-id type="cpan">BioPerl-Run</remote-id>
+ </upstream>
+</pkgmetadata>