summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-07-05 21:44:03 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-07-06 21:31:11 +0000
commit40b9c7abdf2e26711a288970abb260c09023d328 (patch)
treedf7adf1ec20d5594bb68b8515cbfea02d5c0086d /sci-astronomy/cdsclient/cdsclient-3.8.4.ebuild
parentdev-haskell/extra: fix test, bump up to 1.5.1, bug #624030 (diff)
downloadgentoo-40b9c7abdf2e26711a288970abb260c09023d328.tar.gz
gentoo-40b9c7abdf2e26711a288970abb260c09023d328.tar.bz2
gentoo-40b9c7abdf2e26711a288970abb260c09023d328.zip
sci-astronomy/cdsclient: version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'sci-astronomy/cdsclient/cdsclient-3.8.4.ebuild')
-rw-r--r--sci-astronomy/cdsclient/cdsclient-3.8.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sci-astronomy/cdsclient/cdsclient-3.8.4.ebuild b/sci-astronomy/cdsclient/cdsclient-3.8.4.ebuild
new file mode 100644
index 000000000000..868a8b7c0c88
--- /dev/null
+++ b/sci-astronomy/cdsclient/cdsclient-3.8.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils versionator
+
+# upstream versioning wrong: 3.71 is really 3.7.1
+MYP="${PN}-$(delete_version_separator 2)"
+
+DESCRIPTION="Collection of scripts to access the CDS databases"
+HOMEPAGE="http://cdsweb.u-strasbg.fr/doc/cdsclient.html"
+SRC_URI="ftp://cdsarc.u-strasbg.fr/pub/sw/${MYP}.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RESTRICT="mirror bindist"
+DEPEND=""
+RDEPEND="app-shells/tcsh"
+
+S="${WORKDIR}/${MYP}"
+
+PATCHES=( "${FILESDIR}/${PN}-makefile.patch" )
+src_prepare() {
+ default
+ # remove non standard "mantex" page
+ sed -e 's/aclient.tex//' -i configure || die
+}
+
+src_install() {
+ local bindir="${EPREFIX}/usr/bin/${PN}"
+ emake DESTDIR="${D}" SHSDIR="${D}${bindir}" install
+ cat <<-EOF > 99${PN}
+ PATH=${bindir}
+ ROOTPATH=${bindir}
+ EOF
+ doenvd 99${PN}
+}