summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-18 01:03:14 +0000
committerSam James <sam@gentoo.org>2022-12-18 01:03:34 +0000
commit038c222a22b535f2b118c02091c7b53e2d9cb7a6 (patch)
treebe29d737b87a7e771892f5aa84bf5f3caa91c854 /perl-core/Encode
parentdev-libs/openssl: keyword 3.0.7-r2 for ~m68k (diff)
downloadgentoo-038c222a22b535f2b118c02091c7b53e2d9cb7a6.tar.gz
gentoo-038c222a22b535f2b118c02091c7b53e2d9cb7a6.tar.bz2
gentoo-038c222a22b535f2b118c02091c7b53e2d9cb7a6.zip
perl-core/Encode: backport -Werror patch
It's not strictly needed (as this version isn't pulled in w/ Perl 5.36) but the patch exists and it's cheap to pull in, so if it avoids someone wasting some time looking into it, why not? Closes: https://bugs.gentoo.org/886507 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'perl-core/Encode')
-rw-r--r--perl-core/Encode/Encode-3.120.0.ebuild5
-rw-r--r--perl-core/Encode/files/Encode-3.120.0-Werror.patch29
2 files changed, 33 insertions, 1 deletions
diff --git a/perl-core/Encode/Encode-3.120.0.ebuild b/perl-core/Encode/Encode-3.120.0.ebuild
index 34933b10c1e1..76f94b2adc06 100644
--- a/perl-core/Encode/Encode-3.120.0.ebuild
+++ b/perl-core/Encode/Encode-3.120.0.ebuild
@@ -12,4 +12,7 @@ DESCRIPTION="Character encodings in Perl"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-PATCHES=( "${FILESDIR}"/gentoo_enc2xs.diff )
+PATCHES=(
+ "${FILESDIR}"/${P}-Werror.patch
+ "${FILESDIR}"/gentoo_enc2xs.diff
+)
diff --git a/perl-core/Encode/files/Encode-3.120.0-Werror.patch b/perl-core/Encode/files/Encode-3.120.0-Werror.patch
new file mode 100644
index 000000000000..34974911a32f
--- /dev/null
+++ b/perl-core/Encode/files/Encode-3.120.0-Werror.patch
@@ -0,0 +1,29 @@
+https://github.com/dankogai/p5-encode/commit/7c9c5be4e658a5b37632b46925a2735123f65c6e
+https://bugs.gentoo.org/886507
+
+From 7c9c5be4e658a5b37632b46925a2735123f65c6e Mon Sep 17 00:00:00 2001
+From: Nicholas Clark <nick@ccl4.org>
+Date: Wed, 13 Oct 2021 07:51:58 +0000
+Subject: [PATCH] Only add -Werror=declaration-after-statement for 5.035004 and
+ earlier
+
+Perl v5.35.5 now uses some C99 features. This means that Perl's headers now
+contain some code with mixed declarations and code., and so won't compile
+with -Werror=declaration-after-statement
+
+It still makes sense to add this flag for builds for earlier perl versions,
+because they support long obsolete compilers that are strict in rejecting
+certain C99 features, so adding this gcc flag allows us to audit that our
+code does not violate this.
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -20,7 +20,7 @@ if (!$ENV{PERL_CORE}) {
+ $gccver =~ s/\.//g; $gccver =~ s/ .*//;
+ $gccver .= "0" while length $gccver < 3;
+ $gccver = 0+$gccver;
+- $ccflags .= ' -Werror=declaration-after-statement' if $gccver > 412;
++ $ccflags .= ' -Werror=declaration-after-statement' if $gccver > 412 and $] < 5.035005;
+ $ccflags .= ' -Wpointer-sign' if !$Config{d_cplusplus} and $gccver > 400;
+ $ccflags .= ' -fpermissive' if $Config{d_cplusplus};
+ }
+