summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-06-02 15:12:52 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-06-02 15:12:52 -0500
commit4213b89057dbd039f1f81c3846f6658696a01ebe (patch)
treee79d07d21b2548aeffc7a7a38df2215dfc397637 /net-vpn
parentapp-admin/ansible: clean up old ebuilds (diff)
downloadgentoo-4213b89057dbd039f1f81c3846f6658696a01ebe.tar.gz
gentoo-4213b89057dbd039f1f81c3846f6658696a01ebe.tar.bz2
gentoo-4213b89057dbd039f1f81c3846f6658696a01ebe.zip
net-vpn/tailscale: add 1.24.2
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/tailscale/Manifest2
-rw-r--r--net-vpn/tailscale/tailscale-1.24.2.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/net-vpn/tailscale/Manifest b/net-vpn/tailscale/Manifest
index 26e7b264f6b2..3b790574de39 100644
--- a/net-vpn/tailscale/Manifest
+++ b/net-vpn/tailscale/Manifest
@@ -2,3 +2,5 @@ DIST tailscale-1.22.0-vendor.tar.xz 5861668 BLAKE2B 0ccc953e7fa20fd13a6582e10864
DIST tailscale-1.22.0.tar.gz 1018528 BLAKE2B 1ae5a4d76f6f097d85789f875624bae10d146c1503d6d96dc20f85b190ec5586c25c78d5503fb1ac839f6d547379a8ad934bffe0a1a7f76843b643d596aac24f SHA512 d5476d5bac50c0789d0718f39ffee1fb7299f74e6d2682e61fd7856bb63811f2f245c1e10c7befae34b075231210d79fdbde53d24ceba77ed106f8040aab4bcc
DIST tailscale-1.22.2-deps.tar.xz 109072196 BLAKE2B 6cd0b6d1f81ae47815e6ba924da3f8f978e7cc70ce1fa6044b2e12474d07a910d3de73d8005985ce90ebbc304cae0128da61e06871a09b78e5862f2d37c5709c SHA512 31dcb82afa2f75b9513b9a01545d6416218be110ad3350e434cb9c1296da2d7e8793dd55e2269b0ad79ada4174d2e334dcac03f669494ce39fd071dc57bb72b1
DIST tailscale-1.22.2.tar.gz 1019987 BLAKE2B 41911754239944a51e5da9f98392452ad0f28b223423cb2a1b76031cf4f6fb78c4bbcf11efd4b3b257625d66c8c14380cafafb532278a0f6bf306e072326839f SHA512 5aeb2d2881023d1e0cb62a02ac0f3cf931765d2e8674883ccc863c52da7eb3d2f08903556ea0a3679fa404519244a65c9b1df99066c4167402d7e688ca256035
+DIST tailscale-1.24.2-deps.tar.xz 119558132 BLAKE2B 5ffa04b0f4675c5954e00af736274cb0e0c14bb66b18e61407e53b22c5f0687a4994776ab820b09861e79a67899dbcbfd4067503def28c684abc26ac2dad02f8 SHA512 d7c2f79dcafb64c9cba00827915d9c1f2a0d5ab910d5f23c28dc7b84282f94158592bafa0829ede3e051c0ea67232719585617174f5d6ba201922cf53b19152e
+DIST tailscale-1.24.2.tar.gz 1102880 BLAKE2B f72ea66cfa2c5888f2a99d44bc29b760e5dd1de7e0d8142f976b52400d8e63e117c254fdafab6718f747d3602782b74bdafea16c56a9176dcf5b446dcbba2d7c SHA512 cf20bbb56b303897e50071baae88a147e88909d1f01fb0a75688fb880909336b91921ed8331defb874e45c23874b2f4282dddc85b8f58146cab5e27efba063d3
diff --git a/net-vpn/tailscale/tailscale-1.24.2.ebuild b/net-vpn/tailscale/tailscale-1.24.2.ebuild
new file mode 100644
index 000000000000..c040af297b7f
--- /dev/null
+++ b/net-vpn/tailscale/tailscale-1.24.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# These settings are obtained by running ./build_dist.sh shellvars` in
+# the upstream repo.
+VERSION_MINOR="1.24"
+VERSION_SHORT="1.24.2"
+VERSION_LONG="1.24.2-tdce2409b1"
+VERSION_GIT_HASH="dce2409b15837f30885405b8b1d27e7b7fd6bf7a"
+
+DESCRIPTION="Tailscale vpn client"
+HOMEPAGE="https://tailscale.com"
+SRC_URI="https://github.com/tailscale/tailscale/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="net-firewall/iptables"
+
+# This translates the build command from upstream's build_dist.sh to an
+# ebuild equivalent.
+build_dist() {
+ ego build -tags xversion -ldflags "
+ -X tailscale.com/version.Long=${VERSION_LONG}
+ -X tailscale.com/version.Short=${VERSION_SHORT}
+ -X tailscale.com/version.GitCommit=${VERSION_GIT_HASH}" "$@"
+}
+
+src_compile() {
+ build_dist ./cmd/tailscale
+ build_dist ./cmd/tailscaled
+}
+
+src_install() {
+ dosbin tailscaled
+ dobin tailscale
+
+ systemd_dounit cmd/tailscaled/tailscaled.service
+ insinto /etc/default
+ newins cmd/tailscaled/tailscaled.defaults tailscaled
+ keepdir /var/lib/${PN}
+ fperms 0750 /var/lib/${PN}
+
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles" ${PN}.conf
+
+ newinitd "${FILESDIR}/${PN}d.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}d.confd" ${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}