summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2017-03-17 15:37:57 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2017-03-17 15:38:28 +0100
commit9754f457cc6d0aeb90a1535a5228ef909e9584c9 (patch)
treeffbd77f41fb100837cc8f992f8dc863cd01c270d /net-vpn/isatapd/isatapd-0.9.7-r2.ebuild
parentapp-forensics/openscap: remove old (diff)
downloadgentoo-9754f457cc6d0aeb90a1535a5228ef909e9584c9.tar.gz
gentoo-9754f457cc6d0aeb90a1535a5228ef909e9584c9.tar.bz2
gentoo-9754f457cc6d0aeb90a1535a5228ef909e9584c9.zip
Second half of net-vpn/ move
Diffstat (limited to 'net-vpn/isatapd/isatapd-0.9.7-r2.ebuild')
-rw-r--r--net-vpn/isatapd/isatapd-0.9.7-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-vpn/isatapd/isatapd-0.9.7-r2.ebuild b/net-vpn/isatapd/isatapd-0.9.7-r2.ebuild
new file mode 100644
index 000000000000..9474bf9461e8
--- /dev/null
+++ b/net-vpn/isatapd/isatapd-0.9.7-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit linux-info systemd
+
+DESCRIPTION="creates and maintains an ISATAP tunnel (rfc5214)"
+HOMEPAGE="http://www.saschahlusiak.de/linux/isatap.htm"
+SRC_URI="http://www.saschahlusiak.de/linux/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+CONFIG_CHECK="~TUN"
+ERROR_TUN="CONFIG_TUN is needed for isatapd to work"
+
+src_prepare() {
+ sed -e '/^opts/s:opts:extra_started_commands:' \
+ -i openrc/isatapd.init.d || die
+}
+
+src_install() {
+ default
+
+ newinitd openrc/isatapd.init.d isatapd
+ newconfd openrc/isatapd.conf.d isatapd
+ systemd_newunit "${FILESDIR}"/${PN}.service-r2 ${PN}.service
+ systemd_install_serviced "${FILESDIR}"/${PN}.service.conf
+}