summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-proxy/nylon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-proxy/nylon')
-rw-r--r--net-proxy/nylon/Manifest1
-rw-r--r--net-proxy/nylon/files/nylon-1.21-libevent.patch63
-rw-r--r--net-proxy/nylon/files/nylon.conf37
-rw-r--r--net-proxy/nylon/files/nylon.init23
-rw-r--r--net-proxy/nylon/metadata.xml7
-rw-r--r--net-proxy/nylon/nylon-1.21-r1.ebuild34
6 files changed, 165 insertions, 0 deletions
diff --git a/net-proxy/nylon/Manifest b/net-proxy/nylon/Manifest
new file mode 100644
index 000000000000..e3361ddf21c5
--- /dev/null
+++ b/net-proxy/nylon/Manifest
@@ -0,0 +1 @@
+DIST nylon-1.21.tar.gz 115954 SHA256 34c132b005c025c1a5079aae9210855c80f50dc51dde719298e1113ad73408a4 SHA512 7338ebf376843a49777bfc2c04dc0f9b14a25162efb008a555b6d74991bfbddbe5eb8fa6371c8c6a4dae9739f15d6d85135ba9d39472bc2646293a39777b5cfa WHIRLPOOL 50d223998e5f7992dbba17568839d1c6992dc4231d5855a904a93e0e076aea5bc0c57e550fc4f3cd3b72399da16f227342ad061f31e8e0dd626192154a5c8699
diff --git a/net-proxy/nylon/files/nylon-1.21-libevent.patch b/net-proxy/nylon/files/nylon-1.21-libevent.patch
new file mode 100644
index 000000000000..d7ca2a1ab0e9
--- /dev/null
+++ b/net-proxy/nylon/files/nylon-1.21-libevent.patch
@@ -0,0 +1,63 @@
+--- a/configure.in
++++ b/configure.in
+@@ -95,44 +95,10 @@
+ AC_REPLACE_FUNCS(strlcpy strlcat strsep setproctitle daemon)
+
+ dnl Checks for libevent
+-AC_MSG_CHECKING(for libevent)
+-AC_ARG_WITH(libevent,
+-[ --with-libevent=DIR use libevent in DIR],
+-[ case "$withval" in
+- yes|no)
+- AC_MSG_RESULT(no)
+- ;;
+- *)
+- AC_MSG_RESULT($withval)
+- if test -f $withval/include/event.h -a -f $withval/lib/libevent.a; then
+- owd=`pwd`
+- if cd $withval; then withval=`pwd`; cd $owd; fi
+- EVENTINC="-I$withval/include"
+- EVENTLIB="-L$withval/lib -levent"
+- elif test -f $withval/event.h -a -f $withval/libevent.a; then
+- owd=`pwd`
+- if cd $withval; then withval=`pwd`; cd $owd; fi
+- EVENTINC="-I$withval"
+- EVENTLIB="-L$withval -levent"
+- else
+- AC_ERROR(event.h or libevent.a not found in $withval)
+- fi
+- ;;
+- esac ],
+-[ if test -f ${prefix}/include/event.h -a -f ${prefix}/lib/libevent.a;
+-then
+- EVENTINC="-I${prefix}/include"
+- EVENTLIB="-L${prefix}/lib -levent"
+- elif test -f /usr/include/event.h; then
+- EVENTLIB="-levent"
+- else
+- AC_MSG_RESULT(no)
+- AC_ERROR(libevent not found)
+- fi
+- AC_MSG_RESULT(yes) ]
+-)
+-AC_SUBST(EVENTINC)
+-AC_SUBST(EVENTLIB)
++PKG_CHECK_MODULES(LIBEVENT,libevent,,)
++
++AC_SUBST(LIBEVENT_CFLAGS)
++AC_SUBST(LIBEVENT_LIBS)
+
+ if test "x${sysconfdir}" = 'x${prefix}/etc'; then
+ csysconfdir="${prefix}/etc"
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -5,7 +5,7 @@
+ nylon_SOURCES = nylon.c print.c cfg.c expanda.c net.c access.c atomicio.c \
+ socks4.c socks5.c mirror.c cleanup.c misc.c
+
+-AM_CFLAGS = @EVENTINC@ -Wall -g
+-LDADD = @EVENTLIB@ @LIBOBJS@
++AM_CFLAGS = @LIBEVENT_CFLAGS@
++LDADD = @LIBEVENT_LIBS@ @LIBOBJS@
+
+ EXTRA_DIST = strlcpy.c strlcat.c setproctitle.c strsep.c err.c daemon.c
diff --git a/net-proxy/nylon/files/nylon.conf b/net-proxy/nylon/files/nylon.conf
new file mode 100644
index 000000000000..825cc0a3e7e4
--- /dev/null
+++ b/net-proxy/nylon/files/nylon.conf
@@ -0,0 +1,37 @@
+# sample configuration
+# marius aamodt eriksen (marius@umich.edu)
+# $Id$
+# general settings
+[General]
+
+# number of simultaneous connections allowed
+No-Simultaneous-Conn=10
+
+# log connections and other information to syslog? 1: on, 0: off
+Log=1
+
+# be verbose on the console? 1: on, 0: off
+Verbose=0
+
+# store pid file
+#PIDfile=/var/run/nylon.pid
+
+# server settings
+[Server]
+
+# interface to listen to connections
+#Binding-Interface=fxp1
+
+# interface to bind outgoing connections to
+#Connecting-Interface=fxp0
+
+# listening port to bind to
+Port=1080
+
+# allowed is processed first, then deny
+
+# allowable connect ips/ranges
+#Allow-IP=141.0.0.0/8 127.0.0.1 10.0.0.0/24
+Allow-IP=127.0.0.1/32
+# denied connect ips/ranges
+#Deny-IP=10.0.0.0/24
diff --git a/net-proxy/nylon/files/nylon.init b/net-proxy/nylon/files/nylon.init
new file mode 100644
index 000000000000..20a96da58b93
--- /dev/null
+++ b/net-proxy/nylon/files/nylon.init
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting Nylon"
+ start-stop-daemon --start --quiet --pidfile /var/run/nylon.pid \
+ --startas /usr/bin/nylon
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Nylon"
+ start-stop-daemon --stop --quiet --pidfile /var/run/nylon.pid
+ eend $?
+}
+
+
diff --git a/net-proxy/nylon/metadata.xml b/net-proxy/nylon/metadata.xml
new file mode 100644
index 000000000000..ee6d311bbe07
--- /dev/null
+++ b/net-proxy/nylon/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+<longdescription>nylon is a proxy server, developed on OpenBSD. It supports SOCKS version 4 and 5,
+as well as a mirror mode so that services can be mirrored directly.</longdescription>
+</pkgmetadata>
diff --git a/net-proxy/nylon/nylon-1.21-r1.ebuild b/net-proxy/nylon/nylon-1.21-r1.ebuild
new file mode 100644
index 000000000000..f0c4072676d6
--- /dev/null
+++ b/net-proxy/nylon/nylon-1.21-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="A lightweight SOCKS proxy server"
+HOMEPAGE="http://monkey.org/~marius/nylon/"
+SRC_URI="http://monkey.org/~marius/nylon/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/libevent-0.6"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=( README THANKS )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libevent.patch
+ eautoreconf
+}
+
+src_install() {
+ default
+ insinto /etc ; doins "${FILESDIR}/nylon.conf"
+ newinitd "${FILESDIR}/nylon.init" nylond
+}