summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2019-06-10 22:08:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2019-06-10 22:10:00 -0700
commit838574244d2da2a919cf92444bd32a2207607a09 (patch)
tree718320cdba52b4e4912cc28547db219bb9081a2b /net-print
parentmedia-libs/openjpeg: arm64 stable (bug #646774) (diff)
downloadgentoo-838574244d2da2a919cf92444bd32a2207607a09.tar.gz
gentoo-838574244d2da2a919cf92444bd32a2207607a09.tar.bz2
gentoo-838574244d2da2a919cf92444bd32a2207607a09.zip
net-print/dymo-cups-drivers: EAPI7, maintainer, minor patch, fix tests
Used with Dymo LabelWriter 450 Turbo & GLabels, worked great today. Add myself so it doesn't get treecleaned. One outstanding bug fixed, EAPI7 conversion, and make the tests pass (one check fails due to src_test not running as root, and the upstream test design is meant for post-install). Fixes: https://bugs.gentoo.org/601242 Package-Manager: Portage-2.3.67, Repoman-2.3.12 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/dymo-cups-drivers/dymo-cups-drivers-1.4.0-r1.ebuild55
-rw-r--r--net-print/dymo-cups-drivers/files/dymo-cups-drivers-1.4.0.5-flexible-tests.patch9
-rw-r--r--net-print/dymo-cups-drivers/metadata.xml7
3 files changed, 71 insertions, 0 deletions
diff --git a/net-print/dymo-cups-drivers/dymo-cups-drivers-1.4.0-r1.ebuild b/net-print/dymo-cups-drivers/dymo-cups-drivers-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..b6390ae9d51f
--- /dev/null
+++ b/net-print/dymo-cups-drivers/dymo-cups-drivers-1.4.0-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils autotools
+
+DESCRIPTION="Dymo SDK for LabelWriter/LabelManager printers"
+HOMEPAGE="https://newellrubbermaid.secure.force.com/dymopkb"
+SRC_URI="http://download.dymo.com/Download%20Drivers/Linux/Download/${P}.tar.gz"
+
+S="${WORKDIR}/${P}.5"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test usb_modeswitch"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="net-print/cups"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cppunit )
+ usb_modeswitch? ( sys-apps/usb_modeswitch )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.0-cxxflags.patch
+ "${FILESDIR}"/port_to_newer_cups_headers.patch
+ "${FILESDIR}"/dymo-cups-drivers-1.4.0.5-flexible-tests.patch
+)
+
+DOCS=( AUTHORS README ChangeLog docs/SAMPLES )
+
+src_prepare() {
+ default
+ eapply_user
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/doc/${PF}
+ doins docs/*.{txt,rtf,ps,png}
+}
+
+src_test() {
+ # upstream tests are designed to be run AFTER make install, because they depend on final paths.
+ testroot="${T}/testroot"
+ mkdir -p "${testroot}"
+ emake install DESTDIR="${testroot}" || die "Failed to install for testing"
+ # -W filters is because CUPS tries really hard for secure filters: they must be root/root for the filter tests to pass
+ #chown root:root "${testroot}"/usr/libexec/cups/filter/{raster2dymolm,raster2dymolw} || die "failed to set ownership for tests"
+ # This will trigger the following warning repeatedly
+ #Bad permissions on cupsFilter file "..${testroot}/usr/libexec/cups/filter/raster2dymolm"
+ emake check CUPSTESTPPD_OPTS="-R ${testroot} -W filters" || die "failed tests"
+}
diff --git a/net-print/dymo-cups-drivers/files/dymo-cups-drivers-1.4.0.5-flexible-tests.patch b/net-print/dymo-cups-drivers/files/dymo-cups-drivers-1.4.0.5-flexible-tests.patch
new file mode 100644
index 000000000000..e954b45822bd
--- /dev/null
+++ b/net-print/dymo-cups-drivers/files/dymo-cups-drivers-1.4.0.5-flexible-tests.patch
@@ -0,0 +1,9 @@
+diff -Nuar --exclude '*~' dymo-cups-drivers-1.4.0.5.orig/ppd/Makefile.am dymo-cups-drivers-1.4.0.5/ppd/Makefile.am
+--- dymo-cups-drivers-1.4.0.5.orig/ppd/Makefile.am 2012-02-07 05:54:02.000000000 -0800
++++ dymo-cups-drivers-1.4.0.5/ppd/Makefile.am 2019-06-10 21:57:06.785694883 -0700
+@@ -51,4 +51,4 @@
+ testppd_SOURCES=
+
+ testppd:
+- cupstestppd $(dist_cupsmodel_DATA)
++ cupstestppd $(CUPSTESTPPD_OPTS) $(dist_cupsmodel_DATA)
diff --git a/net-print/dymo-cups-drivers/metadata.xml b/net-print/dymo-cups-drivers/metadata.xml
index 097975e3adc2..169f1f54e1f4 100644
--- a/net-print/dymo-cups-drivers/metadata.xml
+++ b/net-print/dymo-cups-drivers/metadata.xml
@@ -1,4 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer type="person">
+ <email>robbat2@gentoo.org</email>
+ <description>Occasional access to Dymo LabelWriter 450 Turbo</description>
+ </maintainer>
+ <use>
+ <flag name="usb_modeswitch">Include usb_modeswitch for some hardware (bug #601242)</flag>
+ </use>
</pkgmetadata>