summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-27 23:17:53 +0000
committerSam James <sam@gentoo.org>2024-02-27 23:20:53 +0000
commit1b6a444e93c9dea09c40fd97e2a35fbc017da3fb (patch)
tree775f4ea573a134025a09efd5f3b25373f2c7907c /net-p2p
parentnet-p2p/go-ethereum: recreate Go dep tarball (diff)
downloadgentoo-1b6a444e93c9dea09c40fd97e2a35fbc017da3fb.tar.gz
gentoo-1b6a444e93c9dea09c40fd97e2a35fbc017da3fb.tar.bz2
gentoo-1b6a444e93c9dea09c40fd97e2a35fbc017da3fb.zip
net-p2p/go-ethereum: add 1.13.14
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/go-ethereum/Manifest2
-rw-r--r--net-p2p/go-ethereum/go-ethereum-1.13.14.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/net-p2p/go-ethereum/Manifest b/net-p2p/go-ethereum/Manifest
index b3d76f40ccfd..f309c4d399f4 100644
--- a/net-p2p/go-ethereum/Manifest
+++ b/net-p2p/go-ethereum/Manifest
@@ -1,2 +1,4 @@
DIST go-ethereum-1.10.18-deps.tar.xz 77657628 BLAKE2B fa4ebb250668489d6d72ac1284dc5b516643acf10c5d69ee97f1066d3cd7c780f198c170fbbf201e149d6664593d9027cf221058b13a82c3ab2681b21225d991 SHA512 130a492bfc281ca3fe10c13edba1907c455f7f322a7fe9b474e3ef206937b8a988e285c57946e5e8dc2639ae031a5a8514ef42be668d7719940ef65fde6c309d
DIST go-ethereum-1.10.18.tar.gz 13084436 BLAKE2B 4918f13b131796f928c17e6cbd3ab42095d4a52874865a2e9b9c6e8b8e4528af0152055c8d8556c795079bd2bc044e9a0fd028d4a90c66181c0cafddb41cf7ae SHA512 ba2b7091ac4ffd5bf02dbc27769ebd138b82dd9d79fb613e727f56f6cfaf969183f343511478e88fbead627141101e77206a4c2449b0ced9a7a2090b4c77d996
+DIST go-ethereum-1.13.14-deps.tar.xz 70373740 BLAKE2B 6bc403f85e024fdeeab8f41ef7f2940cceee11b8f6a1f97dc53cc5dda997f3c97ddcaefac61df196508f00fe61152f21bedc8de9e380fa91245a049c0a93ab58 SHA512 0d6cc6b846dab05acabfa0fc840f2db450a3138f863bf3f99ef83040071260a42fa2dccb88877a0d340e2532241653c32efb783bc67698f316ab1c9291d75330
+DIST go-ethereum-1.13.14.tar.gz 13500798 BLAKE2B f5cf0c3f72aedc7d149c5342c2edbcb4310301b4c9b164d65e1e281b8db78c79ca884e9cb41ecd72ed6fbbed34e198cb13fe7cc726856c9f323a4aacc4a2dc17 SHA512 80a410dbeb06e8a46bd5b4e962fcf030fa8787eef192dbcd01c3d98bf31e822a8c3b92c35251876e122eac3fad707faf95b5e5c0baed8e29aa024c856b6f54bc
diff --git a/net-p2p/go-ethereum/go-ethereum-1.13.14.ebuild b/net-p2p/go-ethereum/go-ethereum-1.13.14.ebuild
new file mode 100644
index 000000000000..3f6a3c174507
--- /dev/null
+++ b/net-p2p/go-ethereum/go-ethereum-1.13.14.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Official golang implementation of the Ethereum protocol"
+HOMEPAGE="https://github.com/ethereum/go-ethereum"
+SRC_URI="https://github.com/ethereum/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="GPL-3+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="devtools"
+
+# Does all kinds of wonky stuff like connecting to Docker daemon, network activity, ...
+RESTRICT+=" test"
+
+src_compile() {
+ emake $(usex devtools all geth)
+}
+
+src_install() {
+ einstalldocs
+
+ dobin build/bin/geth
+
+ if use devtools; then
+ dobin build/bin/abidump
+ dobin build/bin/abigen
+ dobin build/bin/bootnode
+ dobin build/bin/checkpoint-admin
+ dobin build/bin/clef
+ dobin build/bin/devp2p
+ dobin build/bin/ethkey
+ dobin build/bin/evm
+ dobin build/bin/faucet
+ dobin build/bin/p2psim
+ dobin build/bin/puppeth
+ dobin build/bin/rlpdump
+ fi
+}