summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNHOrus <jy6x2b32pie9@yahoo.com>2024-05-11 13:41:23 +0400
committerSam James <sam@gentoo.org>2024-11-27 04:49:52 +0000
commit8f4edd1cc041d8de9898d8277c80b3a19822016f (patch)
tree4b4d943308923abdebcd7c2eec60f0a636c9c06d /net-nntp
parentnet-libs/c-client: fix modern C issues (diff)
downloadgentoo-8f4edd1cc041d8de9898d8277c80b3a19822016f.tar.gz
gentoo-8f4edd1cc041d8de9898d8277c80b3a19822016f.tar.bz2
gentoo-8f4edd1cc041d8de9898d8277c80b3a19822016f.zip
net-nntp/slrn: add missing include
Closes: https://bugs.gentoo.org/874687 Signed-off-by: NHOrus <jy6x2b32pie9@yahoo.com> Closes: https://github.com/gentoo/gentoo/pull/36639 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/slrn/files/slrn-1.0.3-configure.patch48
-rw-r--r--net-nntp/slrn/slrn-1.0.3-r2.ebuild45
2 files changed, 93 insertions, 0 deletions
diff --git a/net-nntp/slrn/files/slrn-1.0.3-configure.patch b/net-nntp/slrn/files/slrn-1.0.3-configure.patch
new file mode 100644
index 000000000000..deef317bf91d
--- /dev/null
+++ b/net-nntp/slrn/files/slrn-1.0.3-configure.patch
@@ -0,0 +1,48 @@
+https://bugs.gentoo.org/874687
+from
+https://github.com/jedsoft/slrn/pull/1
+edited to current situation (line numbers changed so patch applies cleanly)
+and half of the patch pertaining autotools is dropped
+
+From f550d0ab9e1cd3cfe844022435c3d98af3c18441 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Sat, 4 Feb 2023 15:04:36 +0100
+Subject: [PATCH] autoconf: Fix C99 compatibility issue in the VA_COPY checks
+
+The exit function is called without including <stdlib.h>, resulting
+in an implicit function declarations. Future compilers will not
+support implicit function declarations by default. This will lead
+to build failures.
+---
+ autoconf/configure.ac | 3 +++
+ configure | 3 +++
+ 2 files changed, 6 insertions(+)
+
+diff --git a/configure b/configure
+index faec350..8758172 100755
+--- a/configure
++++ b/configure
+@@ -8307,6 +8307,7 @@ else
+ /* end confdefs.h. */
+
+ #include <stdarg.h>
++ #include <stdlib.h>
+ void f (int i, ...) {
+ va_list args1, args2;
+ va_start (args1, i);
+@@ -8352,6 +8353,7 @@ else
+ /* end confdefs.h. */
+
+ #include <stdarg.h>
++ #include <stdlib.h>
+ void f (int i, ...) {
+ va_list args1, args2;
+ va_start (args1, i);
+@@ -8397,6 +8399,7 @@ else
+ /* end confdefs.h. */
+
+ #include <stdarg.h>
++ #include <stdlib.h>
+ void f (int i, ...) {
+ va_list args1, args2;
+ va_start (args1, i);
diff --git a/net-nntp/slrn/slrn-1.0.3-r2.ebuild b/net-nntp/slrn/slrn-1.0.3-r2.ebuild
new file mode 100644
index 000000000000..f968453c2e6c
--- /dev/null
+++ b/net-nntp/slrn/slrn-1.0.3-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${P}a"
+
+DESCRIPTION="A s-lang based newsreader"
+HOMEPAGE="
+ https://slrn.sourceforge.net/
+ https://github.com/jedsoft/slrn
+"
+SRC_URI="https://jedsoft.org/releases/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="canlock nls selinux ssl uudeview"
+
+RDEPEND="app-arch/sharutils
+ >=sys-libs/slang-2.2.3
+ virtual/mta
+ canlock? ( net-libs/canlock:=[legacy(+)] )
+ ssl? (
+ dev-libs/openssl:0=
+ )
+ uudeview? ( dev-libs/uulib )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+RDEPEND+=" selinux? ( sec-policy/selinux-slrnpull )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.2-make.patch
+ "${FILESDIR}"/${P}-configure.patch
+)
+
+src_configure() {
+ econf \
+ --with-docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --with-slrnpull \
+ $(use_with canlock canlock /usr) \
+ $(use_enable nls) \
+ $(use_with ssl) \
+ $(use_with uudeview uu)
+}