summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-04-15 19:44:46 -0400
committerSam James <sam@gentoo.org>2024-04-26 13:48:51 +0100
commitf5b1a3f355a475aa8dd57cfe20057ee81af3d36c (patch)
tree20fad6a1704bdb2a0d3d77c7de970457f58475d3 /net-news
parentnet-news/yydecode: update HOMEPAGE for HTTPS (diff)
downloadgentoo-f5b1a3f355a475aa8dd57cfe20057ee81af3d36c.tar.gz
gentoo-f5b1a3f355a475aa8dd57cfe20057ee81af3d36c.tar.bz2
gentoo-f5b1a3f355a475aa8dd57cfe20057ee81af3d36c.zip
net-news/yydecode: update EAPI 7 -> 8
Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-news')
-rw-r--r--net-news/yydecode/yydecode-0.2.10-r3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-news/yydecode/yydecode-0.2.10-r3.ebuild b/net-news/yydecode/yydecode-0.2.10-r3.ebuild
new file mode 100644
index 000000000000..f3cf3e6ad416
--- /dev/null
+++ b/net-news/yydecode/yydecode-0.2.10-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="A decoder for yENC format, popular on Usenet"
+HOMEPAGE="https://yydecode.sourceforge.net/"
+SRC_URI="mirror://sourceforge/yydecode/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~sparc ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2.10-fix-strcmp-not-found.patch
+)
+
+src_prepare() {
+ default
+ sed -e "s/t3.sh//" -e "s/t7.sh//" -i checks/Makefile.in || die
+}
+
+src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/898078
+ #
+ # Upstream has been dead since 2003. No bug reported.
+ filter-lto
+ default
+}