summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-10-04 02:54:58 +0100
committerSam James <sam@gentoo.org>2024-10-04 02:54:58 +0100
commit574b96930429ec02ed3cadfdf8ebff52abbc2373 (patch)
treea1fa04837f75ad7de2d6603624c1a170970a7c47 /net-misc
parentsys-process/procs: add 0.14.6 (diff)
downloadgentoo-574b96930429ec02ed3cadfdf8ebff52abbc2373.tar.gz
gentoo-574b96930429ec02ed3cadfdf8ebff52abbc2373.tar.bz2
gentoo-574b96930429ec02ed3cadfdf8ebff52abbc2373.zip
net-misc/socat: add 1.8.0.1
Skip handful of tests which need permissions, like: ``` test 518 STDIN_F_SETPIPE_SZ: f-setpipe-sz on STDIN... FAILED ./socat -t 0.1 STDIN,f-setpipe-sz=2097152!!STDOUT EXEC:./filan,nofork 2023/12/29 01:30:22 socat[9560] E fcntl(0, 1031, 0x200000): Operation not permitted ``` Bug: https://bugs.gentoo.org/920907 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/socat/Manifest1
-rw-r--r--net-misc/socat/socat-1.8.0.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/net-misc/socat/Manifest b/net-misc/socat/Manifest
index 5171cae8235d..4b5e778fdd80 100644
--- a/net-misc/socat/Manifest
+++ b/net-misc/socat/Manifest
@@ -1,2 +1,3 @@
DIST socat-1.7.4.4.tar.bz2 522127 BLAKE2B 221b1c7c1ef0ac9c2402a6917ce7740a7ed857ceae4f4c346ed3c69c261fd0f9ca667e21cab5f97427d3947b06fdb0ac6d090852465878db968a24b8ece587ad SHA512 3eedfbf599ecf1d6fd391d03d710044bc5e18a762395bc4cb151b96fe673d405a6630da3070ecddd5ac558126b56aa65feaa74d528eeb755a04aa0ec61690651
DIST socat-1.8.0.0.tar.bz2 564066 BLAKE2B b0b3e8c46f746b1aaff7390bbf9521cca8c421f3c20cd7a7f7d8ffd3d7b5e5e881e2477642f7d29247ee5a9d9edf6c8370a43c5f2757e456966b17e3ba08a58a SHA512 dd15c31204f2843ab473a30aa841e960e7c00ac7487e2265d69f9e8ea0afde3841d57cfcb99084f03935d7223da65cee27166837f2f9b3a20c834bc161af802b
+DIST socat-1.8.0.1.tar.bz2 579492 BLAKE2B 0af65b18dc6fec28e59d75048b1e1c4f442f134d87bc6a9b5ea7b3032a0c5519e0d042ae760d451006eacf368870a0a47465d9ec2d5f2fe8d41efcd639ef58c5 SHA512 ce8147df545f74d4b6e1d3d0dae2dcea58c4c7e6ccd1cb2eec68c29ead2c3a818e9851b30a5e5f1456d70463c31b13ab1c5b350293359419a583ed693a917231
diff --git a/net-misc/socat/socat-1.8.0.1.ebuild b/net-misc/socat/socat-1.8.0.1.ebuild
new file mode 100644
index 000000000000..c95a08a93750
--- /dev/null
+++ b/net-misc/socat/socat-1.8.0.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo flag-o-matic toolchain-funcs
+
+MY_P=${P/_beta/-b}
+DESCRIPTION="Multipurpose relay (SOcket CAT)"
+HOMEPAGE="http://www.dest-unreach.org/socat/ https://repo.or.cz/socat.git"
+SRC_URI="http://www.dest-unreach.org/socat/download/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="ipv6 readline ssl tcpd"
+
+DEPEND="
+ ssl? ( >=dev-libs/openssl-3:= )
+ readline? ( sys-libs/readline:= )
+ tcpd? ( sys-apps/tcp-wrappers )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ FILES PORTING README SECURITY )
+
+src_configure() {
+ # bug #293324
+ filter-flags '-Wno-error*'
+
+ tc-export AR
+
+ local myeconfargs=(
+ $(use_enable ssl openssl)
+ $(use_enable readline)
+ $(use_enable ipv6 ip6)
+ $(use_enable tcpd libwrap)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # Most tests are skipped because they need network access or a TTY
+ # 518 519 need extra permissions
+ edo ./test.sh -v --expect-fail 217,311,313,410,478,518,519,528
+}
+
+src_install() {
+ default
+
+ docinto html
+ dodoc doc/*.html doc/*.css
+}