summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-30 05:51:04 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-30 06:03:01 +0200
commit1156591e7d79fb95241f75d55602ae48b06f00f3 (patch)
treefb79ef6e2db8216c499e0cce2f11363ed7957c9a /net-misc
parentdev-python/httpauth: Bump to 0.4.1 (diff)
downloadgentoo-1156591e7d79fb95241f75d55602ae48b06f00f3.tar.gz
gentoo-1156591e7d79fb95241f75d55602ae48b06f00f3.tar.bz2
gentoo-1156591e7d79fb95241f75d55602ae48b06f00f3.zip
net-misc/electrum: Bump to 4.5.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/electrum/Manifest1
-rw-r--r--net-misc/electrum/electrum-4.5.5.ebuild118
2 files changed, 119 insertions, 0 deletions
diff --git a/net-misc/electrum/Manifest b/net-misc/electrum/Manifest
index fac2490a9d79..614a43a5cafc 100644
--- a/net-misc/electrum/Manifest
+++ b/net-misc/electrum/Manifest
@@ -1 +1,2 @@
DIST electrum-4.5.4.gh.tar.gz 4911082 BLAKE2B 89a58966426b705e0ddfadd75d4c2996976abb66695edd5d426c0232f58a2da701f20112f31a2498858c61a4a1cd9e048b44072bad128b54651929b96341c1c3 SHA512 3fda9a931067e35d8bc11da8855553a1208428975fe65b0fc20eb26bdd2c3840b5c3ed4261e60344c7256461887d286e432568ef385d9c6b1216e708e099b34b
+DIST electrum-4.5.5.gh.tar.gz 4927614 BLAKE2B 9b0bdf4f79ed15279bd8485b9d7fd1d911a5cdc6c3a2deb5e72dad7cd232c87d3f41f10ab572ab3969c9d1ddc65742d1983369a43946ab7f321d49975a50b41a SHA512 28121665cad7bc540600562d4d3e72e20108785c096647fdcc9eb8c26616a04730f53ba53b19f6a332eadc8e20a5524b33dab3719421aeb2b51a0531f9e8ef11
diff --git a/net-misc/electrum/electrum-4.5.5.ebuild b/net-misc/electrum/electrum-4.5.5.ebuild
new file mode 100644
index 000000000000..85c8d7cc1e8f
--- /dev/null
+++ b/net-misc/electrum/electrum-4.5.5.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="ncurses?"
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="User friendly Bitcoin client"
+HOMEPAGE="
+ https://electrum.org/
+ https://github.com/spesmilo/electrum/
+"
+SRC_URI="
+ https://github.com/spesmilo/electrum/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cli ncurses qrcode +qt5"
+REQUIRED_USE="|| ( cli ncurses qt5 )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ <dev-libs/libsecp256k1-0.4
+ >=dev-python/aiohttp-socks-0.8.4[${PYTHON_USEDEP}]
+ =dev-python/aiorpcx-0.23*[${PYTHON_USEDEP}]
+ >=dev-python/attrs-20.1.0[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-2[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ dev-python/pbkdf2[${PYTHON_USEDEP}]
+ dev-python/pyperclip[${PYTHON_USEDEP}]
+ dev-python/PySocks[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.20[${PYTHON_USEDEP}]
+ qrcode? ( media-gfx/zbar[v4l] )
+ qt5? (
+ dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+ )
+ ncurses? ( $(python_gen_impl_dep 'ncurses') )
+"
+BDEPEND="
+ test? (
+ dev-python/pyaes[${PYTHON_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # test for qml/PyQt6 GUI that doesn't work anyway
+ tests/test_qml_types.py
+)
+
+src_prepare() {
+ # use backwards-compatible cryptodome API
+ sed -i -e 's:Cryptodome:Crypto:' electrum/crypto.py || die
+
+ # make qdarkstyle dep optional
+ sed -i -e '/qdarkstyle/d' contrib/requirements/requirements.txt || die
+
+ # remove upper bounds from deps
+ sed -i -e 's:,<[0-9.]*::' contrib/requirements/requirements.txt || die
+
+ local bestgui
+ if use qt5; then
+ bestgui=qt
+ elif use ncurses; then
+ bestgui=text
+ else
+ bestgui=stdio
+ fi
+ sed -i 's/^\([[:space:]]*\)\(config_options\['\''cwd'\''\] = .*\)$/\1\2\n\1config_options.setdefault("gui", "'"${bestgui}"'")\n/' ${PN}/${PN} || die
+
+ eapply_user
+
+ xdg_environment_reset
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ dodoc RELEASE-NOTES
+ distutils-r1_src_install
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ ver_test "${v}" -ge 4.3.4 && return
+ done
+
+ ewarn "If you are new to BitCoin, please be aware that:"
+ ewarn "1. Cryptocurrencies are volatile. BTC has been subject to rapid"
+ ewarn " changes of value in the past."
+ ewarn "2. Cryptocurrency ownership is determined solely by the access to"
+ ewarn " the private key. If the key is lost or stolen, BTC are unrevocably"
+ ewarn " lost."
+ ewarn "3. Proof-of-work based cryptocurrencies have negative environmental"
+ ewarn " impact. BTC mining is consuming huge amounts of electricity."
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}