summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-11-22 11:51:22 +0000
committerSam James <sam@gentoo.org>2023-11-22 11:51:39 +0000
commit83819f3a38705b3ea390a7b3291315a02f854926 (patch)
treeaf55d24d8efd90539d91bf19e1872b2fa1ea8073 /net-misc/streamlink
parentdev-python/urllib3: Stabilize 1.26.18 ALLARCHES, #917745 (diff)
downloadgentoo-83819f3a38705b3ea390a7b3291315a02f854926.tar.gz
gentoo-83819f3a38705b3ea390a7b3291315a02f854926.tar.bz2
gentoo-83819f3a38705b3ea390a7b3291315a02f854926.zip
net-misc/streamlink: add 6.4.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/streamlink')
-rw-r--r--net-misc/streamlink/Manifest1
-rw-r--r--net-misc/streamlink/files/streamlink-6.4.0-libxml2-2.12.0.patch199
-rw-r--r--net-misc/streamlink/streamlink-6.4.0.ebuild78
-rw-r--r--net-misc/streamlink/streamlink-9999.ebuild5
4 files changed, 283 insertions, 0 deletions
diff --git a/net-misc/streamlink/Manifest b/net-misc/streamlink/Manifest
index 30d4bb556928..15b36e018703 100644
--- a/net-misc/streamlink/Manifest
+++ b/net-misc/streamlink/Manifest
@@ -4,3 +4,4 @@ DIST streamlink-6.1.0.tar.gz 686463 BLAKE2B cc2890db0181e47bcae9da38eddeaadfd34b
DIST streamlink-6.2.0.tar.gz 690986 BLAKE2B 5f7cab73ea366580aeb837b8f8a27fa7cd5ca687afa53908900dc9f290a0da916778fda8351acda00f795688b156ca0f37302e67128ce30e9838a45111b88ecd SHA512 2747ebc584caa8ebb2fde5d4f309c911a52fd1a8d2d0e832487e589873c270534e0d0b18120a2db7a68e150e301e57db1e8d63f1d5bb6244f364e9cbd6606213
DIST streamlink-6.2.1.tar.gz 692446 BLAKE2B c1b98ffca37051675a92afc86d12635b538c1b12c023b652a05516faffb289f50b479b38ae48813a4f83d6c881dc7f211e66c6d7f7dd08adcf1a354c9bd15427 SHA512 852610d97138cf0a8066f760f747cb32f1d51c8c55b84df5b6a798556343010c2e68ca5d9a8473e8d32f72bc2a5d89f9d90ee70ccced84b6c9408930ed49585a
DIST streamlink-6.3.1.tar.gz 699073 BLAKE2B 9d1fc58bd0cf4539369fc9d49230c18ef3b9a783783a517c831089571424412841f9e8925202d32bc4218d7a08e4e53c823fc503199131edb59e8fd69e8d49fa SHA512 a1e50688acd3b99efd20c1ff1d3bda03cb6e6b5566484d29372bc6d08ee4115f8ad2edea2f0a90f5de105edb52689781892f413f4af3d836cdd9e9a364006610
+DIST streamlink-6.4.0.tar.gz 715287 BLAKE2B e2657a03bbc02e40207079a43dd2770dddb46b1b07db428bef4623a760bf37dc6853bbbc49a65462f5063e377ca45d2c540e6b879ba7852f76d49062c668f1af SHA512 94387a8d7861c2010319a57b57c430a9600ec3da17320293a13caa5769d19ab366522f36c24d96d481e123faddf6869b1126e3657a1c3b3164a8313daf9a3efb
diff --git a/net-misc/streamlink/files/streamlink-6.4.0-libxml2-2.12.0.patch b/net-misc/streamlink/files/streamlink-6.4.0-libxml2-2.12.0.patch
new file mode 100644
index 000000000000..ed5fd30366d2
--- /dev/null
+++ b/net-misc/streamlink/files/streamlink-6.4.0-libxml2-2.12.0.patch
@@ -0,0 +1,199 @@
+https://github.com/streamlink/streamlink/commit/9d8156dd794ee0919297cd90d85bcc11b8a28358
+
+From 9d8156dd794ee0919297cd90d85bcc11b8a28358 Mon Sep 17 00:00:00 2001
+From: bastimeyer <mail@bastimeyer.de>
+Date: Tue, 21 Nov 2023 20:10:47 +0100
+Subject: [PATCH] utils.parse: fix libxml2 2.12.0 compatibility
+
+---
+ src/streamlink/compat.py | 11 ++++
+ src/streamlink/utils/parse.py | 17 +++++-
+ tests/utils/test_parse.py | 112 ++++++++++++++++++++++++++--------
+ 3 files changed, 114 insertions(+), 26 deletions(-)
+
+diff --git a/src/streamlink/compat.py b/src/streamlink/compat.py
+index c75201544d3..993bce64cfd 100644
+--- a/src/streamlink/compat.py
++++ b/src/streamlink/compat.py
+@@ -2,11 +2,22 @@
+ import sys
+
+
++# compatibility import of charset_normalizer/chardet via requests<3.0
++try:
++ from requests.compat import chardet as charset_normalizer # type: ignore
++except ImportError: # pragma: no cover
++ import charset_normalizer
++
++
+ is_darwin = sys.platform == "darwin"
+ is_win32 = os.name == "nt"
+
+
++detect_encoding = charset_normalizer.detect
++
++
+ __all__ = [
+ "is_darwin",
+ "is_win32",
++ "detect_encoding",
+ ]
+diff --git a/src/streamlink/utils/parse.py b/src/streamlink/utils/parse.py
+index 8c9f79c8b51..17479b81f59 100644
+--- a/src/streamlink/utils/parse.py
++++ b/src/streamlink/utils/parse.py
+@@ -4,6 +4,7 @@
+
+ from lxml.etree import HTML, XML
+
++from streamlink.compat import detect_encoding
+ from streamlink.plugin import PluginError
+
+
+@@ -51,7 +52,21 @@ def parse_html(
+ - Removes XML declarations of invalid XHTML5 documents
+ - Wraps errors in custom exception with a snippet of the data in the message
+ """
+- if isinstance(data, str) and data.lstrip().startswith("<?xml"):
++ # strip XML text declarations from XHTML5 documents which were incorrectly defined as HTML5
++ is_bytes = isinstance(data, bytes)
++ if data and data.lstrip()[:5].lower() == (b"<?xml" if is_bytes else "<?xml"):
++ if is_bytes:
++ # get the document's encoding using the "encoding" attribute value of the XML text declaration
++ match = re.match(rb"^\s*<\?xml\s.*?encoding=(?P<q>[\'\"])(?P<encoding>.+?)(?P=q).*?\?>", data, re.IGNORECASE)
++ if match:
++ encoding_value = detect_encoding(match["encoding"])["encoding"]
++ encoding = match["encoding"].decode(encoding_value)
++ else:
++ # no "encoding" attribute: try to figure out encoding from the document's content
++ encoding = detect_encoding(data)["encoding"]
++
++ data = data.decode(encoding)
++
+ data = re.sub(r"^\s*<\?xml.+?\?>", "", data)
+
+ return _parse(HTML, data, name, exception, schema, *args, **kwargs)
+diff --git a/tests/utils/test_parse.py b/tests/utils/test_parse.py
+index aedae7d4e8e..69c16f282b9 100644
+--- a/tests/utils/test_parse.py
++++ b/tests/utils/test_parse.py
+@@ -74,31 +74,93 @@ def test_parse_xml_entities(self):
+ assert actual.tag == expected.tag
+ assert actual.attrib == expected.attrib
+
+- def test_parse_xml_encoding(self):
+- tree = parse_xml("""<?xml version="1.0" encoding="UTF-8"?><test>ä</test>""")
+- assert tree.xpath(".//text()") == ["ä"]
+- tree = parse_xml("""<test>ä</test>""")
+- assert tree.xpath(".//text()") == ["ä"]
+- tree = parse_xml(b"""<?xml version="1.0" encoding="UTF-8"?><test>\xC3\xA4</test>""")
+- assert tree.xpath(".//text()") == ["ä"]
+- tree = parse_xml(b"""<test>\xC3\xA4</test>""")
+- assert tree.xpath(".//text()") == ["ä"]
+-
+- def test_parse_html_encoding(self):
+- tree = parse_html("""<!DOCTYPE html><html><head><meta charset="utf-8"/></head><body>ä</body></html>""")
+- assert tree.xpath(".//body/text()") == ["ä"]
+- tree = parse_html("""<!DOCTYPE html><html><body>ä</body></html>""")
+- assert tree.xpath(".//body/text()") == ["ä"]
+- tree = parse_html(b"""<!DOCTYPE html><html><meta charset="utf-8"/><body>\xC3\xA4</body></html>""")
+- assert tree.xpath(".//body/text()") == ["ä"]
+- tree = parse_html(b"""<!DOCTYPE html><html><body>\xC3\xA4</body></html>""")
+- assert tree.xpath(".//body/text()") == ["ä"]
+-
+- def test_parse_html_xhtml5(self):
+- tree = parse_html("""<?xml version="1.0" encoding="UTF-8"?><!DOCTYPE html><html><body>ä?></body></html>""")
+- assert tree.xpath(".//body/text()") == ["ä?>"]
+- tree = parse_html(b"""<?xml version="1.0" encoding="UTF-8"?><!DOCTYPE html><html><body>\xC3\xA4?></body></html>""")
+- assert tree.xpath(".//body/text()") == ["ä?>"]
++ @pytest.mark.parametrize(("content", "expected"), [
++ pytest.param(
++ """<?xml version="1.0" encoding="UTF-8"?><test>ä</test>""",
++ "ä",
++ id="string-utf-8",
++ ),
++ pytest.param(
++ """<test>ä</test>""",
++ "ä",
++ id="string-unknown",
++ ),
++ pytest.param(
++ b"""<?xml version="1.0" encoding="UTF-8"?><test>\xC3\xA4</test>""",
++ "ä",
++ id="bytes-utf-8",
++ ),
++ pytest.param(
++ b"""<?xml version="1.0" encoding="ISO-8859-1"?><test>\xE4</test>""",
++ "ä",
++ id="bytes-iso-8859-1",
++ ),
++ pytest.param(
++ b"""<test>\xC3\xA4</test>""",
++ "ä",
++ id="bytes-unknown",
++ ),
++ ])
++ def test_parse_xml_encoding(self, content, expected):
++ tree = parse_xml(content)
++ assert tree.xpath(".//text()") == [expected]
++
++ @pytest.mark.parametrize(("content", "expected"), [
++ pytest.param(
++ """<!DOCTYPE html><html><head><meta charset="utf-8"/></head><body>ä</body></html>""",
++ "ä",
++ id="string-utf-8",
++ ),
++ pytest.param(
++ """<!DOCTYPE html><html><body>ä</body></html>""",
++ "ä",
++ id="string-unknown",
++ ),
++ pytest.param(
++ b"""<!DOCTYPE html><html><head><meta charset="utf-8"/></head><body>\xC3\xA4</body></html>""",
++ "ä",
++ id="bytes-utf-8",
++ ),
++ pytest.param(
++ b"""<!DOCTYPE html><html><head><meta charset="ISO-8859-1"/></head><body>\xE4</body></html>""",
++ "ä",
++ id="bytes-iso-8859-1",
++ ),
++ pytest.param(
++ b"""<!DOCTYPE html><html><body>\xC3\xA4</body></html>""",
++ "ä",
++ id="bytes-unknown",
++ ),
++ ])
++ def test_parse_html_encoding(self, content, expected):
++ tree = parse_html(content)
++ assert tree.xpath(".//body/text()") == [expected]
++
++ @pytest.mark.parametrize(("content", "expected"), [
++ pytest.param(
++ """<?xml version="1.0" encoding="UTF-8"?><!DOCTYPE html><html><body>ä?></body></html>""",
++ "ä?>",
++ id="string",
++ ),
++ pytest.param(
++ b"""<?xml version="1.0" encoding="UTF-8"?><!DOCTYPE html><html><body>\xC3\xA4?></body></html>""",
++ "ä?>",
++ id="bytes-utf-8",
++ ),
++ pytest.param(
++ b"""<?xml version="1.0" encoding="ISO-8859-1"?><!DOCTYPE html><html><body>\xE4?></body></html>""",
++ "ä?>",
++ id="bytes-iso-8859-1",
++ ),
++ pytest.param(
++ b"""<?xml version="1.0"?><!DOCTYPE html><html><body>\xC3\xA4?></body></html>""",
++ "ä?>",
++ id="bytes-unknown",
++ ),
++ ])
++ def test_parse_html_xhtml5(self, content, expected):
++ tree = parse_html(content)
++ assert tree.xpath(".//body/text()") == [expected]
+
+ def test_parse_qsd(self):
+ assert parse_qsd("test=1&foo=bar", schema=validate.Schema({"test": str, "foo": "bar"})) == {"test": "1", "foo": "bar"}
+
diff --git a/net-misc/streamlink/streamlink-6.4.0.ebuild b/net-misc/streamlink/streamlink-6.4.0.ebuild
new file mode 100644
index 000000000000..2c9ca567becc
--- /dev/null
+++ b/net-misc/streamlink/streamlink-6.4.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/streamlink/${PN}.git"
+ inherit git-r3
+fi
+
+DISTUTILS_SINGLE_IMPL=1
+# >= 6.2.1 uses a bunch of setuptools hooks instead of vanilla setuptools
+# https://github.com/streamlink/streamlink/commit/194d9bc193f5285bc1ba33af5fd89209a96ad3a7
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE='xml(+),threads(+)'
+inherit distutils-r1
+
+DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
+HOMEPAGE="https://streamlink.github.io/"
+
+if [[ ${PV} != 9999* ]]; then
+ SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
+fi
+
+LICENSE="BSD-2 Apache-2.0"
+SLOT="0"
+if [[ ${PV} != 9999* ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+# See https://github.com/streamlink/streamlink/commit/9d8156dd794ee0919297cd90d85bcc11b8a28358 for chardet/charset-normalizer dep
+RDEPEND="
+ media-video/ffmpeg
+ $(python_gen_cond_dep '
+ dev-python/certifi[${PYTHON_USEDEP}]
+ || (
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/charset-normalizer[${PYTHON_USEDEP}]
+ )
+ >=dev-python/requests-2.26.0[${PYTHON_USEDEP}]
+ dev-python/isodate[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.6.4[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-1.2.1[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
+ >dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.22.0[${PYTHON_USEDEP}]
+ >=dev-python/trio-websocket-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/setuptools-64[${PYTHON_USEDEP}]
+ >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/freezegun-1.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+ ')
+"
+
+if [[ ${PV} == 9999* ]]; then
+ RDEPEND+="
+ $(python_gen_cond_dep '
+ >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
+ ')
+ "
+fi
+
+PATCHES=(
+ "${FILESDIR}"/${P}-libxml2-2.12.0.patch
+)
+
+distutils_enable_tests pytest
diff --git a/net-misc/streamlink/streamlink-9999.ebuild b/net-misc/streamlink/streamlink-9999.ebuild
index 05ac7784a3e8..d73952536218 100644
--- a/net-misc/streamlink/streamlink-9999.ebuild
+++ b/net-misc/streamlink/streamlink-9999.ebuild
@@ -29,10 +29,15 @@ if [[ ${PV} != 9999* ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi
+# See https://github.com/streamlink/streamlink/commit/9d8156dd794ee0919297cd90d85bcc11b8a28358 for chardet/charset-normalizer dep
RDEPEND="
media-video/ffmpeg
$(python_gen_cond_dep '
dev-python/certifi[${PYTHON_USEDEP}]
+ || (
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/charset-normalizer[${PYTHON_USEDEP}]
+ )
>=dev-python/requests-2.26.0[${PYTHON_USEDEP}]
dev-python/isodate[${PYTHON_USEDEP}]
>=dev-python/lxml-4.6.4[${PYTHON_USEDEP}]