summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/portspoof
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/portspoof')
-rw-r--r--net-misc/portspoof/Manifest2
-rw-r--r--net-misc/portspoof/metadata.xml13
-rw-r--r--net-misc/portspoof/portspoof-1.1.ebuild29
-rw-r--r--net-misc/portspoof/portspoof-1.3.ebuild37
-rw-r--r--net-misc/portspoof/portspoof-9999.ebuild37
5 files changed, 118 insertions, 0 deletions
diff --git a/net-misc/portspoof/Manifest b/net-misc/portspoof/Manifest
new file mode 100644
index 000000000000..0f4adc5eb658
--- /dev/null
+++ b/net-misc/portspoof/Manifest
@@ -0,0 +1,2 @@
+DIST portspoof-1.1.tar.gz 399119 SHA256 84e07ac328d741c1ccea3847d413d01185a6a2393f8637e67178f984703ef613 SHA512 ff78058d66aa142e34f70c6759bf04bfd69c5149e294803c41837276646fad21eea2d20b9eb1ba897e2fbd5f57f65b3a86fecb8ebbc25cdec7d31a2f7997f91b WHIRLPOOL c736160d3643fe96bf50e392953a8e78f2bb792211b16f16313ddc8d21906fb4afd02079a9d45ca22e32b550819357bcfa7413b99cb1510588ddc20e6d00080a
+DIST portspoof-1.3.tar.gz 401187 SHA256 56287536b9baf71d8a9f8009f9ce1fafcae85587e881da1ce86f7f46bc8afc8f SHA512 8d537ecf2ae5de8388c2b9b7210a2d38fe614e525a2ba286321fcf3b237f0888e59bb79a80056e49cf7f850be8ef274e87f04597a50dc1b86350bbc094e8be6e WHIRLPOOL 683f4cb89f2ba9d4ba3323161e9847638c6d6ac7a3a22ccd5b2c61784f9a43590863484aa7cbd5004a24b6d143b001fa50c27e351bb1df23f9a8e94d30123cde
diff --git a/net-misc/portspoof/metadata.xml b/net-misc/portspoof/metadata.xml
new file mode 100644
index 000000000000..adaca1811357
--- /dev/null
+++ b/net-misc/portspoof/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="github">drk1wi/portspoof</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/portspoof/portspoof-1.1.ebuild b/net-misc/portspoof/portspoof-1.1.ebuild
new file mode 100644
index 000000000000..cedb2e10fc20
--- /dev/null
+++ b/net-misc/portspoof/portspoof-1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="return SYN+ACK for every port connection attempt"
+HOMEPAGE="http://portspoof.org/"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3 autotools
+ EGIT_REPO_URI="https://github.com/drk1wi/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/drk1wi/portspoof/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ eautoreconf
+ fi
+}
diff --git a/net-misc/portspoof/portspoof-1.3.ebuild b/net-misc/portspoof/portspoof-1.3.ebuild
new file mode 100644
index 000000000000..030a83813d34
--- /dev/null
+++ b/net-misc/portspoof/portspoof-1.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="return SYN+ACK for every port connection attempt"
+HOMEPAGE="http://portspoof.org/"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3 autotools
+ EGIT_REPO_URI="https://github.com/drk1wi/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/drk1wi/portspoof/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ eautoreconf
+ fi
+ sed -i \
+ 's#/usr/local/bin/portspoof -D -c /usr/local/etc/portspoof.conf -s /usr/local/etc/portspoof_signatures#/usr/bin/portspoof -D -c /etc/portspoof.conf -s /etc/portspoof_signatures#'\
+ system_files/init.d/portspoof.sh
+}
+
+src_install() {
+ default_src_install
+ newsbin system_files/init.d/portspoof.sh portspoof-runner
+}
diff --git a/net-misc/portspoof/portspoof-9999.ebuild b/net-misc/portspoof/portspoof-9999.ebuild
new file mode 100644
index 000000000000..030a83813d34
--- /dev/null
+++ b/net-misc/portspoof/portspoof-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="return SYN+ACK for every port connection attempt"
+HOMEPAGE="http://portspoof.org/"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3 autotools
+ EGIT_REPO_URI="https://github.com/drk1wi/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/drk1wi/portspoof/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ eautoreconf
+ fi
+ sed -i \
+ 's#/usr/local/bin/portspoof -D -c /usr/local/etc/portspoof.conf -s /usr/local/etc/portspoof_signatures#/usr/bin/portspoof -D -c /etc/portspoof.conf -s /etc/portspoof_signatures#'\
+ system_files/init.d/portspoof.sh
+}
+
+src_install() {
+ default_src_install
+ newsbin system_files/init.d/portspoof.sh portspoof-runner
+}