summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2020-06-25 21:03:06 +0200
committerAaron Bauman <bman@gentoo.org>2020-06-27 16:49:39 -0400
commitc23aecb5a87b1108cb02b8370dc760ee47dfc435 (patch)
tree2c0a06e9cf43d0165c78fa05050896623496e0e5 /net-misc/clockspeed
parentmedia-libs/gd: remove unused patches (diff)
downloadgentoo-c23aecb5a87b1108cb02b8370dc760ee47dfc435.tar.gz
gentoo-c23aecb5a87b1108cb02b8370dc760ee47dfc435.tar.bz2
gentoo-c23aecb5a87b1108cb02b8370dc760ee47dfc435.zip
net-misc/clockspeed: EAPI7, use HTTPS
Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16419 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'net-misc/clockspeed')
-rw-r--r--net-misc/clockspeed/clockspeed-0.62-r7.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-misc/clockspeed/clockspeed-0.62-r7.ebuild b/net-misc/clockspeed/clockspeed-0.62-r7.ebuild
new file mode 100644
index 000000000000..69bb561244a7
--- /dev/null
+++ b/net-misc/clockspeed/clockspeed-0.62-r7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Simple Network Time Protocol (NTP) client"
+HOMEPAGE="https://cr.yp.to/clockspeed.html"
+
+# this is the trailing part of the name for the latest leapseconds file.
+LEAPSECONDS_DATE="20081114"
+
+SRC_URI="https://cr.yp.to/clockspeed/${P}.tar.gz
+ https://dev.gentoo.org/~pacho/maintainer-needed/leapsecs.dat."$LEAPSECONDS_DATE""
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="static selinux"
+RESTRICT="mirror bindist test"
+
+DEPEND="sys-apps/groff"
+RDEPEND="selinux? ( sec-policy/selinux-clockspeed )
+ net-dns/djbdns"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_configure() {
+ echo "$(tc-getCC) ${CFLAGS} ${ASFLAGS}" > conf-cc || die
+ use static && append-ldflags -static
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld || die
+}
+
+src_install() {
+ dobin clockspeed clockadd clockview sntpclock taiclock taiclockd
+ dosbin "${FILESDIR}"/ntpclockset
+
+ doman *.1
+ dodoc BLURB CHANGES INSTALL README THANKS TODO
+
+ insinto /var/lib/clockspeed
+ newins "${DISTDIR}"/leapsecs.dat."$LEAPSECONDS_DATE" leapsecs.dat
+}