summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-09-04 13:53:47 -0400
committerMike Gilbert <floppym@gentoo.org>2018-09-05 10:00:41 -0400
commit3258d7f48cd61a5a116b857de94fa02547a3f06d (patch)
tree0c661627304a28278fb5bba960407fd6d8ac43cb /net-misc/chrony
parentnet-misc/curl: Version 7.61.1. (diff)
downloadgentoo-3258d7f48cd61a5a116b857de94fa02547a3f06d.tar.gz
gentoo-3258d7f48cd61a5a116b857de94fa02547a3f06d.tar.bz2
gentoo-3258d7f48cd61a5a116b857de94fa02547a3f06d.zip
net-misc/chrony: systemd changes/fixes
Use upstream unit file with a couple tweaks. Stop installing obsolete[1] ntp-units.d file. [1] https://github.com/systemd/systemd/commit/b72ddf0f4f552dd53d6404b6ddbc9f17d02b8e12
Diffstat (limited to 'net-misc/chrony')
-rw-r--r--net-misc/chrony/chrony-3.4_pre1-r2.ebuild (renamed from net-misc/chrony/chrony-3.4_pre1-r1.ebuild)10
-rw-r--r--net-misc/chrony/chrony-9999.ebuild12
-rw-r--r--net-misc/chrony/files/chronyd-systemd-gentoo.patch28
3 files changed, 41 insertions, 9 deletions
diff --git a/net-misc/chrony/chrony-3.4_pre1-r1.ebuild b/net-misc/chrony/chrony-3.4_pre1-r2.ebuild
index a39dc7b24dce..2b17b91c999e 100644
--- a/net-misc/chrony/chrony-3.4_pre1-r1.ebuild
+++ b/net-misc/chrony/chrony-3.4_pre1-r2.ebuild
@@ -36,12 +36,15 @@ RESTRICT=test
S="${WORKDIR}/${P/_/-}"
+PATCHES=(
+ "${FILESDIR}"/chronyd-systemd-gentoo.patch
+)
+
src_prepare() {
+ default
sed -i \
-e 's:/etc/chrony\.conf:/etc/chrony/chrony.conf:g' \
doc/* examples/* || die
-
- default
}
src_configure() {
@@ -116,6 +119,5 @@ src_install() {
insinto /etc/logrotate.d
newins "${FILESDIR}"/chrony-2.4-r1.logrotate chrony
- systemd_newunit "${FILESDIR}"/chronyd.service-r2 chronyd.service
- systemd_enable_ntpunit 50-chrony chronyd.service
+ systemd_dounit examples/chronyd.service
}
diff --git a/net-misc/chrony/chrony-9999.ebuild b/net-misc/chrony/chrony-9999.ebuild
index 1878efaf91d0..ac4e878733ef 100644
--- a/net-misc/chrony/chrony-9999.ebuild
+++ b/net-misc/chrony/chrony-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -33,13 +33,16 @@ RDEPEND="
RESTRICT=test
S="${WORKDIR}/${P/_/-}"
+PATCHES=(
+ "${FILESDIR}"/chronyd-systemd-gentoo.patch
+)
+
src_prepare() {
+ default
sed -i \
-e 's:/etc/chrony\.:/etc/chrony/chrony.:g' \
-e 's:/var/run:/run:g' \
conf.c doc/*.adoc examples/* || die
-
- default
}
src_configure() {
@@ -111,6 +114,5 @@ src_install() {
insinto /etc/logrotate.d
newins "${FILESDIR}"/chrony-2.4-r1.logrotate chrony
- systemd_newunit "${FILESDIR}"/chronyd.service-r2 chronyd.service
- systemd_enable_ntpunit 50-chrony chronyd.service
+ systemd_dounit examples/chronyd.service
}
diff --git a/net-misc/chrony/files/chronyd-systemd-gentoo.patch b/net-misc/chrony/files/chronyd-systemd-gentoo.patch
new file mode 100644
index 000000000000..63d6b7ed3398
--- /dev/null
+++ b/net-misc/chrony/files/chronyd-systemd-gentoo.patch
@@ -0,0 +1,28 @@
+From ba3ddefc90f58d30a365104cf6e930333e3a2704 Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Tue, 4 Sep 2018 13:01:06 -0400
+Subject: [PATCH] Tweak chronyd.service for Gentoo
+
+---
+ examples/chronyd.service | 5 ++---
+ 1 file changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/examples/chronyd.service b/examples/chronyd.service
+index 1777413..ceed830 100644
+--- a/examples/chronyd.service
++++ b/examples/chronyd.service
+@@ -7,9 +7,8 @@ ConditionCapability=CAP_SYS_TIME
+
+ [Service]
+ Type=forking
+-PIDFile=/var/run/chrony/chronyd.pid
+-EnvironmentFile=-/etc/sysconfig/chronyd
+-ExecStart=/usr/sbin/chronyd $OPTIONS
++PIDFile=/run/chrony/chronyd.pid
++ExecStart=/usr/sbin/chronyd
+ PrivateTmp=yes
+ ProtectHome=yes
+ ProtectSystem=full
+--
+2.18.0
+