summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2024-08-16 15:14:50 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2024-08-16 15:15:00 +0200
commitff09b21fee0eca4295e388f626654a3e5d5d2751 (patch)
tree1f334d20c7bc81d99da412d51c67eea7f4904c0f /net-mail
parentnet-mail/fetchmail: drop 6.4.37 (diff)
downloadgentoo-ff09b21fee0eca4295e388f626654a3e5d5d2751.tar.gz
gentoo-ff09b21fee0eca4295e388f626654a3e5d5d2751.tar.bz2
gentoo-ff09b21fee0eca4295e388f626654a3e5d5d2751.zip
net-mail/fetchmail: add 6.4.39
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/fetchmail/Manifest1
-rw-r--r--net-mail/fetchmail/fetchmail-6.4.39.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/net-mail/fetchmail/Manifest b/net-mail/fetchmail/Manifest
index 10a12c674727..59b3c90fcbca 100644
--- a/net-mail/fetchmail/Manifest
+++ b/net-mail/fetchmail/Manifest
@@ -1 +1,2 @@
DIST fetchmail-6.4.38.tar.xz 1220892 BLAKE2B 6bb743b0e1f47143f69e3790ba2ad8849d2ec216c5fd7cc427a737e00183f2e3a65007df9dc5ffdebd991bd13e079a501519b271d02b1fd75151032d74e84dd2 SHA512 f58ab1275ceab2d11df590d32f5f59a8eb656ddab13bc47ffee8962aed53ce0509aa2cc100d5d67e59dac76c2d8159655a702e0c3f454d218b070129f785be59
+DIST fetchmail-6.4.39.tar.xz 1221596 BLAKE2B 2d03f6668d2882e7dd1d4e83e8643a2a4c81576a143c75ff1b24327873fa6112fa313f9723373a268e04697b76b3b638cbbd7a04c21cba946cd1532b6aaf201d SHA512 979721aead72c9b706f9c64a83cf78a91890f5a2dce235b3b4f0dbdb17e879eaef2fb9a08efb415cb288ebee07c915adc8025a6d2d11f532fb95a9e30f93f7f5
diff --git a/net-mail/fetchmail/fetchmail-6.4.39.ebuild b/net-mail/fetchmail/fetchmail-6.4.39.ebuild
new file mode 100644
index 000000000000..0865aa799592
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.4.39.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools systemd tmpfiles toolchain-funcs
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="https://www.fetchmail.info/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris"
+IUSE="ssl nls kerberos tk selinux socks"
+
+RDEPEND="acct-user/fetchmail
+ ssl? ( >=dev-libs/openssl-3.0.9:= )
+ kerberos? ( virtual/krb5 )
+ nls? ( virtual/libintl )
+ !elibc_glibc? ( sys-fs/e2fsprogs )
+ socks? ( net-proxy/dante )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ app-alternatives/lex
+ nls? ( sys-devel/gettext )"
+RDEPEND+=" selinux? ( sec-policy/selinux-fetchmail )"
+
+REQUIRED_USE="kerberos? ( ssl )"
+
+DOCS="FAQ FEATURES NEWS NOTES README README.NTLM README.SSL* TODO"
+HTML_DOCS="*.html"
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.3.26-python-optional.patch
+)
+S=${WORKDIR}/${P/_/.}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ export PYTHON=:
+
+ econf \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ $(use_enable nls) \
+ $(use_with ssl ssl "${EPREFIX}/usr") \
+ $(use_with kerberos gssapi) \
+ $(use_with kerberos kerberos5) \
+ --without-hesiod \
+ $(use_with socks)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/fetchmail.initd fetchmail
+ newconfd "${FILESDIR}"/fetchmail.confd fetchmail
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ systemd_newunit "${FILESDIR}"/${PN}_at.service "${PN}@.service"
+ dotmpfiles "${FILESDIR}"/${PN}.conf
+
+ docinto contrib
+ local f
+ for f in contrib/* ; do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Please see /etc/conf.d/fetchmail if you want to adjust"
+ elog "the polling delay used by the fetchmail init script."
+ fi
+}