summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2022-05-28 11:20:04 +0300
committerEray Aslan <eras@gentoo.org>2022-05-28 11:20:29 +0300
commit2a7b70d6874dfd700cc9c92f0e51c0594366b201 (patch)
tree7448f5e469e7416b5a76446b72790c155d45df08 /net-mail
parentmail-mta/postfix: add 3.8_pre20220527, drop 3.8_pre20220509 (diff)
downloadgentoo-2a7b70d6874dfd700cc9c92f0e51c0594366b201.tar.gz
gentoo-2a7b70d6874dfd700cc9c92f0e51c0594366b201.tar.bz2
gentoo-2a7b70d6874dfd700cc9c92f0e51c0594366b201.zip
net-mail/mailbase: add 1.8.1
copiousoutput and needsterminal do not make sense when used together. one is "does no interaction with the user" and the other "needs to interact with the user". Signed-off-by: Eray Aslan <eras@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mailbase/files/mailcap-r430
-rw-r--r--net-mail/mailbase/mailbase-1.8.1.ebuild44
2 files changed, 74 insertions, 0 deletions
diff --git a/net-mail/mailbase/files/mailcap-r4 b/net-mail/mailbase/files/mailcap-r4
new file mode 100644
index 000000000000..8c1bd310e3de
--- /dev/null
+++ b/net-mail/mailbase/files/mailcap-r4
@@ -0,0 +1,30 @@
+# Database binding MIME types to programs that can process them.
+# This file is generally used by mail clients to view attachments.
+#
+# Users should add their own rules to their ~/.mailcap file. That file will be
+# processed first before falling back to this one.
+#
+# For more information, see the mailcap(5) man page.
+
+# NB: Do not quote %s. Clients will handle expanding it with proper quoting,
+# so adding quotes ourselves just confuses things.
+
+application/pdf; xdg-open %s; needsterminal
+application/postscript; xdg-open %s; needsterminal
+application/x-info; info --subnodes -o /dev/stdout -f %s 2>/dev/null; copiousoutput; description=GNU Info document
+application/x-gtar; tar tvzf -; print=tar tvzf - | print text/plain:-; copiousoutput
+application/x-tar; tar tvf -; print=tar tvf - | print text/plain:-; copiousoutput
+application/x-troff-man; nroff -mandoc -Tutf8; copiousoutput; print=nroff -mandoc -Tutf8 | print text/plain:-
+# It'd be nice to limit this to compressed formats (e.g. x-*), but the file
+# format doesn't support that, and less has good fallbacks already.
+application/*; less %s; needsterminal
+
+audio/*; xdg-open %s; needsterminal
+image/*; xdg-open %s; needsterminal
+
+text/html; lynx -dump -assume_charset=%{charset} %s; copiousoutput; description=HTML Text; nametemplate=%s.html
+text/troff; man -l %s; needsterminal; description=Man page
+text/*; less %s; needsterminal
+text/*; gview %s; edit=gvim -f %s; compose=gvim -f %s; test=test "$DISPLAY" != ""
+text/*; view %s; edit=vim %s; compose=vim %s; needsterminal
+text/*; more %s; needsterminal
diff --git a/net-mail/mailbase/mailbase-1.8.1.ebuild b/net-mail/mailbase/mailbase-1.8.1.ebuild
new file mode 100644
index 000000000000..31a62191a865
--- /dev/null
+++ b/net-mail/mailbase/mailbase-1.8.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit pam
+
+DESCRIPTION="MTA layout package"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+S=${WORKDIR}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="pam"
+
+RDEPEND="
+ acct-group/mail
+ acct-user/mail
+ acct-user/postmaster
+ pam? ( sys-libs/pam )
+"
+
+src_install() {
+ insinto /etc/mail
+ doins "${FILESDIR}"/aliases
+ insinto /etc
+ newins "${FILESDIR}"/mailcap-r4 mailcap
+ doman "${FILESDIR}"/mailcap.5
+
+ dosym spool/mail /var/mail
+
+ if use pam ; then
+ newpamd "${FILESDIR}"/common-pamd-include pop
+ newpamd "${FILESDIR}"/common-pamd-include imap
+ local p
+ for p in pop3 pop3s pops ; do
+ dosym pop /etc/pam.d/${p}
+ done
+ for p in imap4 imap4s imaps ; do
+ dosym imap /etc/pam.d/${p}
+ done
+ fi
+}