summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Seichter <github@seichter.de>2024-07-05 20:36:30 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-08-10 10:09:02 +0300
commit228d53133b6a97480b562ca1862a3725fe37e79c (patch)
tree02948a0644022b4ff3be42d8ac6d20081f5f3076 /net-mail
parentx11-misc/x11vnc: fix build on 32bit arches with 64bit time_t (diff)
downloadgentoo-228d53133b6a97480b562ca1862a3725fe37e79c.tar.gz
gentoo-228d53133b6a97480b562ca1862a3725fe37e79c.tar.bz2
gentoo-228d53133b6a97480b562ca1862a3725fe37e79c.zip
net-mail/automx2: add 2024.2
Bump to automx2 version 2024.2 (bugfix & feature release). Signed-off-by: Ralph Seichter <github@seichter.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/automx2/Manifest1
-rw-r--r--net-mail/automx2/automx2-2024.2.ebuild45
-rw-r--r--net-mail/automx2/files/automx2-2024.2-setupcfg.patch13
3 files changed, 59 insertions, 0 deletions
diff --git a/net-mail/automx2/Manifest b/net-mail/automx2/Manifest
index 09d4d97cdb2b..d34d7dbed896 100644
--- a/net-mail/automx2/Manifest
+++ b/net-mail/automx2/Manifest
@@ -1 +1,2 @@
DIST automx2-2022.1.tar.gz 182519 BLAKE2B baf2ecc801f6f024eb6a6fe2610d6cb7c3dd0726cfa877fdea76d94ebf16b9393addc5be8844f3017fd664b73adc74f2cd898736bbcad1fa0b2b3c1022cb638a SHA512 3d6fb9cf01cff641c78851560d72e3d80f9011cca4cd438cd49e999feef3f290bbd9495655f41319eb5456beac09bb8862dc327b521254266e0d53aa17b0bbd3
+DIST automx2-2024.2.tar.gz 169710 BLAKE2B 1977e07291d27168424e536273af4069d0cbe4c44e2c37fc10b4d0a2fa53272c404aae6dbb8b0a33dd9926e9fc94aae7cd3c6e5669454dad802e6a6ad85bfaf6 SHA512 de518e7eb5184d5dcd7945ab860250c6338e3343a9c4bba26bcdd68b4cb1d22de9624c329ff63af1420746a17ea220ad6d4bbda627af64f7ddcc5ae73275e5dd
diff --git a/net-mail/automx2/automx2-2024.2.ebuild b/net-mail/automx2/automx2-2024.2.ebuild
new file mode 100644
index 000000000000..598ce69b2d1f
--- /dev/null
+++ b/net-mail/automx2/automx2-2024.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11,12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Email client autoconfiguration service"
+HOMEPAGE="https://rseichter.github.io/automx2/"
+SRC_URI="https://github.com/rseichter/automx2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="acct-user/automx2
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-migrate[${PYTHON_USEDEP}]
+ dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/ldap3[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-setupcfg.patch"
+)
+
+distutils_enable_tests unittest
+
+python_test() {
+ local -x AUTOMX2_CONF="tests/unittest.conf"
+ eunittest tests/
+}
+
+python_install_all() {
+ local DOCS=( "${S}"/docs/*.adoc "${S}"/contrib/*sample.conf )
+ local HTML_DOCS=( "${S}"/docs/*.{html,svg} )
+ newconfd "${FILESDIR}/confd" "${PN}"
+ newinitd "${FILESDIR}/init-r1" "${PN}"
+ insinto /etc
+ newins "${FILESDIR}/conf" "${PN}.conf"
+ distutils-r1_python_install_all
+}
diff --git a/net-mail/automx2/files/automx2-2024.2-setupcfg.patch b/net-mail/automx2/files/automx2-2024.2-setupcfg.patch
new file mode 100644
index 000000000000..07a68305f44f
--- /dev/null
+++ b/net-mail/automx2/files/automx2-2024.2-setupcfg.patch
@@ -0,0 +1,13 @@
+diff --color -r -u a/setup.cfg b/setup.cfg
+--- a/setup.cfg 2024-02-21 05:58:03.000000000 +0100
++++ b/setup.cfg 2024-07-08 18:27:14.404495000 +0200
+@@ -51,6 +51,9 @@
+ packages = find:
+ python_requires = >=3.7
+
++[options.packages.find]
++exclude = test*
++
+ [options.package_data]
+ * =
+ contrib/flask.sh