summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2019-02-26 17:37:33 +0300
committerEray Aslan <eras@gentoo.org>2019-02-26 17:37:33 +0300
commit5cda653f481a0f4e17309af05290b425b8d2c53b (patch)
tree58702afeb11c9baac8bdb63c1693aacd7baf1a96 /net-mail/mailutils/files
parentdev-python/curtsies: depend on dev-python/typing correctly (diff)
downloadgentoo-5cda653f481a0f4e17309af05290b425b8d2c53b.tar.gz
gentoo-5cda653f481a0f4e17309af05290b425b8d2c53b.tar.bz2
gentoo-5cda653f481a0f4e17309af05290b425b8d2c53b.zip
net-mail/mailutils: bump to 3.6
and fix underlinking Closes: https://bugs.gentoo.org/677762 Closes: https://bugs.gentoo.org/665996 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Eray Aslan <eras@gentoo.org>
Diffstat (limited to 'net-mail/mailutils/files')
-rw-r--r--net-mail/mailutils/files/mailutils-3.6-python3.patch59
-rw-r--r--net-mail/mailutils/files/mailutils-3.6-underlinking.patch11
2 files changed, 70 insertions, 0 deletions
diff --git a/net-mail/mailutils/files/mailutils-3.6-python3.patch b/net-mail/mailutils/files/mailutils-3.6-python3.patch
new file mode 100644
index 000000000000..cad46d006a2a
--- /dev/null
+++ b/net-mail/mailutils/files/mailutils-3.6-python3.patch
@@ -0,0 +1,59 @@
+From 4e66a6a9e5f5696d60f7df875175f2e0ad8f7376 Mon Sep 17 00:00:00 2001
+From: Sergey Poznyakoff <gray@gnu.org>
+Date: Sun, 24 Feb 2019 22:56:21 +0200
+Subject: Bugfix
+
+* python/3/libmu_py/mailcap.c: Fix leftover uses of PyString_FromString
+and PyInt_FromLong.
+---
+ python/3/libmu_py/mailcap.c | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/python/3/libmu_py/mailcap.c b/python/3/libmu_py/mailcap.c
+index 6db1770..fdb5b71 100644
+--- a/python/3/libmu_py/mailcap.c
++++ b/python/3/libmu_py/mailcap.c
+@@ -91,11 +91,11 @@ api_mailcap_create (PyObject *self, PyObject *args)
+
+ status = mu_mailcap_create (&py_mc->mc);
+ if (status)
+- return _ro (PyInt_FromLong (status));
++ return _ro (PyLong_FromLong (status));
+ status = mu_mailcap_parse (py_mc->mc, py_stm->stm, NULL);
+ if (status == MU_ERR_PARSE)
+ status = 0; /* FIXME */
+- return _ro (PyInt_FromLong (status));
++ return _ro (PyLong_FromLong (status));
+ }
+
+ static PyObject *
+@@ -183,7 +183,7 @@ api_mailcap_entry_get_field (PyObject *self, PyObject *args)
+ status = mu_mailcap_entry_sget_field (py_entry->entry, name, &value);
+ return status_object (status,
+ status == 0
+- ? (value ? PyString_FromString (value)
++ ? (value ? PyUnicode_FromString (value)
+ : PyBool_FromLong (1))
+ : PyBool_FromLong (0));
+ }
+@@ -199,7 +199,7 @@ api_mailcap_entry_get_typefield (PyObject *self, PyObject *args)
+ return NULL;
+
+ status = mu_mailcap_entry_sget_type (py_entry->entry, &value);
+- return status_object (status, PyString_FromString (status == 0 ? value : ""));
++ return status_object (status, PyUnicode_FromString (status == 0 ? value : ""));
+ }
+
+ static PyObject *
+@@ -213,7 +213,7 @@ api_mailcap_entry_get_viewcommand (PyObject *self, PyObject *args)
+ return NULL;
+
+ status = mu_mailcap_entry_sget_command (py_entry->entry, &value);
+- return status_object (status, PyString_FromString (status == 0 ? value : ""));
++ return status_object (status, PyUnicode_FromString (status == 0 ? value : ""));
+ }
+
+ static PyMethodDef methods[] = {
+--
+cgit v1.0-41-gc330
+
diff --git a/net-mail/mailutils/files/mailutils-3.6-underlinking.patch b/net-mail/mailutils/files/mailutils-3.6-underlinking.patch
new file mode 100644
index 000000000000..512a05f3a313
--- /dev/null
+++ b/net-mail/mailutils/files/mailutils-3.6-underlinking.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac 2019-02-26 17:11:29.398115222 +0300
++++ b/configure.ac 2019-02-26 17:14:13.733899654 +0300
+@@ -985,7 +985,7 @@
+ AC_CHECK_LIB(ldap, ldap_bind,[
+ status_ldap=yes
+ AC_DEFINE(WITH_LDAP, 1, [Define to 1 if you want to use -lldap])
+- MU_AUTHLIBS="$MU_AUTHLIBS -lldap"],
++ MU_AUTHLIBS="$MU_AUTHLIBS -lldap -llber"],
+ [status_ldap=no])
+ fi
+