summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2025-02-17 00:55:32 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2025-02-17 17:46:47 +0100
commitd8818952a9727aa74db9dc7f7e0b1ad867712665 (patch)
treeaba94090f3891a894352cdded2f9b8ee27dea2c2 /net-libs
parentsys-kernel/gentoo-sources: GCC15 fixes, thanks Holgar (diff)
downloadgentoo-d8818952a9727aa74db9dc7f7e0b1ad867712665.tar.gz
gentoo-d8818952a9727aa74db9dc7f7e0b1ad867712665.tar.bz2
gentoo-d8818952a9727aa74db9dc7f7e0b1ad867712665.zip
net-libs/qxmpp: drop 1.5.5, 1.9.3; no stable revdeps
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/qxmpp/Manifest2
-rw-r--r--net-libs/qxmpp/qxmpp-1.5.5.ebuild57
-rw-r--r--net-libs/qxmpp/qxmpp-1.9.3.ebuild54
3 files changed, 0 insertions, 113 deletions
diff --git a/net-libs/qxmpp/Manifest b/net-libs/qxmpp/Manifest
index 0080ea99411b..1e706851fd12 100644
--- a/net-libs/qxmpp/Manifest
+++ b/net-libs/qxmpp/Manifest
@@ -1,3 +1 @@
-DIST qxmpp-1.5.5.tar.gz 606405 BLAKE2B 999dfcaa601f1d79df97febcd63bfcdcce87de9c0e68db6c1253407c89414003f326011a9a5e366031f78ddae084d06f04851ab3f4573ee53c59567770ae0edc SHA512 39774655fdb87dc54f32f7a018d4964c9ff8e9bebedd9cc94e6ad41288bd67365eec524525de09c5a3d2ea274e418fc6d5497ac2c1927946154cadaf7fc0d655
-DIST qxmpp-1.9.3.tar.gz 725634 BLAKE2B 1212596e53ccf92bc83d9676a2e8e6c773b92e40cfa71daccb52da647245a8b0ddef5789c6a1586089fac9aab0560f70853d7db3f570291b0718e0f6f8c3ba09 SHA512 80a81c9d13c8155fc1d219f52c38d0370192acf51f2ebcff52c7ecd1d342e60e188d5eb19a7bc961f9e3bc5aeea77ecc1efd2bbe59e36988954c18bb210285cd
DIST qxmpp-1.9.4.tar.gz 725814 BLAKE2B 435321095d0d1ae707000dd954aeaf73cf11192f516fc345d0911e1c5a7099d6217d5313499ae2a639d948d35af8f5fdd93faf7ac2484c6c66e5d0ca979d7251 SHA512 ae1620af13bc998406258c6997875fe2b5922c4318a9544879bed45b408ea9b585ee56b12c8db6dd04aa28e5bd327bf202a5ce2e47513144f1310fa3f054556f
diff --git a/net-libs/qxmpp/qxmpp-1.5.5.ebuild b/net-libs/qxmpp/qxmpp-1.5.5.ebuild
deleted file mode 100644
index 943f6c7e5580..000000000000
--- a/net-libs/qxmpp/qxmpp-1.5.5.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="A cross-platform C++ XMPP client library based on the Qt framework"
-HOMEPAGE="https://github.com/qxmpp-project/qxmpp"
-SRC_URI="https://github.com/${PN}-project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc gstreamer omemo test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-qt/qtcore:5
- dev-qt/qtnetwork:5[ssl]
- dev-qt/qtxml:5
- gstreamer? ( media-libs/gstreamer )
- omemo? (
- app-crypt/qca:2[qt5(+)]
- net-libs/libomemo-c
- )
-"
-DEPEND="${RDEPEND}
- test? ( dev-qt/qttest:5 )
-"
-BDEPEND="
- doc? ( app-text/doxygen )
-"
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_DOCUMENTATION=$(usex doc)
- -DBUILD_EXAMPLES=OFF
- -DBUILD_TESTS=$(usex test)
- -DBUILD_INTERNAL_TESTS=$(usex test)
- -DBUILD_OMEMO=$(usex omemo)
- -DWITH_QCA=$(usex omemo)
- -DWITH_GSTREAMER=$(usex gstreamer)
- -DQT_VERSION_MAJOR=5
- )
-
- cmake_src_configure
-}
-
-src_test() {
- local myctestargs=(
- # require network connection, bug #623708
- -E "tst_(qxmpptransfermanager|qxmppiceconnection)"
- )
-
- cmake_src_test
-}
diff --git a/net-libs/qxmpp/qxmpp-1.9.3.ebuild b/net-libs/qxmpp/qxmpp-1.9.3.ebuild
deleted file mode 100644
index e847bd3c9cc5..000000000000
--- a/net-libs/qxmpp/qxmpp-1.9.3.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2025 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="A cross-platform C++ XMPP client library based on the Qt framework"
-HOMEPAGE="https://github.com/qxmpp-project/qxmpp"
-SRC_URI="https://github.com/${PN}-project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1 CC0-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc gstreamer omemo test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-qt/qtbase:6[network,ssl,xml]
- dev-qt/qt5compat:6
- gstreamer? ( media-libs/gstreamer )
- omemo? (
- app-crypt/qca:2[qt6(+)]
- net-libs/libomemo-c
- )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- doc? ( app-text/doxygen )
-"
-
-src_configure() {
- local mycmakeargs=(
- -DQT_VERSION_MAJOR=6
- -DBUILD_DOCUMENTATION=$(usex doc)
- -DBUILD_EXAMPLES=OFF
- -DBUILD_TESTS=$(usex test)
- -DBUILD_INTERNAL_TESTS=$(usex test)
- -DBUILD_OMEMO=$(usex omemo)
- -DWITH_QCA=$(usex omemo)
- -DWITH_GSTREAMER=$(usex gstreamer)
- )
-
- cmake_src_configure
-}
-
-src_test() {
- local myctestargs=(
- # require network connection, bug #623708
- -E "tst_(qxmpptransfermanager|qxmppiceconnection)"
- )
-
- cmake_src_test
-}