summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-03-26 13:39:06 -0400
committerMike Frysinger <vapier@gentoo.org>2016-03-26 14:06:38 -0400
commit99fb715b09406fa544ccbdeb2ba0eb0e6dc19b51 (patch)
treed71b95674fc7abbc426508c722dc0fcf1c79b7ab /net-libs
parentwww-apps/icingaweb2-module-pnp4nagios: amd64 stable wrt bug #578100 (diff)
downloadgentoo-99fb715b09406fa544ccbdeb2ba0eb0e6dc19b51.tar.gz
gentoo-99fb715b09406fa544ccbdeb2ba0eb0e6dc19b51.tar.bz2
gentoo-99fb715b09406fa544ccbdeb2ba0eb0e6dc19b51.zip
net-libs/nghttp2: version bump to 1.9.0
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nghttp2/Manifest1
-rw-r--r--net-libs/nghttp2/nghttp2-1.9.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index 69054fce2a68..82fd17c74a24 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -2,3 +2,4 @@ DIST nghttp2-1.6.0.tar.gz 1983953 SHA256 c88012e87b80c055ddd2412efd7e96b9e8cfe06
DIST nghttp2-1.7.0.tar.gz 2001726 SHA256 f0be9560baa30fc56bcce0151d88126d71b91815bb47076a8dd9ad2b9023ff49 SHA512 556a81ef9bad8a75a23b13532e6066af4412d79fa8dbde508ea893780bc9b19e0525674dc1cfb04b25cc48d62ae704737d6c4b1aa2b442a2be514b72490f6c1b WHIRLPOOL 138bb50c85ef7838be919989c032157ecedbfe1d5bf28633d5ee0c3d6f18dc7fa7525e185d476d146788466b58db0a2104054a1a28cb5152a8c4e9652fcb22ba
DIST nghttp2-1.7.1.tar.gz 1993320 SHA256 d83858464c03555828bb603288b66a48680bf164b376d2459a5407c102098a14 SHA512 3a71153d2b30a69e79115402b7db9a04bc812025ccb67b918079f33690f18eb5b286095b8bc161df91abf6466b6bb822ecc13c49bee54265a06ba9ab7c289b54 WHIRLPOOL 41d0afd43878029069d2c339e22b8aec77fedbd1b0fb45da96b9592525c760731e2eec567999af704d63cf94c913b1d0c52063380e69170e1f2d2b928c1d70f3
DIST nghttp2-1.8.0.tar.gz 2021815 SHA256 3ac8cdf47c744cb387e6c867fe8c9a449254e9fab7fdf96782f9eaf7f635320a SHA512 447ee232abb9ea4105044567baabedc471089af7dfe72219f7c830898d3cd9bc63351d187129e43331cc775702f8dbe2afd21a2c88dc5191b858539dcb7c61d2 WHIRLPOOL b3ec7eae828c240dcd2c972d8148ceb6f2476fe8b6b8636c38b68b236e91915f07851a19a1e9daae27c636eb68898b8675e33b9e13d75c51ef99f56d992908dd
+DIST nghttp2-1.9.0.tar.gz 2058664 SHA256 d4ab680ba4308073848bd864b76dae545c7eee38b58dd2e73c661378b10e9a59 SHA512 b07dee045dd8647ce1be1617210fa7a7d7286762d28ddefdc95198988333f4fbc07f66769950e4851e8124eeefe26a557fe4c9be6b8e78476ca0f94a84ffe0ea WHIRLPOOL 70109e735dd72800543c79f3b002e8d8fad9f818f5550338e745e164343ba329c55d04d7a426013ad562b77d732d54861f739d751780f110eaf31ee002cd94d7
diff --git a/net-libs/nghttp2/nghttp2-1.9.0.ebuild b/net-libs/nghttp2/nghttp2-1.9.0.ebuild
new file mode 100644
index 000000000000..f035e7eafded
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.9.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# TODO: Add python support.
+
+EAPI="5"
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/tatsuhiro-t/nghttp2.git"
+ inherit git-2
+else
+ SRC_URI="https://github.com/tatsuhiro-t/nghttp2/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
+
+RDEPEND="
+ cxx? ( dev-libs/boost:=[${MULTILIB_USEDEP},threads] )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
+ jemalloc? ( dev-libs/jemalloc )
+ utils? (
+ >=dev-libs/libev-4.15
+ !libressl? ( >=dev-libs/openssl-1.0.2:0[-bindist] )
+ libressl? ( dev-libs/libressl )
+ >=sys-libs/zlib-1.2.3
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-examples \
+ --disable-failmalloc \
+ --disable-werror \
+ --without-cython \
+ --disable-python-bindings \
+ --without-spdylay \
+ $(use_enable cxx asio-lib) \
+ $(use_enable debug) \
+ $(multilib_native_use_enable hpack-tools) \
+ $(use_enable static-libs static) \
+ $(use_enable threads) \
+ $(multilib_native_use_enable utils app) \
+ $(multilib_native_use_with jemalloc) \
+ $(multilib_native_use_with xml libxml2)
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED}"/usr -name '*.la' -delete
+}