summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Hoffstätte <holger@applied-asynchrony.com>2024-09-04 10:32:42 +0200
committerSam James <sam@gentoo.org>2024-09-04 09:39:28 +0100
commit8ca9fa4e05dea29e5e3f2685b54b09d600a8c2b2 (patch)
treef72a648ac46bf456cc0658334868692001c8ee9c /net-libs
parentdev-vcs/pre-commit: add python 3.10 compat for autojump (diff)
downloadgentoo-8ca9fa4e05dea29e5e3f2685b54b09d600a8c2b2.tar.gz
gentoo-8ca9fa4e05dea29e5e3f2685b54b09d600a8c2b2.tar.bz2
gentoo-8ca9fa4e05dea29e5e3f2685b54b09d600a8c2b2.zip
net-libs/grpc: fix build against abseil-cpp-20240722.0
Closes: https://bugs.gentoo.org/939015 Signed-off-by: Holger Hoffstätte <holger@applied-asynchrony.com> Closes: https://github.com/gentoo/gentoo/pull/38422 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/grpc/files/grpc-1.65.0-vlog.patch17
-rw-r--r--net-libs/grpc/grpc-1.65.1.ebuild1
2 files changed, 18 insertions, 0 deletions
diff --git a/net-libs/grpc/files/grpc-1.65.0-vlog.patch b/net-libs/grpc/files/grpc-1.65.0-vlog.patch
new file mode 100644
index 000000000000..e57c0ba222b3
--- /dev/null
+++ b/net-libs/grpc/files/grpc-1.65.0-vlog.patch
@@ -0,0 +1,17 @@
+
+Fix build with abseil-cpp-20240722.0 which no longer implicitly
+includes absl/log/vlog_is_on.h
+
+See: https://github.com/abseil/abseil-cpp/releases/tag/20240722.0
+Bug: https://bugs.gentoo.org/939015
+
+--- grpc-1.65.1/src/core/util/log.cc~ 2024-07-17 00:53:49.000000000 +0200
++++ grpc-1.65.1/src/core/util/log.cc 2024-09-04 09:28:18.494476262 +0200
+@@ -19,6 +19,7 @@
+ #include <grpc/support/port_platform.h>
+
+ #include "absl/log/log.h"
++#include "absl/log/vlog_is_on.h"
+
+ #include <stdio.h>
+ #include <string.h>
diff --git a/net-libs/grpc/grpc-1.65.1.ebuild b/net-libs/grpc/grpc-1.65.1.ebuild
index 448a008c7796..3fbe1dcd6309 100644
--- a/net-libs/grpc/grpc-1.65.1.ebuild
+++ b/net-libs/grpc/grpc-1.65.1.ebuild
@@ -56,6 +56,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-1.65.0-system-gtest.patch"
+ "${FILESDIR}/${PN}-1.65.0-vlog.patch"
)
python_check_deps() {