summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-10-15 19:40:42 -0700
committerDavid Seifert <soap@gentoo.org>2017-10-15 19:47:37 -0700
commit450566e7fae4a5f41ecdcc680cdab8301c52bd94 (patch)
tree584a2091dd63ec9f07135358824a40fdf08d8ced /net-libs
parentnet-libs/libwebsockets: [QA] Add cmake-utils_src_prepare (diff)
downloadgentoo-450566e7fae4a5f41ecdcc680cdab8301c52bd94.tar.gz
gentoo-450566e7fae4a5f41ecdcc680cdab8301c52bd94.tar.bz2
gentoo-450566e7fae4a5f41ecdcc680cdab8301c52bd94.zip
net-libs/polarssl: [QA] Add cmake-utils_src_prepare
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/polarssl/polarssl-1.3.9-r1.ebuild6
-rw-r--r--net-libs/polarssl/polarssl-1.3.9.ebuild6
2 files changed, 8 insertions, 4 deletions
diff --git a/net-libs/polarssl/polarssl-1.3.9-r1.ebuild b/net-libs/polarssl/polarssl-1.3.9-r1.ebuild
index a8b641680e7f..01f8abbeec11 100644
--- a/net-libs/polarssl/polarssl-1.3.9-r1.ebuild
+++ b/net-libs/polarssl/polarssl-1.3.9-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -24,6 +24,8 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen media-gfx/graphviz )
test? ( dev-lang/perl )"
+PATCHES=( "${FILESDIR}"/${PN}-1.3.9-respect-cflags.patch )
+
enable_polarssl_option() {
local myopt="$@"
# check that config.h syntax is the same at version bump
@@ -39,7 +41,7 @@ src_prepare() {
use threads && enable_polarssl_option POLARSSL_THREADING_C
use threads && enable_polarssl_option POLARSSL_THREADING_PTHREAD
- epatch "${FILESDIR}"/${PN}-1.3.9-respect-cflags.patch
+ cmake-utils_src_prepare
}
multilib_src_configure() {
diff --git a/net-libs/polarssl/polarssl-1.3.9.ebuild b/net-libs/polarssl/polarssl-1.3.9.ebuild
index 1e9b0680450e..6dce83e4878f 100644
--- a/net-libs/polarssl/polarssl-1.3.9.ebuild
+++ b/net-libs/polarssl/polarssl-1.3.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -21,6 +21,8 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen media-gfx/graphviz )
test? ( dev-lang/perl )"
+PATCHES=( "${FILESDIR}"/${PN}-1.3.9-respect-cflags.patch )
+
enable_polarssl_option() {
local myopt="$@"
# check that config.h syntax is the same at version bump
@@ -36,7 +38,7 @@ src_prepare() {
use threads && enable_polarssl_option POLARSSL_THREADING_C
use threads && enable_polarssl_option POLARSSL_THREADING_PTHREAD
- epatch "${FILESDIR}"/${PN}-1.3.9-respect-cflags.patch
+ cmake-utils_src_prepare
}
multilib_src_configure() {