summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-04-01 20:32:51 -0400
committerMatt Turner <mattst88@gentoo.org>2023-04-01 20:56:52 -0400
commit78b8ae45f7267ffb506f53f14d0e4c345e3d8b66 (patch)
tree31e77c57b8dc69232c46c8412e81f9be363b0462 /net-libs/rest
parentnet-libs/glib-networking: Drop old versions (diff)
downloadgentoo-78b8ae45f7267ffb506f53f14d0e4c345e3d8b66.tar.gz
gentoo-78b8ae45f7267ffb506f53f14d0e4c345e3d8b66.tar.bz2
gentoo-78b8ae45f7267ffb506f53f14d0e4c345e3d8b66.zip
net-libs/rest: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-libs/rest')
-rw-r--r--net-libs/rest/rest-0.9.1.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/net-libs/rest/rest-0.9.1.ebuild b/net-libs/rest/rest-0.9.1.ebuild
deleted file mode 100644
index 545813a842ca..000000000000
--- a/net-libs/rest/rest-0.9.1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit gnome.org meson vala
-
-DESCRIPTION="Helper library for RESTful services"
-HOMEPAGE="https://wiki.gnome.org/Projects/Librest"
-
-LICENSE="LGPL-2.1"
-SLOT="1.0" # librest_soversion
-KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv sparc x86"
-IUSE="gtk-doc +introspection test vala"
-REQUIRED_USE="
- gtk-doc? ( introspection )
- vala? ( introspection )
-"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-libs/glib-2.44.0:2
- >=net-libs/libsoup-2.99.2:3.0
- dev-libs/json-glib:0[introspection?]
- dev-libs/libxml2:2
- app-misc/ca-certificates
- introspection? ( >=dev-libs/gobject-introspection-1.74.0:= )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-util/glib-utils
- gtk-doc? ( >=dev-util/gi-docgen-2021.6 )
- vala? ( $(vala_depend) )
-"
-
-src_prepare() {
- default
- vala_setup
-
- # The only two tests from the rest-extras suite (flickr and lastfm) require
- # network access
- if has network-sandbox ${FEATURES}; then
- sed -i -e '/flickr/d' -e '/lastfm/d' tests/meson.build
- fi
-}
-
-src_configure() {
- local emesonargs=(
- -Dca_certificates=true
- -Dca_certificates_path="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt
- $(meson_use introspection)
- $(meson_use vala vapi)
- -Dexamples=false
- $(meson_use gtk-doc gtk_doc)
- -Dsoup2=false
- $(meson_use test tests)
- )
- meson_src_configure
-}