summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-06-10 23:46:28 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-06-10 23:49:24 +0200
commit84563b4ddff03dafc9a3a2edf0d9a41f2ede49c7 (patch)
tree4ed9fcfbf504119b05c2482a9dc3f668eff2d84e /net-libs/librouteros/librouteros-1.1.3.ebuild
parentdev-lang/R: Stabilize 4.2.0 sparc, #851024 (diff)
downloadgentoo-84563b4ddff03dafc9a3a2edf0d9a41f2ede49c7.tar.gz
gentoo-84563b4ddff03dafc9a3a2edf0d9a41f2ede49c7.tar.bz2
gentoo-84563b4ddff03dafc9a3a2edf0d9a41f2ede49c7.zip
net-libs/librouteros: add 1.1.3
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-libs/librouteros/librouteros-1.1.3.ebuild')
-rw-r--r--net-libs/librouteros/librouteros-1.1.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-libs/librouteros/librouteros-1.1.3.ebuild b/net-libs/librouteros/librouteros-1.1.3.ebuild
new file mode 100644
index 000000000000..663f240b6072
--- /dev/null
+++ b/net-libs/librouteros/librouteros-1.1.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Library for accessing MikroTik's RouterOS via its API"
+HOMEPAGE="https://octo.github.io/librouteros/"
+SRC_URI="https://github.com/octo/${PN}/archive/refs/tags/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="dev-libs/libgcrypt:0="
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -e 's/-Werror//g' -i src/Makefile.am || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}