summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-17 01:08:32 +0100
committerSam James <sam@gentoo.org>2021-10-17 01:09:06 +0100
commitd5b5288d2eda333a283575c184c61f062cea7918 (patch)
treeef823e8d894384c8cc43f965de123894661b89ad /net-libs/libnids/libnids-1.24-r8.ebuild
parentdev-python/cachelib: skip fragile Redis tests (diff)
downloadgentoo-d5b5288d2eda333a283575c184c61f062cea7918.tar.gz
gentoo-d5b5288d2eda333a283575c184c61f062cea7918.tar.bz2
gentoo-d5b5288d2eda333a283575c184c61f062cea7918.zip
net-libs/libnids: don't inline exported functions
Closes: https://bugs.gentoo.org/818517 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/libnids/libnids-1.24-r8.ebuild')
-rw-r--r--net-libs/libnids/libnids-1.24-r8.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-libs/libnids/libnids-1.24-r8.ebuild b/net-libs/libnids/libnids-1.24-r8.ebuild
new file mode 100644
index 000000000000..a993c8d91295
--- /dev/null
+++ b/net-libs/libnids/libnids-1.24-r8.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic toolchain-funcs
+
+DESCRIPTION="an implementation of an E-component of Network Intrusion Detection System"
+HOMEPAGE="http://libnids.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="1.2"
+KEYWORDS="amd64 ppc x86"
+IUSE="+glib +libnet static-libs"
+
+RDEPEND="!net-libs/libnids:1.1
+ net-libs/libpcap
+ glib? ( dev-libs/glib:2 )
+ libnet? ( >=net-libs/libnet-1.1.0-r3 )"
+DEPEND="${RDEPEND}"
+BDEPEND="glib? ( virtual/pkgconfig )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${P}-libdir.patch
+ "${FILESDIR}"/${P}-static-libs.patch
+ "${FILESDIR}"/${P}-no-inline.patch
+)
+
+src_prepare() {
+ default
+ eautoconf
+}
+
+src_configure() {
+ tc-export AR
+
+ append-flags -fno-strict-aliasing
+
+ econf \
+ --enable-shared \
+ $(usex glib '' --disable-libglib) \
+ $(use_enable libnet)
+}
+
+src_compile() {
+ emake shared $(usex static-libs static '')
+}
+
+src_install() {
+ local tgt
+ for tgt in _installshared $(usex static-libs _install ''); do
+ emake install_prefix="${D}" ${tgt}
+ done
+
+ dodoc CHANGES CREDITS MISC README doc/*
+}