summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libnfnetlink
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libnfnetlink')
-rw-r--r--net-libs/libnfnetlink/Manifest1
-rw-r--r--net-libs/libnfnetlink/libnfnetlink-1.0.1.ebuild46
-rw-r--r--net-libs/libnfnetlink/metadata.xml5
3 files changed, 52 insertions, 0 deletions
diff --git a/net-libs/libnfnetlink/Manifest b/net-libs/libnfnetlink/Manifest
new file mode 100644
index 000000000000..ad35fba0b5ad
--- /dev/null
+++ b/net-libs/libnfnetlink/Manifest
@@ -0,0 +1 @@
+DIST libnfnetlink-1.0.1.tar.bz2 320641 SHA256 f270e19de9127642d2a11589ef2ec97ef90a649a74f56cf9a96306b04817b51a SHA512 2ec2cd389c04e21c8a02fb3f6d6f326fc33ca9589577f1739c23d883fe2ee9feaa16e83b6ed09063ad886432e49565dc3256277d035260aca5aab17954b46104 WHIRLPOOL a27bee0e096e695ed4661c50f1ab2fb16e7012f96cc94baae8d5d67224e8b5dcbd869e5001b73fde4c9788f0fd87f85ff6caa3c5b95bae25f3005caed377451c
diff --git a/net-libs/libnfnetlink/libnfnetlink-1.0.1.ebuild b/net-libs/libnfnetlink/libnfnetlink-1.0.1.ebuild
new file mode 100644
index 000000000000..6ecd4d8e29e3
--- /dev/null
+++ b/net-libs/libnfnetlink/libnfnetlink-1.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit linux-info eutils
+
+DESCRIPTION="the low-level library for netfilter related kernel/userspace communication"
+HOMEPAGE="http://www.netfilter.org/projects/libnfnetlink/"
+SRC_URI="http://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE="static-libs"
+
+DOCS=( README )
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ if kernel_is lt 2 6 18 ; then
+ ewarn "${PN} requires at least 2.6.18 kernel version"
+ fi
+
+ #netfilter core team has changed some option names with kernel 2.6.20
+ error_common=' is not set when it should be. You can activate it in the Core Netfilter Configuration'
+ if kernel_is lt 2 6 20 ; then
+ CONFIG_CHECK="~IP_NF_CONNTRACK_NETLINK"
+ ERROR_IP_NF_CONNTRACK_NETLINK="CONFIG_IP_NF_CONNTRACK_NETLINK:\t${error_common}"
+ else
+ CONFIG_CHECK="~NF_CT_NETLINK"
+ ERROR_NF_CT_NETLINK="CONFIG_NF_CT_NETLINK:\t${error_common}"
+ fi
+
+ check_extra_config
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/net-libs/libnfnetlink/metadata.xml b/net-libs/libnfnetlink/metadata.xml
new file mode 100644
index 000000000000..03aa50bab7e3
--- /dev/null
+++ b/net-libs/libnfnetlink/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+</pkgmetadata>