summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-07-30 17:40:52 +0300
committerMart Raudsepp <leio@gentoo.org>2018-07-30 17:41:15 +0300
commit4bfca778cda9114f04914681e9a9257d6d294852 (patch)
tree40c158e22f5807f3ba9638fa912a7e7085a07dbc /net-libs/gupnp
parentnet-libs/gupnp: bump to 1.0.3 (diff)
downloadgentoo-4bfca778cda9114f04914681e9a9257d6d294852.tar.gz
gentoo-4bfca778cda9114f04914681e9a9257d6d294852.tar.bz2
gentoo-4bfca778cda9114f04914681e9a9257d6d294852.zip
net-libs/gupnp-1.0.3: py3 support and python-single-r1.eclass
Python is used for install gupnp-binding-tool /usr/bin utility, there's no point installing it for all python versions supported, even if more than one is supported, as there's no point for the /usr/bin wrapper. Use python-single-r1 properly instead. The package not working with python3 seems to be an old comment, and other distributions seem to use it fine, so support up to py3.6 as well as the single-target choice. I don't have 3.7 quite yet to test that. Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'net-libs/gupnp')
-rw-r--r--net-libs/gupnp/gupnp-1.0.3.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/net-libs/gupnp/gupnp-1.0.3.ebuild b/net-libs/gupnp/gupnp-1.0.3.ebuild
index 02c1369b6736..7d734ad14af9 100644
--- a/net-libs/gupnp/gupnp-1.0.3.ebuild
+++ b/net-libs/gupnp/gupnp-1.0.3.ebuild
@@ -3,11 +3,10 @@
EAPI="6"
VALA_USE_DEPEND="vapigen"
-# FIXME: Claims to works with python3 but appears to be wishful thinking
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
PYTHON_REQ_USE="xml"
-inherit gnome2 multilib-minimal python-r1 vala
+inherit gnome2 multilib-minimal python-single-r1 vala
DESCRIPTION="An object-oriented framework for creating UPnP devs and control points"
HOMEPAGE="https://wiki.gnome.org/Projects/GUPnP"
@@ -69,5 +68,5 @@ multilib_src_install() {
multilib_src_install_all() {
einstalldocs
- python_foreach_impl python_doscript tools/gupnp-binding-tool
+ python_fix_shebang "${ED}"/usr/bin/gupnp-binding-tool
}