summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-27 22:42:20 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-27 22:59:30 -0400
commit303f556c6c4ecaeac6bcddfa2976bde7b08d8925 (patch)
tree4f5662ecc88a868fda6ee6c70007b1a0a5a887fd /net-libs/gtk-vnc
parentgnome-base/gnome-session: Version bump to 40.1 (diff)
downloadgentoo-303f556c6c4ecaeac6bcddfa2976bde7b08d8925.tar.gz
gentoo-303f556c6c4ecaeac6bcddfa2976bde7b08d8925.tar.bz2
gentoo-303f556c6c4ecaeac6bcddfa2976bde7b08d8925.zip
net-libs/gtk-vnc: Version bump to 1.2.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-libs/gtk-vnc')
-rw-r--r--net-libs/gtk-vnc/Manifest1
-rw-r--r--net-libs/gtk-vnc/gtk-vnc-1.2.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/net-libs/gtk-vnc/Manifest b/net-libs/gtk-vnc/Manifest
index cd3ec8f77a9f..8145e4057993 100644
--- a/net-libs/gtk-vnc/Manifest
+++ b/net-libs/gtk-vnc/Manifest
@@ -1,2 +1,3 @@
DIST gtk-vnc-1.0.0-patchset.tar.xz 9636 BLAKE2B 4f25fdf279e5a1718ea8dc42bdb59722630b363e4e289704b946ae788d593b5d95c56d0eb5315e30ff00c2eb4d3a9e5df366f74808f94e926a47c2f817b0f1ee SHA512 998771ceb28516f52bb083d872a1ad8aa22a7208c8a0ca94270f63d91cc7f7a0f99c4bb93f7a545d9a6c796fa063dd27b36a1cb9a3d7c9349a9d8372754ea929
DIST gtk-vnc-1.0.0.tar.xz 215904 BLAKE2B 05ef0389c3ac307859228506adf55a5ed0f5d577078b82686ad97c9df180fc5c23d8dd030930c61f87b1bbd3cb6cee74c4485af4816b7b29fd53016c2d9b1d07 SHA512 63a40b9b284c4e46a92d5375ab3660b324ff27bfc572559d3b34d29fe4f7d24e976396b6688b8f3e3109d49dc5527075d128c43bb997507e68ddc0880b0ad148
+DIST gtk-vnc-1.2.0.tar.xz 218024 BLAKE2B 8e13886826eebc3261271b94e15c504f82b15681417e70cc6b54b824ceff4de20a470460c5176abb2df04f325389a08032f40b49cfc3429c290d6d7255fc56d2 SHA512 830c614afa6540397352da864ad32a5687ccce5dc1e2150220c9a7fc3c7b0fbcbb3770e06b5fed75602d830bc9a9d40855fa8b6d8b65f740fc7a53bbdfce6edb
diff --git a/net-libs/gtk-vnc/gtk-vnc-1.2.0.ebuild b/net-libs/gtk-vnc/gtk-vnc-1.2.0.ebuild
new file mode 100644
index 000000000000..5cd29c52ea67
--- /dev/null
+++ b/net-libs/gtk-vnc/gtk-vnc-1.2.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit gnome.org vala meson python-any-r1 xdg
+
+DESCRIPTION="VNC viewer widget for GTK"
+HOMEPAGE="https://wiki.gnome.org/Projects/gtk-vnc"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection pulseaudio sasl +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=dev-libs/glib-2.56.0:2
+ >=x11-libs/gdk-pixbuf-2.36.0:2
+ >=dev-libs/libgcrypt-1.8.0:0=
+ >=net-libs/gnutls-3.6.0:0=
+ >=sys-libs/zlib-1.2.11
+ sasl? ( >=dev-libs/cyrus-sasl-2.1.27 )
+ >=x11-libs/gtk+-3.22.0:3[introspection?]
+ >=x11-libs/cairo-1.15.0
+ >=x11-libs/libX11-1.6.5
+ pulseaudio? ( >=media-sound/pulseaudio-11.0 )
+ introspection? ( >=dev-libs/gobject-introspection-1.56.0:= )
+"
+# Keymap databases code is generated with python3; configure picks up $PYTHON exported from python-any-r1_pkg_setup
+# perl for pod2man
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-lang/perl-5
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+PATCHES=(
+ "${FILESDIR}"/1.0.0-honor-python-ver.patch
+)
+
+src_prepare() {
+ vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature introspection)
+ $(meson_feature pulseaudio)
+ $(meson_feature sasl)
+ -Dwith-coroutine=auto # gthread on windows, libc ucontext elsewhere; neither has extra deps
+ $(meson_feature vala with-vala)
+ )
+ meson_src_configure
+}