summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2024-08-28 12:15:40 +0300
committerArsen Arsenović <arsen@gentoo.org>2024-09-18 15:06:39 +0200
commitc98e5ce2ab7341b172ea7e63cb4ac0ae0c810f79 (patch)
treefc62b0619f2fe9e9cd6ab85ec38785ce412cb600 /net-irc
parentnet-irc/weechat: switch to new guile mechanism (diff)
downloadgentoo-c98e5ce2ab7341b172ea7e63cb4ac0ae0c810f79.tar.gz
gentoo-c98e5ce2ab7341b172ea7e63cb4ac0ae0c810f79.tar.bz2
gentoo-c98e5ce2ab7341b172ea7e63cb4ac0ae0c810f79.zip
net-irc/weechat: update live to use new guile mechanism
Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/weechat/weechat-9999.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/net-irc/weechat/weechat-9999.ebuild b/net-irc/weechat/weechat-9999.ebuild
index b35455cb8847..51c44dccd853 100644
--- a/net-irc/weechat/weechat-9999.ebuild
+++ b/net-irc/weechat/weechat-9999.ebuild
@@ -3,10 +3,11 @@
EAPI=8
+GUILE_COMPAT=( 2-2 3-0 )
LUA_COMPAT=( lua5-{1..4} )
PYTHON_COMPAT=( python3_{10..13} )
-inherit cmake lua-single python-single-r1 xdg
+inherit cmake guile-single lua-single python-single-r1 xdg
if [[ ${PV} == "9999" ]] ; then
inherit git-r3
@@ -36,6 +37,7 @@ IUSE="doc enchant man nls relay-api selinux test +zstd ${SCRIPT_LANGS} ${PLUGINS
REQUIRED_USE="
enchant? ( spell )
+ guile? ( ${GUILE_REQUIRED_USE} )
lua? ( ${LUA_REQUIRED_USE} )
python? ( ${PYTHON_REQUIRED_USE} )
test? ( nls )
@@ -49,7 +51,7 @@ RDEPEND="
sys-libs/zlib:=
net-misc/curl[ssl]
charset? ( virtual/libiconv )
- guile? ( >=dev-scheme/guile-2.0:12= )
+ guile? ( ${GUILE_DEPS} )
lua? ( ${LUA_DEPS} )
nls? ( virtual/libintl )
perl? (
@@ -90,6 +92,7 @@ DOCS="AUTHORS.md CHANGELOG.md CONTRIBUTING.md UPGRADING.md README.md"
RESTRICT="!test? ( test )"
pkg_setup() {
+ use guile && guile-single_pkg_setup
use lua && lua-single_pkg_setup
use python && python-single-r1_pkg_setup
}
@@ -97,6 +100,8 @@ pkg_setup() {
src_prepare() {
cmake_src_prepare
+ use guile && guile_bump_sources
+
# install only required translations
local i
for i in ${LANGS} ; do
@@ -185,3 +190,9 @@ src_test() {
die "required locale missing"
fi
}
+
+src_install() {
+ cmake_src_install
+
+ use guile && guile_unstrip_ccache
+}