summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Persson Forsberg <cat@catcream.org>2024-10-30 15:28:15 +0100
committerSam James <sam@gentoo.org>2024-10-30 15:10:49 +0000
commit521bd2bc26491f73dcb5e680116b0d247d960f12 (patch)
tree56a460ac7e18358b3cd48f9aa9464ed5c474ff7b /net-irc
parentsys-apps/systemd-utils: enable py3.13 (diff)
downloadgentoo-521bd2bc26491f73dcb5e680116b0d247d960f12.tar.gz
gentoo-521bd2bc26491f73dcb5e680116b0d247d960f12.tar.bz2
gentoo-521bd2bc26491f73dcb5e680116b0d247d960f12.zip
net-irc/soju: add tmpfiles.d config
Closes: https://bugs.gentoo.org/942477 Signed-off-by: Alfred Persson Forsberg <cat@catcream.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/soju/files/soju.tmpfiles1
-rw-r--r--net-irc/soju/soju-0.8.2-r1.ebuild (renamed from net-irc/soju/soju-0.8.2.ebuild)7
2 files changed, 7 insertions, 1 deletions
diff --git a/net-irc/soju/files/soju.tmpfiles b/net-irc/soju/files/soju.tmpfiles
new file mode 100644
index 000000000000..6280a148121c
--- /dev/null
+++ b/net-irc/soju/files/soju.tmpfiles
@@ -0,0 +1 @@
+d /run/soju 0750 soju soju
diff --git a/net-irc/soju/soju-0.8.2.ebuild b/net-irc/soju/soju-0.8.2-r1.ebuild
index f92c219dc9f1..0d8a5761bc01 100644
--- a/net-irc/soju/soju-0.8.2.ebuild
+++ b/net-irc/soju/soju-0.8.2-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit go-module systemd
+inherit go-module systemd tmpfiles
DESCRIPTION="soju is a user-friendly IRC bouncer"
HOMEPAGE="https://soju.im/"
@@ -61,6 +61,9 @@ src_install() {
doman doc/soju.1
doman doc/sojuctl.1
systemd_dounit contrib/soju.service
+
+ newtmpfiles "${FILESDIR}/soju.tmpfiles" soju.conf
+
keepdir /etc/soju
insinto /etc/soju
newins config.in config
@@ -69,6 +72,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process soju.conf
+
elog "${PN} requires a user database for authenticating clients."
elog "As the soju user, create a database using:"
elog "$ sojudb -config ${EROOT}/etc/soju/config create-user <username> [-admin]"