summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/pisg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/pisg')
-rw-r--r--net-irc/pisg/Manifest1
-rw-r--r--net-irc/pisg/metadata.xml8
-rw-r--r--net-irc/pisg/pisg-0.73-r1.ebuild52
3 files changed, 61 insertions, 0 deletions
diff --git a/net-irc/pisg/Manifest b/net-irc/pisg/Manifest
new file mode 100644
index 000000000000..b89369971623
--- /dev/null
+++ b/net-irc/pisg/Manifest
@@ -0,0 +1 @@
+DIST pisg-0.73.tar.gz 236539 SHA256 979efdd489114c10360dff9c7c8fdc287c126508e65790dfd0d0aa6fdf7d7c3b SHA512 290656fc556090fa8a263eaf123bad8e12b0ac50a2c1eb4619c50faf70fd3ee8afc7a8d97dbc4ff6338dd0fa9f73f7b19c60ca996b6612def95f1c494b3ef91e WHIRLPOOL a958d4b52fb0a09ca444878d1be27da55c1c584d5702cbdad7693d502d2aa01d1103eb1dbc1ee6276674d8bc785bb42e3088abce21efb3fd89f5b7a333cc9038
diff --git a/net-irc/pisg/metadata.xml b/net-irc/pisg/metadata.xml
new file mode 100644
index 000000000000..a41ad8725cbf
--- /dev/null
+++ b/net-irc/pisg/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-irc</herd>
+ <upstream>
+ <remote-id type="sourceforge">pisg</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-irc/pisg/pisg-0.73-r1.ebuild b/net-irc/pisg/pisg-0.73-r1.ebuild
new file mode 100644
index 000000000000..6a3228449803
--- /dev/null
+++ b/net-irc/pisg/pisg-0.73-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="Perl IRC Statistics Generator"
+HOMEPAGE="http://pisg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+
+IUSE=""
+
+RDEPEND="dev-perl/Text-Iconv"
+DEPEND=">=sys-apps/sed-4"
+
+src_prepare() {
+ sed -i \
+ -e 's!lang\.txt!/usr/share/pisg/lang.txt!' \
+ -e 's!layout/!/usr/share/pisg/layout/!' \
+ modules/Pisg.pm || die "sed failed"
+}
+
+src_compile() {
+ einfo "Nothing to compile"
+}
+
+src_install() {
+ perl_set_version
+
+ dobin pisg || die "dobin failed"
+
+ insinto "${VENDOR_LIB}"
+ doins -r modules/.
+
+ insinto /usr/share/pisg
+ doins -r gfx layout lang.txt
+
+ dodoc docs/{FORMATS,pisg-doc.txt} \
+ docs/dev/API pisg.cfg README
+ doman docs/pisg.1
+ dohtml docs/pisg-doc.html
+}
+
+pkg_postinst() {
+ einfo "The pisg images have been installed in /usr/share/pisg/gfx"
+}