summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-09-14 14:25:58 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-09-14 14:26:17 +0200
commitcca8253ed307de004120b6d94758d554be1c2d36 (patch)
treef5b9fc7556771e81f2e3ae10b20dbc3dd547ecb4 /net-im
parentsys-kernel/ugrd: del 1.19.4 (diff)
downloadgentoo-cca8253ed307de004120b6d94758d554be1c2d36.tar.gz
gentoo-cca8253ed307de004120b6d94758d554be1c2d36.tar.bz2
gentoo-cca8253ed307de004120b6d94758d554be1c2d36.zip
net-im/whatsie: add 4.15.5
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/whatsie/Manifest1
-rw-r--r--net-im/whatsie/whatsie-4.15.5.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/net-im/whatsie/Manifest b/net-im/whatsie/Manifest
index 9dc1f768cb93..102f0395e028 100644
--- a/net-im/whatsie/Manifest
+++ b/net-im/whatsie/Manifest
@@ -1,2 +1,3 @@
DIST whatsie-4.15.0.tar.gz 21146977 BLAKE2B fc8d3aba5776681efe761ce495419b793c54abd7bc1aadef2bbddb9356ccadfcd4b3937d5640e363e0fa5580a19fe4ea84e8d1d79ea44de5b1311d176d1b8495 SHA512 7e06a2ed60df8bd7714a2b768b05a2b6ff0038eb9b84b1c98977b99b48b0720837010df9adc37617102787dd86d51d6793bfa2b7c7fd0cc9e481a7585c7e7050
DIST whatsie-4.15.3.tar.gz 21139889 BLAKE2B 54576dfeeb527f801582ad2d94c24b5d5437ed15eca2b3a2dced73d026725f07eb52d1a837c307ee25cf20ac631a9dd2750f9577da580604da56bc5878462dbb SHA512 6bc493b050b4d092a9e075d399cea169873dba6ca4c8db925e3fab82b8c19074713828619a8f699c7917559f9eb052b13bc4935b7a376fcac3017988269014ec
+DIST whatsie-4.15.5.tar.gz 21405021 BLAKE2B 26151415d0669b011391b187a28f3ac32960c7db4bce05ba44fdee93680367e0cbee44c8087d95cabc92e1bc844c118c0a0d935a0733180d154646f75d62daa2 SHA512 1ede2a1dd95b010505b3a702e3730616cac619b2460b5935d6bf3eaf48183f4b2a8d66930990db0bf6f8aeec9649b66ea2865f7b8a386cc80c22f7cdf6515e5f
diff --git a/net-im/whatsie/whatsie-4.15.5.ebuild b/net-im/whatsie/whatsie-4.15.5.ebuild
new file mode 100644
index 000000000000..8919b85b6d47
--- /dev/null
+++ b/net-im/whatsie/whatsie-4.15.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils xdg
+
+DESCRIPTION="Qt Based WhatsApp Client"
+HOMEPAGE="https://github.com/keshavbhatt/whatsie"
+SRC_URI="https://github.com/keshavbhatt/whatsie/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P}/src"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+QT_MIN="5.15"
+
+DEPEND="
+ x11-libs/libX11
+ x11-libs/libxcb:=
+ >=dev-qt/qtcore-${QT_MIN}:5
+ >=dev-qt/qtgui-${QT_MIN}:5
+ >=dev-qt/qtnetwork-${QT_MIN}:5
+ >=dev-qt/qtpositioning-${QT_MIN}:5
+ >=dev-qt/qtwebengine-${QT_MIN}:5[widgets]
+ >=dev-qt/qtwidgets-${QT_MIN}:5
+"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ einstalldocs
+ INSTALL_ROOT="${ED}" emake install
+}