summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-03-01 19:38:22 +0100
committerDavid Seifert <soap@gentoo.org>2022-03-01 19:38:22 +0100
commitb42bb8fc61c5f13945391c804e877bc379493f69 (patch)
treec9d547a3251c670340107e88637f312d887704e4 /net-im/skypeforlinux
parentdev-util/FlameGraph: add 1.0_p20210830 (diff)
downloadgentoo-b42bb8fc61c5f13945391c804e877bc379493f69.tar.gz
gentoo-b42bb8fc61c5f13945391c804e877bc379493f69.tar.bz2
gentoo-b42bb8fc61c5f13945391c804e877bc379493f69.zip
net-im/skypeforlinux: add 8.81.0.268
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-im/skypeforlinux')
-rw-r--r--net-im/skypeforlinux/Manifest1
-rw-r--r--net-im/skypeforlinux/skypeforlinux-8.81.0.268.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/net-im/skypeforlinux/Manifest b/net-im/skypeforlinux/Manifest
index ba49ab9497cd..6176cb574784 100644
--- a/net-im/skypeforlinux/Manifest
+++ b/net-im/skypeforlinux/Manifest
@@ -2,3 +2,4 @@ DIST skypeforlinux_8.78.0.161-1.x86_64.rpm 123910012 BLAKE2B 560b9548f99d681c916
DIST skypeforlinux_8.79.0.92-1.x86_64.rpm 117949890 BLAKE2B a7150c362f117096d554c446357789f51595ff403061f81adf8be3e59452b7bf7970ff10e2fe31413f793a0a137f8f0822fd6710932e9aea2197959ef2976cfa SHA512 2094870f227acb7e0a24af4d96d39bc0cf94ea0d3e5fb5907c75ad0ff6704c55882b104a306ad5d1e350c4adf5fd4f0d8444a9ddb07d7a39ef79a8cacd7faf3d
DIST skypeforlinux_8.79.0.95-1.x86_64.rpm 118002157 BLAKE2B 0e836e3fd0c06bb5bd57d2806b3a51772e307a9555e573fdc366ebf1b82f2f8f1e422d64981f1973962d0ed1fa689c26482a48bf8193eedb65fe009056ff651c SHA512 eda292a1cd624c9a4819362820430769ead67f08113c66e58d6a4db17af4323f5483b6dadec41075b53feb25e7d7ef4c7ab738289246724678d2af9414fe58ad
DIST skypeforlinux_8.80.0.143-1.x86_64.rpm 118601687 BLAKE2B 8686eeb83a9e5df927a366cd05168224ac5869f83a11e59efb68af54f4c734b914e44f0993e3fa93b3b2e9749092063bdba77bb4fc4ce2dfedbddd523dc2617d SHA512 23c2a4db2831775bb20a709576319bdade0bc17d6e29af55a7953c54fdb626ec020066f5c54fbcb0d40aab534596ccb558211b76f2a656a9edc5daf49818e610
+DIST skypeforlinux_8.81.0.268-1.x86_64.rpm 140540850 BLAKE2B 5d6cca460c5ad663ba5ac90d3d22f7c7eab7869b6b34413de7e8a479d7461d8b7aa9112798722a38c6b9ed0bf0321a37300bf410fc123e0bb8c7164cb027b2a7 SHA512 e2b077cca85c9fdbdac7b50cbfe3fa5bb628c7321dc30d5d6eac5d3c8b83d2a365bbe226f33cf35d2e5614a1b48eb9971ada4c87b98dd161c985e99a5008a9c9
diff --git a/net-im/skypeforlinux/skypeforlinux-8.81.0.268.ebuild b/net-im/skypeforlinux/skypeforlinux-8.81.0.268.ebuild
new file mode 100644
index 000000000000..911974eaca88
--- /dev/null
+++ b/net-im/skypeforlinux/skypeforlinux-8.81.0.268.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit chromium-2 desktop pax-utils rpm multilib-build xdg
+
+DESCRIPTION="Instant messaging client, with support for audio and video"
+HOMEPAGE="https://www.skype.com/"
+SRC_URI="https://repo.skype.com/rpm/stable/${PN}_${PV}-1.x86_64.rpm"
+S="${WORKDIR}"
+
+LICENSE="Skype-TOS MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 Boost-1.0 ISC CC-BY-SA-3.0 CC0-1.0 openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+QA_PREBUILT="*"
+RESTRICT="mirror bindist strip" #299368
+
+RDEPEND="
+ app-crypt/libsecret[${MULTILIB_USEDEP}]
+ dev-libs/atk[${MULTILIB_USEDEP}]
+ dev-libs/expat[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr[${MULTILIB_USEDEP}]
+ dev-libs/nss[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
+ media-libs/freetype:2[${MULTILIB_USEDEP}]
+ media-libs/libv4l[${MULTILIB_USEDEP}]
+ net-print/cups[${MULTILIB_USEDEP}]
+ sys-apps/dbus[${MULTILIB_USEDEP}]
+ sys-devel/gcc[cxx]
+ sys-libs/glibc
+ virtual/ttf-fonts
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXScrnSaver[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libxcb[${MULTILIB_USEDEP}]
+ x11-libs/libxkbcommon[${MULTILIB_USEDEP}]
+ x11-libs/libxkbfile[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]"
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ rpm_src_unpack ${A}
+}
+
+src_prepare() {
+ default
+ sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EPREFIX}/opt/skypeforlinux/skypeforlinux!" \
+ -i usr/bin/skypeforlinux || die
+ sed -e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
+ -e "/^OnlyShowIn=/d" \
+ -i usr/share/applications/skypeforlinux.desktop || die
+}
+
+src_install() {
+ dodir /opt
+ cp -a usr/share/skypeforlinux "${ED}"/opt || die
+
+ # remove chrome-sandbox binary, users should use kernel namespaces
+ # https://bugs.gentoo.org/692692#c18
+ rm "${ED}"/opt/skypeforlinux/chrome-sandbox || die
+
+ dobin usr/bin/skypeforlinux
+
+ dodoc usr/share/skypeforlinux/*.html
+ dodoc -r usr/share/doc/skypeforlinux/.
+ # symlink required for the "Help->3rd Party Notes" menu entry (otherwise frozen skype -> xdg-open)
+ dosym ${PF} usr/share/doc/skypeforlinux
+
+ doicon usr/share/pixmaps/skypeforlinux.png
+
+ local res
+ for res in 16 32 256 512; do
+ newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
+ done
+
+ domenu usr/share/applications/skypeforlinux.desktop
+
+ pax-mark -m "${ED}"/opt/skypeforlinux/skypeforlinux
+ pax-mark -m "${ED}"/opt/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
+}