summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-07 11:02:24 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-07 11:03:57 +0100
commitbb9a5774f1bc70d9a2d4714f9316cf6cde0cd994 (patch)
tree8c32a7b07a17a4c5ebf6fed395a23c8ea0098611 /net-im/rocketchat-desktop-bin
parentmedia-video/droidcam: cleanup old (diff)
downloadgentoo-bb9a5774f1bc70d9a2d4714f9316cf6cde0cd994.tar.gz
gentoo-bb9a5774f1bc70d9a2d4714f9316cf6cde0cd994.tar.bz2
gentoo-bb9a5774f1bc70d9a2d4714f9316cf6cde0cd994.zip
net-im/rocketchat-desktop-bin: add version 3.7.0
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-im/rocketchat-desktop-bin')
-rw-r--r--net-im/rocketchat-desktop-bin/Manifest1
-rw-r--r--net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-im/rocketchat-desktop-bin/Manifest b/net-im/rocketchat-desktop-bin/Manifest
index 5c2a7918b353..3cce9b693702 100644
--- a/net-im/rocketchat-desktop-bin/Manifest
+++ b/net-im/rocketchat-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST rocketchat-3.6.0.x86_64.rpm 58643360 BLAKE2B 23e630112c8c28d39dbeb6824aa75d7289ad59e6cf061f2e61165511e2f57062832fb4ec64d9c985b1de94b0a28025b7f374d2a1428bc72eb6259f80cf79428d SHA512 8cc6b6842f9bdc3d13c4d293aa1aa75daba2bc66fab1262c051407fbe686fac1980e0abba3ccfa8d7cc6d96fc6391e24101b6baa9af3751edf4bf680968df142
+DIST rocketchat-3.7.0.x86_64.rpm 72048484 BLAKE2B c7f2d81df1cde64caf0699ac706891bd3d5bb38a976354abb344a6ea65f465fb32ceeb08c445621f5a65eda1b886b836520095ee295f7c1c6dd32ab498ea77ff SHA512 c4574520bdb60666eefde5899e304b65dc7cc9eb2cce7221d84cef6e3d003ecee0630c2175357591b5545d682be16c7bade490f37df86f80db1948c30a50e52c
diff --git a/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.0.ebuild b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.0.ebuild
new file mode 100644
index 000000000000..46fc3d26d958
--- /dev/null
+++ b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="The Ultimate Open Source Web Chat Platform"
+HOMEPAGE="https://rocket.chat"
+SRC_URI="https://github.com/RocketChat/Rocket.Chat.Electron/releases/download/${PV}/rocketchat-${PV}.x86_64.rpm"
+
+KEYWORDS="-* ~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/libappindicator
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/noto-emoji
+ media-libs/alsa-lib
+ net-print/cups
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+"
+
+QA_PREBUILT="/opt/Rocket.Chat/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ mv "${S}"/* "${ED}" || die
+}