summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-im/kadu
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-im/kadu')
-rw-r--r--net-im/kadu/Manifest2
-rw-r--r--net-im/kadu/files/kadu-2.1-qt5-compilation.patch11
-rw-r--r--net-im/kadu/kadu-0.12.3.ebuild98
-rw-r--r--net-im/kadu/kadu-2.1.ebuild145
-rw-r--r--net-im/kadu/metadata.xml17
5 files changed, 273 insertions, 0 deletions
diff --git a/net-im/kadu/Manifest b/net-im/kadu/Manifest
new file mode 100644
index 000000000000..a50a33da2f97
--- /dev/null
+++ b/net-im/kadu/Manifest
@@ -0,0 +1,2 @@
+DIST kadu-0.12.3.tar.bz2 5106482 SHA256 d607bbd0d00b01bfb70dd15f15c8be4076896a935041651e67a3887ad12ab8a8 SHA512 0aeaec9ac3ce5a1860571721e307a8d5e6657a30780125e21d153901ce5f2870ba3ea6ebc272bbb6f35a56ed9a24127abfc8f25b9eb88d01ecf9c931fa5c851c WHIRLPOOL 0a2b1b9684577d95027b9107fc51e8a8f290b7ed38a18bf282f9589eb3dd5ca7a9fa61b088e2fb2be8d4d16e6d4e72d766476e36f7d65cc55a2d5efae53bb8ca
+DIST kadu-2.1.tar.bz2 6013519 SHA256 9f8092756d4a870c1ecb016c0cba2c833e1697b3eb7e9bf51813b1f0a541ffb8 SHA512 3f0e38aefbaf15f357ae8232b1364deb5954a2464895fafa0a324ad99c7d14c6ba7495bed51d628e04c30bbaaf8e49412c70bbbbf01a40f360406c1afba2384a WHIRLPOOL 10b214ca8d1964054918dc0e1b85bf1157d2496e3ad340958302083a0374ac4fb7b6ac96741637f3847ac06dd9c322b0e529f9c204b9ebc6658157f7b7c2b8a2
diff --git a/net-im/kadu/files/kadu-2.1-qt5-compilation.patch b/net-im/kadu/files/kadu-2.1-qt5-compilation.patch
new file mode 100644
index 000000000000..68120a4ede0e
--- /dev/null
+++ b/net-im/kadu/files/kadu-2.1-qt5-compilation.patch
@@ -0,0 +1,11 @@
+diff -ruN kadu-2.1/kadu-core/os/single-application/single-application.cpp my/kadu-core/os/single-application/single-application.cpp
+--- kadu-2.1/kadu-core/os/single-application/single-application.cpp 2015-03-24 22:13:18.000000000 +0100
++++ my/kadu-core/os/single-application/single-application.cpp 2015-07-05 21:08:09.044685214 +0200
+@@ -26,6 +26,7 @@
+ #include "long-lived-lock-file.h"
+
+ #include <QtCore/QCoreApplication>
++#include <QtCore/QDataStream>
+ #include <QtCore/QDir>
+ #include <QtCore/QRegExp>
+ #include <QtNetwork/QLocalServer>
diff --git a/net-im/kadu/kadu-0.12.3.ebuild b/net-im/kadu/kadu-0.12.3.ebuild
new file mode 100644
index 000000000000..5eb83a8ef69b
--- /dev/null
+++ b/net-im/kadu/kadu-0.12.3.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit base cmake-utils flag-o-matic
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="An open source Gadu-Gadu and Jabber/XMPP protocol Instant Messenger client"
+HOMEPAGE="http://www.kadu.net"
+SRC_URI="http://download.kadu.im/stable/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86"
+SLOT="0"
+IUSE="ayatana +gadu mpd phonon sdk speech spell xmpp"
+REQUIRED_USE="
+ || (
+ gadu
+ xmpp
+ )
+"
+COMMON_DEPEND="
+ app-crypt/qca:2[qt4(+)]
+ x11-libs/libX11
+ x11-libs/libXfixes
+ x11-libs/libXScrnSaver
+ >=dev-qt/qtdbus-4.7.0:4
+ >=dev-qt/qtgui-4.7.0:4
+ >=dev-qt/qtscript-4.7.0:4
+ >=dev-qt/qtsql-4.7.0:4[sqlite]
+ >=dev-qt/qtwebkit-4.7.0:4
+ ayatana? ( dev-libs/libindicate-qt )
+ gadu? (
+ >=net-libs/libgadu-1.11.1[threads]
+ >=dev-qt/qtxmlpatterns-4.7.0:4
+ )
+ mpd? ( media-libs/libmpdclient )
+ phonon? (
+ || (
+ media-libs/phonon[qt4]
+ >=dev-qt/qtphonon-4.7.0:4
+ )
+ )
+ spell? ( app-text/enchant )
+ xmpp? (
+ net-dns/libidn
+ sys-libs/zlib
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ x11-proto/fixesproto
+ x11-proto/scrnsaverproto
+ x11-proto/xproto
+"
+RDEPEND="${COMMON_DEPEND}
+ app-crypt/qca:2[openssl]
+ >=dev-qt/qtsvg-4.7.0:4
+ speech? ( app-accessibility/powiedz )
+"
+
+PLUGINS='amarok1_mediaplayer antistring auto_hide autoaway autoresponder autostatus cenzor chat_notify config_wizard desktop_docking docking encryption_ng encryption_ng_simlite exec_notify ext_sound falf_mediaplayer filedesc firewall freedesktop_notify hints history idle imagelink last_seen mediaplayer mprisplayer_mediaplayer pcspeaker qt4_docking qt4_docking_notify screenshot simpleview single_window sms sound sql_history tabs word_fix'
+
+src_configure() {
+ # Filter out dangerous flags
+ filter-flags -fno-rtti
+ strip-unsupported-flags
+
+ # Ensure -DQT_NO_DEBUG is added
+ append-cppflags -DQT_NO_DEBUG
+
+ # Plugin selection
+ if use gadu; then
+ PLUGINS+=' gadu_protocol history_migration profiles_import'
+ fi
+
+ use mpd && PLUGINS+=' mpd_mediaplayer'
+ use xmpp && PLUGINS+=' jabber_protocol'
+ use phonon && PLUGINS+=' phonon_sound'
+ use speech && PLUGINS+=' speech'
+ use spell && PLUGINS+=' spellchecker'
+
+ # Configure package
+ local mycmakeargs=(
+ -DBUILD_DESCRIPTION='Gentoo Linux'
+ -DCOMPILE_PLUGINS="${PLUGINS}"
+ -DNETWORK_IMPLEMENTATION="Qt"
+ -DSIG_HANDLING_ENABLED=TRUE
+ $(cmake-utils_use sdk INSTALL_SDK)
+ $(cmake-utils_use_with ayatana INDICATE_QT)
+ $(cmake-utils_use_with spell ENCHANT)
+ )
+ unset PLUGINS
+
+ cmake-utils_src_configure
+}
diff --git a/net-im/kadu/kadu-2.1.ebuild b/net-im/kadu/kadu-2.1.ebuild
new file mode 100644
index 000000000000..c743349bc1e7
--- /dev/null
+++ b/net-im/kadu/kadu-2.1.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit base cmake-utils flag-o-matic
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="An open source Gadu-Gadu and Jabber/XMPP protocol Instant Messenger client"
+HOMEPAGE="http://www.kadu.net"
+SRC_URI="http://download.kadu.im/stable/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="+gadu mpd otr phonon sdk speech spell xmpp"
+REQUIRED_USE="
+ || (
+ gadu
+ xmpp
+ )
+"
+COMMON_DEPEND="
+ app-crypt/qca:2[openssl,qt5]
+ >=dev-libs/injeqt-1.0.0
+ >=dev-qt/qtcore-5.2.0:5
+ >=dev-qt/qtdbus-5.2.0:5
+ >=dev-qt/qtgui-5.2.0:5
+ >=dev-qt/qtmultimedia-5.2.0:5
+ >=dev-qt/qtnetwork-5.2.0:5
+ >=dev-qt/qtquick1-5.2.0:5
+ >=dev-qt/qtscript-5.2.0:5
+ >=dev-qt/qtsql-5.2.0:5
+ >=dev-qt/qtsvg-5.2.0:5
+ >=dev-qt/qtwebkit-5.2.0:5
+ >=dev-qt/qtwidgets-5.2.0:5
+ >=dev-qt/qtx11extras-5.2.0:5
+ >=dev-qt/qtxml-5.2.0:5
+ >=dev-qt/qtxmlpatterns-5.2.0:5
+ >=app-arch/libarchive-2.6[lzma]
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXScrnSaver
+ gadu? ( >=net-libs/libgadu-1.11.1[threads] )
+ mpd? ( media-libs/libmpdclient )
+ otr? (
+ >=dev-libs/libgcrypt-1.2.2:0
+ >=net-libs/libotr-4.1.0
+ )
+ phonon? (
+ || (
+ media-libs/phonon[qt5]
+ >=dev-qt/qtphonon-4.7.0:4
+ )
+ )
+ spell? ( app-text/enchant )
+ xmpp? (
+ net-dns/libidn
+ sys-libs/zlib
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-qt/linguist-tools-5.2.0:5
+ x11-proto/scrnsaverproto
+ x11-proto/xextproto
+ x11-proto/xproto
+"
+RDEPEND="${COMMON_DEPEND}
+ speech? ( app-accessibility/powiedz )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-qt5-compilation.patch"
+)
+
+PLUGINS='
+antistring
+auto_hide
+autoaway
+autoresponder
+autostatus
+cenzor
+chat_notify
+config_wizard
+desktop_docking
+docking
+emoticons
+encryption_ng
+encryption_ng_simlite
+exec_notify
+ext_sound
+falf_mediaplayer
+filedesc
+firewall
+freedesktop_notify
+hints
+history
+idle
+imagelink
+last_seen
+mediaplayer
+mprisplayer_mediaplayer
+pcspeaker
+qt4_docking
+qt4_docking_notify
+screenshot simpleview
+single_window
+sms
+sound
+sql_history
+tabs
+word_fix
+'
+
+src_configure() {
+ # Filter out dangerous flags
+ filter-flags -fno-rtti
+ strip-unsupported-flags
+
+ # Ensure -DQT_NO_DEBUG is added
+ append-cppflags -DQT_NO_DEBUG
+
+ # Plugin selection
+ use gadu && PLUGINS+=' gadu_protocol history_migration profiles_import'
+ use mpd && PLUGINS+=' mpd_mediaplayer'
+ use otr && PLUGINS+=' encryption_otr'
+ use phonon && PLUGINS+=' phonon_sound'
+ use speech && PLUGINS+=' speech'
+ use spell && PLUGINS+=' spellchecker'
+ use xmpp && PLUGINS+=' jabber_protocol'
+
+ # Configure package
+ local mycmakeargs=(
+ -DBUILD_DESCRIPTION='Gentoo Linux'
+ -DCOMPILE_PLUGINS="${PLUGINS}"
+ -DNETWORK_IMPLEMENTATION="Qt"
+ $(cmake-utils_use sdk INSTALL_SDK)
+ $(cmake-utils_use_with spell ENCHANT)
+ )
+ unset PLUGINS
+
+ cmake-utils_src_configure
+}
diff --git a/net-im/kadu/metadata.xml b/net-im/kadu/metadata.xml
new file mode 100644
index 000000000000..d54eca9f9ee3
--- /dev/null
+++ b/net-im/kadu/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-im</herd>
+ <maintainer>
+ <email>reavertm@gentoo.org</email>
+ <name>Maciej Mrozowski</name>
+ </maintainer>
+ <use>
+ <flag name="gadu">Enables Gadu communication protocol</flag>
+ <flag name="mpd">Enables Music Player Daemon support</flag>
+ <flag name="otr">Enable char encryption via OTR library</flag>
+ <flag name="phonon">Enables phonon audio plugin</flag>
+ <flag name="sdk">Install Kadu SDK (cmake module, API headers)</flag>
+ <flag name="speech">Enables speech module</flag>
+ </use>
+</pkgmetadata>