summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2023-03-21 09:28:16 +0000
committerSam James <sam@gentoo.org>2023-03-22 05:46:07 +0000
commit26ce492ae2ba61b6e6e0a36d70f83653dc014b4f (patch)
treec7767b5dbd15c9ed6c708a58367ab5a79a7c00f7 /net-im/dino
parentnet-im/dino: remove dependency on gspell (diff)
downloadgentoo-26ce492ae2ba61b6e6e0a36d70f83653dc014b4f.tar.gz
gentoo-26ce492ae2ba61b6e6e0a36d70f83653dc014b4f.tar.bz2
gentoo-26ce492ae2ba61b6e6e0a36d70f83653dc014b4f.zip
net-im/dino: drop 0.4.0
0.4.1 works fine. Signed-off-by: Michael Vetter <jubalh@iodoru.org> Closes: https://github.com/gentoo/gentoo/pull/30279 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-im/dino')
-rw-r--r--net-im/dino/dino-0.4.0-r1.ebuild92
1 files changed, 0 insertions, 92 deletions
diff --git a/net-im/dino/dino-0.4.0-r1.ebuild b/net-im/dino/dino-0.4.0-r1.ebuild
deleted file mode 100644
index b2932f67878a..000000000000
--- a/net-im/dino/dino-0.4.0-r1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake vala xdg readme.gentoo-r1
-
-DESCRIPTION="Modern Jabber/XMPP Client using GTK+/Vala"
-HOMEPAGE="https://dino.im"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="+gpg +http +omemo +notification-sound test"
-RESTRICT="!test? ( test )"
-
-MY_REPO_URI="https://github.com/dino/dino"
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="${MY_REPO_URI}.git"
- inherit git-r3
-else
- KEYWORDS="~amd64 ~arm64"
- SRC_URI="${MY_REPO_URI}/releases/download/v${PV}/${P}.tar.gz"
-fi
-
-RDEPEND="
- dev-db/sqlite:3
- dev-libs/glib:2
- dev-libs/icu:=
- dev-libs/libgee:0.8=
- gui-libs/gtk:4
- >=gui-libs/libadwaita-1.2.0:1
- net-libs/glib-networking
- >=net-libs/libnice-0.1.15
- net-libs/libsignal-protocol-c
- net-libs/libsrtp:2
- x11-libs/cairo
- x11-libs/gdk-pixbuf:2
- x11-libs/pango
- gpg? ( app-crypt/gpgme:= )
- http? ( net-libs/libsoup:2.4 )
- notification-sound? ( media-libs/libcanberra:0[sound] )
- omemo? (
- dev-libs/libgcrypt:=
- media-gfx/qrencode:=
- )
-"
-DEPEND="
- ${RDEPEND}
- media-libs/gst-plugins-base
- media-libs/gstreamer
-"
-BDEPEND="
- sys-devel/gettext
- $(vala_depend)
-"
-
-src_configure() {
- vala_setup
-
- # TODO: Make videocalls (rtp) optional and not completely disable it
- local disabled_plugins=(
- $(usex gpg "" "openpgp")
- $(usex omemo "" "omemo")
- $(usex http "" "http-files")
- "rtp"
- )
- local enabled_plugins=(
- $(usex notification-sound "notification-sound" "")
- )
- local mycmakeargs=(
- "-DENABLED_PLUGINS=$(local IFS=";"; echo "${enabled_plugins[*]}")"
- "-DDISABLED_PLUGINS=$(local IFS=";"; echo "${disabled_plugins[*]}")"
- "-DVALA_EXECUTABLE=${VALAC}"
- "-DBUILD_TESTS=$(usex test)"
- )
-
- cmake_src_configure
-}
-
-src_test() {
- "${BUILD_DIR}"/xmpp-vala-test || die
-}
-
-src_install() {
- cmake_src_install
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- readme.gentoo_print_elog
-}