summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Fore <csfore@posteo.net>2023-11-25 10:49:16 -0500
committerJoonas Niilola <juippis@gentoo.org>2024-01-27 10:49:27 +0200
commitfcf1b8dd56c1a793c0017161160638678c436f24 (patch)
treed223b8a2606202a7067ab0a5597ea3064465738d /net-dns
parentmail-filter/spamassassin: Fix script output when amavisd is disabled (diff)
downloadgentoo-fcf1b8dd56c1a793c0017161160638678c436f24.tar.gz
gentoo-fcf1b8dd56c1a793c0017161160638678c436f24.tar.bz2
gentoo-fcf1b8dd56c1a793c0017161160638678c436f24.zip
net-dns/fpdns: add 20190131
Closes: https://bugs.gentoo.org/677038 Signed-off-by: Christopher Fore <csfore@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/33981 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/fpdns/Manifest1
-rw-r--r--net-dns/fpdns/fpdns-20190131.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/net-dns/fpdns/Manifest b/net-dns/fpdns/Manifest
index d49483f1e17b..2ff396154d77 100644
--- a/net-dns/fpdns/Manifest
+++ b/net-dns/fpdns/Manifest
@@ -1 +1,2 @@
DIST fpdns-0.10.0_pre20130404.tar.gz 931723 BLAKE2B cab459afee74ef5d8163a25b98c123b799270e6d3293f155a340ebdbfbc86266fbffa999d31928c9b1a732898b0adf4a49e97469f9ae992a0e38f9478431e84c SHA512 1a4d9c1cb666efa3f48dcca2b5cd04793e92727359652095572b17479f5343479c57d2937f1fff8070c071a2698eda5c4dff981caf86436f184f0b076b0fa0b3
+DIST fpdns-20190131.tar.gz 933415 BLAKE2B 58208f9b1c1204a9cddcc390a8814158b0cbd5ed958c1b4d30588d2bc422c20047732b47a0358484dc21b255e67f2b312dd3af82e8ec52253345651d8c38fa67 SHA512 cde6e3ae9661b82456b65e1b309c1190b63b83406fcc75971b2903d7b38a16cf46b2e2c3d9b3f577c20a8f7ffc077243414fc5e53bed962c85512e2ea6aec15b
diff --git a/net-dns/fpdns/fpdns-20190131.ebuild b/net-dns/fpdns/fpdns-20190131.ebuild
new file mode 100644
index 000000000000..b556dd7766a9
--- /dev/null
+++ b/net-dns/fpdns/fpdns-20190131.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+DESCRIPTION="Fingerprinting DNS servers"
+HOMEPAGE="https://github.com/kirei/fpdns/"
+SRC_URI="https://github.com/kirei/fpdns/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-perl/Net-DNS-0.74"
+
+src_install() {
+ dobin apps/fpdns
+ insinto "${VENDOR_LIB}"/Net/DNS/
+ doins lib/Net/DNS/Fingerprint.pm
+}