summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-03-23 07:56:14 -0400
committerMichael Orlitzky <mjo@gentoo.org>2024-03-23 08:01:19 -0400
commitc2477a76b1edeb7bec683b4f924b16ff53a6798f (patch)
tree55454ed43779bc0c983185ae507645a7a0bd3a0b /net-dns/djbdns
parentdev-python/types-psutil: Remove old (diff)
downloadgentoo-c2477a76b1edeb7bec683b4f924b16ff53a6798f.tar.gz
gentoo-c2477a76b1edeb7bec683b4f924b16ff53a6798f.tar.bz2
gentoo-c2477a76b1edeb7bec683b4f924b16ff53a6798f.zip
net-dns/djbdns: hide -Wincompatible-pointer-types problems
This is the worst solution to this problem, but our djbdns package isn't djbdns at all, it's twenty patches in a trenchcoat. Maintenance for things like this typically comes in the form of yet more downstream patches, but invasive patches are essentially blocked by the fact that they introduce conflicts with the others. There is at least one big patch, the ipv6 patch, that is maintained by someone else, so it's not as simple as basing all new patches on top of the old ones. For lack of a better solution, we append -Wno-error for this warning. Closes: https://bugs.gentoo.org/927539 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'net-dns/djbdns')
-rw-r--r--net-dns/djbdns/djbdns-1.05-r39.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/net-dns/djbdns/djbdns-1.05-r39.ebuild b/net-dns/djbdns/djbdns-1.05-r39.ebuild
index 77ba586d70d9..9b70fbb959bb 100644
--- a/net-dns/djbdns/djbdns-1.05-r39.ebuild
+++ b/net-dns/djbdns/djbdns-1.05-r39.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit readme.gentoo-r1 toolchain-funcs
+inherit flag-o-matic readme.gentoo-r1 toolchain-funcs
DESCRIPTION="Collection of DNS client/server software"
HOMEPAGE="https://cr.yp.to/djbdns.html"
@@ -81,6 +81,10 @@ src_prepare() {
}
src_compile() {
+ # Bug 927539. This is beyond our ability to realistically fix due
+ # to patch conflicts.
+ append-cflags $(test-flags-CC -Wno-error=incompatible-pointer-types)
+
echo "$(tc-getCC) ${CFLAGS}" > conf-cc || die
echo "$(tc-getCC) ${LDFLAGS}" > conf-ld || die
echo "/usr" > conf-home || die